-   SUSE / openSUSE (
-   -   Burning CDs w/SuSE & IDE CDRW (

tmeehan 08-20-2005 09:28 PM

Burning CDs w/SuSE & IDE CDRW
When I try to use K3B in SuSE 9.3 with my IDE CD-RW, the application hangs on the splash screen and I get this in /var/log/messages:

Aug 20 18:37:05 linux kernel: cdrom: This disc doesn't have any tracks I recognize!
Aug 20 18:39:32 linux kernel: hdc: DMA interrupt recovery
Aug 20 18:39:32 linux kernel: hdc: lost interrupt
Aug 20 18:39:32 linux kernel: hdc: status timeout: status=0xd0 { Busy }
Aug 20 18:39:32 linux kernel: ide: failed opcode was: unknown
Aug 20 18:39:32 linux kernel: hdc: DMA disabled
Aug 20 18:39:32 linux kernel: hdc: drive not ready for command
Aug 20 18:39:32 linux kernel: hdc: ATAPI reset complete
Aug 20 18:39:32 linux kernel: cdrom_pc_intr, write: dev hdc: flags = REQ_STARTED REQ_PC REQ_QUIET
Aug 20 18:39:32 linux kernel: sector 0, nr/cnr 0/0
Aug 20 18:39:32 linux kernel: bio 00000000, biotail 00000000, buffer 00000000, data 00000000, len 0
Aug 20 18:39:32 linux kernel: cdb: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
Aug 20 18:39:32 linux kernel: hdc: cdrom_pc_intr: The drive appears confused (ireason = 0x02)
Aug 20 18:40:32 linux kernel: hdc: lost interrupt

The same block of messages are logged repeatedly until I reboot. I've had this same problem under Mandrake/Mandriva since they went to the 2.6 kernel. The same system worked fine under previous Redhat and Mandrake kernels (and under Windows 98 SE). On Mandrake 10.2, Nautilus CD Burner worked, so I had a work around.

Since moving to SuSE 9.3, neither has worked. Nautilus reports that the CD has data written to it already, but that's not the case...I've tried multiple brands of blank CDs. Specifically, the dialog window reports:

Insert blank disc
Please put a blank disc, with at least 1MiB free, into the drive.
Cancel Retry

Nautilus logs nothing to /var/log/messages.

Here's what I get from "cdrecord -scanbus dev=ATAPI:"

linux:~ # cdrecord -scanbus dev=ATAPI:
Cdrecord-Clone 2.01 (i686-suse-linux) Copyright (C) 1995-2004 Jörg Schilling
Note: This version is an unofficial (modified) version
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to <URL removed to post>
Note: The author of cdrecord should not be bothered with problems in this version.
scsidev: 'ATAPI:'
devname: 'ATAPI'
scsibus: -1 target: -1 lun: -1
Warning: Using ATA Packet interface.
Warning: The related Linux kernel interface code seems to be unmaintained.
Warning: There is absolutely NO DMA, operations thus are slow.
Using libscg version 'schily-0.8'.
cdrecord: Warning: controller returns wrong size for CD capabilities page.
0,0,0 0) 'Lite-On ' 'LTN483S 48x Max ' 'PD02' Removable CD-ROM
0,1,0 1) 'LG ' 'CD-RW CED-8080B ' '1.07' Removable CD-ROM
0,2,0 2) *
0,3,0 3) *
0,4,0 4) *
0,5,0 5) *
0,6,0 6) *
0,7,0 7) *
linux:~ #

I've searched for answers, but found little. It seems the kernel is dropping support for the SCSI emulator for IDE devices, and the CD burning packages haven't quite caught up.

It also appears that others have had similar flaky issues with IDE CD-RW devices and few have had follow-up solutions.

Any help is appreciated.

smannell 08-21-2005 02:19 PM

Can you read data and/or play music CDs from this device? Have you tried burning a data CD from the command line? I haven't had any serious issues with my LiteOn DVD Rom/CD Burner in 9.3 using K3B or the command line tools, so I don't think the problem is due to dropping SCSI emulation from the kernel; but I could be wrong. Are you sure it isn't a hardware problem? I know you said the drive worked before, but maybe it recently screwed up. You might try another IDE CD drive if you have one laying around or can borrow one. Have you tried starting K3B without any disc in the drive, or is this when you get your error?

tmeehan 08-22-2005 09:59 PM

The LiteOn device is just a CD-ROM drive. The LG device is the CD-RW drive.

I put a known good music CD into the LG CD-RW and KsCD started, but indicateed that the status was "ejected". despite being closed. When I pressed the Eject button in KsCD, it showed a status of "closing", but did nothing. So I exited KsCD.

I moved the music CD to the LiteOn CD-ROM and it played with KsCD. Since both drives use the same IDE channel and controller (hdc and hdd), that rules out a number of things in the OS and the IDE controller.

So it would seem to the be something specific with the CD-RW drive.

At the moment, I don't have any spare drives or systems to test with. I also only have SuSE loaded, so testing with an alternate OS will be time consuming.

I appreciate the reply.

smannell 08-23-2005 12:40 PM

It sounds like a hardware issue, but it is hard to know for sure. You might try another application to play a music CD in the LG device, or see if you can read a data CD with it. Have you checked the HCL (hardware compatibility list) to see if there are any known issues with the LG device you have?

tmeehan 08-24-2005 11:38 PM

I generally agree...something goofy going on.

Checked the HCL...only one post from over a year ago...tested mostly OK on 2.4 kernel (Debian), but some issue burning music CDs.

Took a suggestion from guy at work and put the CD-RW as first in IDE chain. It now plays the music CD and can read files off CD, but same problem when using burning software.

I'm still able to play music CDs in CD-ROM.

Only things that appears goofy are the symlinks in /dev:
lrwxrwxrwx 1 root root 3 Aug 24 22:27 cdrecorder -> hdd
lrwxrwxrwx 1 root root 3 Aug 24 22:27 cdrom -> hdc

The cdrecorder is actually hdc now, and the cdrom is hdd. Not sure I want to tinker with those as they appear to have been automagically generated (they have today's date).

I'll be traveling over the next week, so it maybe some time before I get back to this :)

Again, thanks for the suggestions.

J.W. 08-25-2005 12:56 AM

Try burning via the command line

cdrecord -v speed=16 dev=0,1,0 -data <filename>
Note that according to your "cdrecord -scanbus" output, your CD-RW is at 0,1,0 rather than 0,0,0 so you need to specify that (also change the speed parameter to match your equipment, although 16X is as fast as I ever burn) Can't say that would make any difference, but I'd at least give it a try.

Another random thought, are the CD drives jumpered correctly? Good luck with it -- J.W.

tmeehan 09-02-2005 08:32 PM

Both the CD-ROM and CD-RW are jumpered as "cable select". That had previously worked under Windows98SE, RedHat 9.0, and Mandrake 9.2 (2.4 kernels). So I'm assuming it "should" still work.

I first ran the cdrecord command with the -dummy option just to test it. As mentioned previously, I changed the order of the devices on the IDE chain/channel so that the CD-RW is now 0,0,0. My CD-RW is only 4x, so reduced the speed too:
<code>cdrecord -dummy -v speed=4 dev=0,0,0 -data file</code>

That seemed to work (no errors). Then I ran it without the -dummy and it worked...?!

cdrecord: No write mode specified.
cdrecord: Asuming -tao mode.
cdrecord: Future versions of cdrecord may have different drive dependent defaults.
cdrecord: Continuing in 5 seconds...
Cdrecord-Clone 2.01 (i686-suse-linux) Copyright (C) 1995-2004 Jörg Schilling
Note: This version is an unofficial (modified) version
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to --URL--
Note: The author of cdrecord should not be bothered with problems in this version.
TOC Type: 1 = CD-ROM
cdrecord: Operation not permitted. WARNING: Cannot set RR-scheduler
cdrecord: Permission denied. WARNING: Cannot set priority using setpriority().
cdrecord: WARNING: This causes a high risk for buffer underruns.
cdrecord: Warning: not running as root user, fs= option ignored.
scsidev: '0,0,0'
scsibus: 0 target: 0 lun: 0
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version ( '@(#)scsi-linux-sg.c 1.83 04/05/20 Copyright 1997 J. Schilling').
SCSI buffer size: 64512
atapi: 1
Device type : Removable CD-ROM
Version : 0
Response Format: 1
Vendor_info : 'LG '
Identifikation : 'CD-RW CED-8080B '
Revision : '1.07'
Device seems to be: Generic mmc CD-RW.
Using generic SCSI-3/mmc CD-R/CD-RW driver (mmc_cdr).
Driver flags : MMC SWABAUDIO
Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R RAW/R16 RAW/R96P RAW/R96R
Drive buf size : 1024000 = 1000 KB
Drive DMA Speed: 117294 kB/s 666x CD 84x DVD
FIFO size : 4194304 = 4096 KB
Track 01: data 0 MB padsize: 570 KB
Total size: 0 MB (00:04.02) = 302 sectors
Lout start: 1 MB (00:06/02) = 302 sectors
Current Secsize: 2048
ATIP info from disk:
Indicated writing power: 6
Is not unrestricted
Is not erasable
Disk sub type: Medium Type C, low Beta category (C-) (6)
ATIP start of lead in: -11231 (97:32/19)
ATIP start of lead out: 359846 (79:59/71)
Disk type: Short strategy type (Phthalocyanine or similar)
Manuf. index: 27
Manufacturer: Prodisc Technology Inc.
Blocks total: 359846 Blocks current: 359846 Blocks remaining: 359544
Starting to write CD/DVD at speed 4 in real TAO mode for single session.
Last chance to quit, starting real write 0 seconds. Operation starts.
Waiting for reader process to fill input buffer ... input buffer ready.
Performing OPC...
Starting new track at sector: 0
Track 01: 0 of 0 MB written.
WARNING: padding up to secsize.
Track 01: writing 570 KB of pad data.
Track 01: Total bytes read/written: 29046/614400 (300 sectors).
Writing time: 13.091s
Average write speed 0.3x.
Fixating time: 63.758s
cdrecord: fifo had 1 puts and 1 gets.
cdrecord: fifo was 0 times empty and 0 times full, min fill was 100%.

So it seems the command line version (cdrecord) works, but the two GUI CD burning tools (K3B & GNOME CD/DVD Creator) do not. That suggests it's not a SCSI emulation issue and the search goes on...grrr.

Thanks JW

smannell 09-03-2005 07:17 AM

At least now you know where to look. Search the K3B site for known bugs, and you can always try different versions of both software tools. Good luck.

All times are GMT -5. The time now is 03:43 AM.