-   SUSE / openSUSE (
-   -   Build symlink missing (

Bobo7581 12-03-2004 12:43 PM

Build symlink missing
I have tried to install some ipw2200 drivers for my wireless card and when i run make, the console reports:

/lib/modules/2.6.5-7.111.5-default/build: No such file or directory.

as an error....

I understand that this is some kind or link to another place "/usr/src/<kernal name>" where in "/usr/src/" i have only...


When i double-click on build it says "file:/lib/modules/2.6.5-7.111.5-default/build doesn't seem to exist anymore"

doesn't anyone know where build is supposed to link to and how i can sort it out.


abisko00 12-03-2004 01:22 PM

I would assume that you didn't install the kernel sources. These are needed by the driver to compile.

You may install them via Yast. Search for the package 'kernel-source'. Make sure that the output of uname -r and the version of the sources (rpm -q kernel-source) are the same. It may be necessary to run an online update to install matching sources.

Bobo7581 12-08-2004 07:54 AM


I installed the kernel-source using Yast, but it installed kernel-source-2.6.4-52 and i'm using kernel 2.6.5-7.111.5-default, found by uname -r...

so i tried what you said and did an update via Yast which was unsucessful, it simply kept the same sources, no new updates were reported for the kernel-source..

so i looked on the web for an rpm and found a site offering the particular 2.6.5-7.111.5 rpm. I downloaded this and tried installing it from Yast, i.e. using the button displayed in konquerer when an rpm is downloaded and also downloaded it seperatley and tried using the command rpm... Tried installing it with -i and using --replacepkgs and --replacefiles as well...

Still only have kernel-source- installed when listed from rpm -qa and only folder in /usr/src/...

Am i doing anything wrong ??? (I think a previous Yast update took my kernel from to 2.6.5-7.111.5, so probs why its giving me those sources, however the build link obs points to /usr/src/kernel-source-2.6.5-7.111.5-obj/...)


abisko00 12-08-2004 08:20 AM

This sounds rather strange. Let's check it systematically:


user@linux:~> rpm -q kernel-default
user@linux:~> rpm -q kernel-source
user@linux:~> uname -r

Do you get the same from these commands?

Did you run Yast -> Software -> Online Update after you installed the kernel-source package?
You may need to select the package to reinstall manually. Select from the 'Show Patch Category' tab 'Installable and Installed Patches' and select 'The Linux Kernel on x86 architecture'. The green 'recycle' symbol should appear.

Otherwise download this and install it with
rpm -Uhv kernel-source-2.6.5-7.111.5.i586.rpm

Bobo7581 12-08-2004 12:52 PM


I managed to get the right kernel-source and built the correct drivers...
Now i just have a problem connect to the net from my wireless card, i don't know if you know anything about this but basically I'm trying to use my intel PRO/Wireless 2200BG card...

I have download and installed...
- Kernel-default-2.6.5-7.111.5
- Kernel-source-2.6.5-7.111.5
- ipw2200-0.15 drivers
- ipw2200-fw-2.0 firmware update
- wireless_tools 27 wireless tools

I followed the instructions in the INSTALL document on the ipw2200 sourceforge page, however i can't seem to access the internet....

Looking through the suse hardware pannel, and it lists "Intel® PRO/Wireless 2200BG" under the Network Controller menu, and when i check the details it says...

Available Yes
Configured No

and under the Driver tab...

Driver Info #0:
Driver Status: ipw2200 is active
Driver Activation Cmd:"modprobe ipw2200"

I also ran "iwconfig eth1" to check and it came up with

eth1 IEEE 802.11b ESSID:"default"
Mode:Managed Channel:6 Access Point: 00:0D:88:E2:AE:BE
Bit Rate=11 Mb/s Tx-Power=20 dBm
RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality:40/100 Signal level:-23 dBm Noise level:-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:325 Missed beacon:3

Am i doing anything wrong, do i have to configure any files ?

Thanx for any help

All times are GMT -5. The time now is 12:26 PM.