-   SUSE / openSUSE (
-   -   Boot Help Please? (

noasprin 09-15-2008 07:28 PM

Boot Help Please?

I have a Dell Latitude c400 laptop with 256mb ram, no CD cable or drive, only a 20gb internal and USB ability. I was able to install the Live version of OpenSuSE 11 with KDE 4 on the internal 20gb hd via usb cable from another computer. It installed fine on there but when I put it back in the laptop it wants to still see the hard drive by /dev/disk/by-id/USB etc etc: part0:0 etc etc/ (sorry about the device id etc's but I've since changed them to reflect the hardware I have on the laptop). The USB subsystem will start up and look for /dev/sda1 as root and /dev/sda2 as swap from a 4gb USB stick. The internal hd is using the older /dev/hda1 and /dev/hda2 names. I changed the menu.lst on physical /dev/hda1 to point it at /dev/hda1 and 2. When I boot now, it will pull up the USB subsystem 1st and say that /dev/hda1 and 2 not found. When it gets to that point it asks if I want to fall back to /dev/sda1? If I say yes, it will boot to the USB stick just fine, and as it boots it finally sees the ide subsystem and sees /dev/hda1 and 2, but only after the USB subsystem comes up.

Enough of the confusing info, simply put, I want to know how to force the IDE subsystem come up first so it will boot to /dev/hda1. Is there a way to change the init order of USB and IDE subsystem? I have looked all over the place and I can't seem to find it anywhere, at least with my search words. I've even tried rootdelay=30 or 60, and it still wont get past the USB subsystem before it asks if I want to fall back to /dev/sda1.

I've even gone as far as copying /dev/.udev and a few other directories and files from the /dev/sda1 and didn't hurt but didn't get me anywhere either. Lucky too, I was expecting all kinda errors from that.

Please help me figure this out. It's driving me nuts, and I don't need any help there... I have two kids for that.

/dev/sda1 NO, /dev/hda1 YES. Boot init order IDE 1st, USB 2nd.

Thanks for your help folks, I know the answer is out there in someones amazing geek brain.

htnakirs 09-16-2008 04:41 AM

Opensuse, I think, doesn't have an hdx notation, only sdx. All hard disks are sdx. So the int. hard disk would be sda, and the USB probably sdb or vice versa.
Also changing the grub's menu.lst file would only be the first step, since the fstab file also will have to be modified to reflect the changed notations.

davesny 09-16-2008 09:55 PM


In the older versions of SuSE the names of the partitions were; hda1, hda2, hda5, etc. I think it changed with SuSE 10.2 where the partitions are named as sda1, sda2, sda5, etc.
If I understand the problem correctly you will need to open Yast, then go to System, then open your Boot Loader. In the second tab you will want to select the option to start from the MBR, and save it. I hope this helps.


noasprin 09-16-2008 11:28 PM

Thanks for the replies. I understand that the naming convention changed in the newer versions, but as the hard drive is actually physically listed in the fstab and /dev , it is /dev/hda1 and /dev/hda2.

I tried the chroot to the other system and yast2 from there to change the boot setup, but it still sees the USB subsystem first, then the IDE subsystem. I'm sure if I could install ON the laptop itself it would show the devices as /dev/hda1 and /dev/hda2. I can only guess it's because its an older laptop (Dell Latitude c400).

All times are GMT -5. The time now is 04:50 AM.