LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 12-19-2005, 01:47 PM   #1
mardek01
LQ Newbie
 
Registered: Dec 2005
Posts: 1

Rep: Reputation: 0
black screen, cant repair with yast or sax


I am almost giving up. installed suse linux 10 on my via epia M10000 and all seemed to go very well. good. But on logging in for the first time my screen got black. Then I tried to start yast in failsafe. when entering the item "hardware>monitor and video" I also got an black screen. Then I tried to run sax2 (as some postings on the internet suggest). The same happened, a black screen. I can get back by ctrl-alt-F1 and then a ctrl-C.

Can anyone help me on how to fix my settings for my videocard/monitor.

Thanks,
 
Old 12-19-2005, 03:19 PM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian stable
Posts: 5,908

Rep: Reputation: 356Reputation: 356Reputation: 356Reputation: 356
I recently wanted to change my monitor config. Used Sax to select one of the pre-configured settings. Sax rejected my every effort. I got errors about 'mode not supported'. When I selected one that was not in the pre-configured group, it worked just fine. Go figure.

Try this on boot. When grub comes up, add this to the boot prompt (you should see it under the menu of OSs to boot). If not, press the letter e to edit the kernel parameters. Add this to the prompt: vga=791. Its the code for 1280x1024 resolution for 16 bit graphics. If you have your system setup for 24 bit graphics, use vga=792.

If all goes well, you won't see the black screen, and you can use Sax to change the default setting.
 
Old 12-20-2005, 04:29 AM   #3
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: Ubuntu
Posts: 3,513

Rep: Reputation: 58
If the above doesn't help, try to start sax2 with the driver specified. Should look like 'sax2 -m 0=via-drv' (maybe via_drv).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
I messed with the screen resolution and now Redhat will boot into a black screen! Mr. Hill Linux - Newbie 29 05-04-2009 12:52 PM
screen saver goes off and screen goes black Doug.Gentry SUSE / openSUSE 2 03-26-2005 06:08 PM
Startx results in a black screen with VGA and screen errors kwosource Linux - Newbie 4 03-11-2005 03:58 PM
MDK 9.2: X freezes with a black screen or blue screen with "X cursor" Apoc Linux - Newbie 10 03-30-2004 04:38 PM
MDK 9.2: X freezes on a black screen or blue screen with "X cursor" Apoc Linux - Software 1 12-29-2003 04:56 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 09:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration