-   SUSE / openSUSE (
-   -   apt4suse errors (

dastardly 01-28-2007 10:32 AM

apt4suse errors
Im trying to install apt on suse 10.2, but when I run apt4suse I get this:


# install-apt4suse
Setup apt for SuSE Linux 10.2 on i386...

Downloading apt and apt-libs packages...
No such directory `pub/linux/suse/apt/SuSE/10.2-i386/RPMS.suser-rbos'.

unlink: No such file or directory
No such directory `pub/linux/suse/apt/SuSE/10.2-i386/RPMS.suser-rbos'.

unlink: No such file or directory

error: File not found by glob: /tmp/apt-*
package apt-libs is not installed
Package apt-libs is not installed
Im a complete nix noob, so I saw that there was a few changes. Also at bottom of wiki there was a note


I found that easier than following the instructions above, just run YAST and install Apt from there.
But I couldnt figure out how to install apt from yast either. Anyone know whats up?

colucix 01-28-2007 10:45 AM

To install via YAST, open YAST from Applications -> System in the main menu. Open Software Management, wait for a couple of minutes (it ownloads catalogs from repositories) and search for apt. Then check the square near apt and apt-libs and click on Accept. YAST should take care of the installation process eventually including all the dependencies.

dastardly 01-28-2007 11:01 AM

apt and apt-libs didnt show up, only apt4yast.

colucix 01-28-2007 01:00 PM

You probably don't have a complete OS source from which to download the suse packages. You can add a source from YAST. Open "Installation Source", choose a Mirror from here and add it to the list of repositories. To do this in the Installation Source click on add, when you are prompted for "Media Type" click on ftp. In the next screen fill in the "Server Name" and "Directory Name" fields. For example:

Server Name:
Directory Name: pub/
Click on next and wait for the process to complete. When you have done, you will be able to find the apt related packages with Software Management. Please note, in this case the apt package are available under a OSS installation repository. You may find useful also to add a NON-OSS installation repository and an UPDATE too.

dastardly 01-28-2007 03:39 PM

Ty, worked perfectly :)

fallen3019 05-06-2007 07:41 AM

I too am having a simimlar problem with apt...

when I use apt, it would not find the command, so I tried to install it, using the same command

# install-apt4suse
it would also not find the install command

So I tried with YAST2, I added the Mirror
and I tried to search for apt and it would not find it.

Is there something I am missing? and is there something wrong if bash is not even fining 'install'?

cormack 05-09-2007 07:54 AM


yast -i apt4suse

Also you will most likely need a space between install -apt4suse, and will possibly not even need the -. I have never personally used 'install' but you may not even have that programme installed? If you definatly added the repo correctly and it tries and updates when you start the software managment. Is it 10.2 or 10.2 you are both using?

Probably be better off googleing for another repo that hosts apt4suse then try adding that one.



fallen3019 05-10-2007 04:49 PM

I solved my problem,

I had to


install install-apt4suse


All times are GMT -5. The time now is 02:53 PM.