-   SUSE / openSUSE (
-   -   Apple Trackpad and DVD drive on suse 12.1 (

combrains 03-09-2012 07:01 PM

Apple Trackpad and DVD drive on suse 12.1
Hi All,

I have managed to get openSUSE 12.1 installed onto MacBook pro (mid 2011) Model identifier 8,1.

Most things seem to be working OK except for the wifi, DVD drive and (of course) click-and-drag functions on the trackpad (as the new Apple trackpads have no discrete button)

Has anyone had any success in getting any of the above to work?

I have read on a few places around the web that support for some of the newer Apple HW was introduced in kernel 3.2. and 3.3. I'd like to avoid having to compile a custom kernel but if push comes to shove I will have to. (the default kernel in 12.1 is 3.1)

I can provide any logs, HWinfo etc needed if this helps anyone.

Many thanks

[update] updated the kernel from the factory repo from version 3.1.x to 3.2.x series. DVD drive now working OK. Also looks like support for the particular Broadcom WIFI chipset in these models will be part of kernel 3.3 so looks like I'll have to wait for the good guys at the SUSE project to provide a pre-copiled RPM or compile a vanilla kernel myself :S.

Still no luck with the trackpad. Anyone have any luck with that?

combrains 03-14-2012 11:21 PM

Bump! :)

Knightron 03-16-2012 09:19 AM

The track-pad is currently the only issue left? Which desktop environment are you using?

combrains 03-18-2012 12:07 AM

I'm currently using Gnome 3.

As I said, once the new mainline kernel goes stable, it will have drivers for the WIFI (so, technically it's still not working, but I know what the fix is)

I am able to click and drag with one finger on the trackpad without any issues. But this is difficult given that the button on the Apple trackpads is bottom-centre.

I had a thought the other day that, all the trackpad driver would need to do to resolve this is be able to detect a pinch gesture but, if the button is pressed, ignore the finger that is not moving.

If anyone has any solutions for me to try, I'd be willing to test. BTW, is this sort of detection done at kernel or X level?


Knightron 03-18-2012 06:18 AM

it's working so the kernel knows it's there. X is responsible for getting it to function the way you desire. I don't use gnome3, so you're lucky i had it on my Frugalware distribution. I've booted up Frugalware. Here's what you should try. open the activities menu; click Applications; On the right hand side there's a menu. Down close to the bottom of the menu is System Tools, click that. In the list of applications, there's one called system settings, open that. There a tool called, 'Mouse and Touchpad' open that. in the tool, open the touchpad tab.
Now, i have a 7.1 mac, and i don't think the trackpad has changed since, so here's what you'd need to do. Mark a tick on 'Disable touchpad while typing'; make sure there's no tick on 'Enable mouse clicks with touchpad'. Under scrolling, change it to, 'Two-finger-scrolling'. The horizontal scrolling is up to you.
That should do it. I hope that has helped.

All times are GMT -5. The time now is 12:48 PM.