Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
SUSE / openSUSE This Forum is for the discussion of Suse Linux.


  Search this Thread
Old 01-12-2007, 10:24 AM   #1
LQ Newbie
Registered: Jan 2007
Location: Mandan, ND
Distribution: SuSE
Posts: 2

Rep: Reputation: 0
Exclamation Apache 2 will not Restart on a particular SuSE 9 server.

We have strange thing happening on a freshly installed and patched server. Apache 2 will come up on boot, but then after that, it will not start again if for some reason it is stopped. We have hundreds of similar installs and have never had a problem, but something is a little different on this one.

Here is the error that we get in the error_log when it tries to restart:
[emerg] (38)Function not implemented: Couldn't create accept lock

And here are the versions:
SUSE LINUX Enterprise Server 9 (x86_64)

Any help would be appreciated.
Leif E. Olson
Systems Engineer
Old 01-16-2007, 01:06 PM   #2
Registered: Nov 2006
Location: Seattle, WA
Distribution: Fedora
Posts: 407

Rep: Reputation: 35
A search on Google for your error message turned up some build issues, but
they appeared to cough up the "(38)Function not implemented" immediately on
startup. Since your server starts up on boot just fine, but fails to restart,
I would suspect a problem with file permissions (probably on the mutex lockfile).
Check where your configuration puts that lockfile, and then check that the user/group
that is used by apache has permission to write (delete) that lockfile and recreate
it the next time it starts.

Old 01-16-2007, 04:50 PM   #3
LQ Newbie
Registered: Jan 2007
Location: Mandan, ND
Distribution: SuSE
Posts: 2

Original Poster
Rep: Reputation: 0
Apache 2 problem seems to be SSL related.

Thanks for your reply. I had already done much Googling as well before posting and seen those same comments. Many saying link this or that when compiling or recompiling your Kernel with IPC, but since we are using stock packaged things that worked else where, and it works on boot, I figured that was not the case.
I looked into the Mutex settings we are using the:
SSLMutex sem
setting by default which I assume means it is just setting a semaphore somewhere and not creating an actual file.
I switched it to:
SSLMutex file:/var/lib/apache2/ssl_mutex
and made sure the path and perms were good just for kicks, but unfortunately I got the same result and error message.
I even tried switching it to
SSLMutex none
which is also supported but not recommended and I still got the same error message.

The problem does, however, definately seem to br related to SSL because if I disable SSL, apache 2 will start up just fine, but this is not acceptable as we need SSL.

So, anyone have any other ideas?



apache, suse

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help with HTTP Server and Apache on Suse 9.3 ksmith65 Linux - Networking 2 01-10-2006 06:55 PM
how do i apache restart? einstien Linux - General 3 03-30-2005 01:22 PM
Apache can't restart Serbulent Linux - Enterprise 2 03-16-2005 02:29 AM
To install Apache server on SuSe sumi SUSE / openSUSE 1 01-16-2005 06:15 AM
How do I restart Apache? 360 Linux - Networking 2 08-25-2001 06:26 PM > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 07:19 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration