LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 07-16-2005, 04:43 AM   #1
Master_Simon
Member
 
Registered: Jun 2005
Location: SE England
Distribution: Latest foray is the Fedora world
Posts: 46

Rep: Reputation: 15
Unhappy Another SUSE 9.3 , KDE resolution problem


Folks
I am a LINUX nube as far as this level of support is concerned, I have been using an older version for sometime with no problems what so ever, until i upgrade to 9.3 pro.
It installed fine, with everything detected as I required, I installed the nvidia driver from the YOU list ( well the script did it ), and have since tried to set up the KDE resolution, this appears to be stuck at 1280 resolution, which wouldn't be so much of an issue except it will not fill the screen of the monitor, the monitor is at it's maximum width settings, this is only in the X settings, the boot up texts etc are all on the screen as i would expect. I've tried using the SAX2 utility as others have said here but it does not make any difference, i tried the hack on the Xorg config file as suggested here and wonder if I have not saved this to the right place, I am now stuffed as I can only get to the command line, it errors when i try to start x.
If anyone can help me here I would be very grateful, but i will need the complete dummies guide, although I am not totally new to the LINIX idea I have never needed to get this deep into any part of it.

To reitterate I have tried the other thread's suggestions and have found no joy, unless I have incorrectly saved config file.

Kind regards
Simon
 
Old 07-16-2005, 04:47 AM   #2
Master_Simon
Member
 
Registered: Jun 2005
Location: SE England
Distribution: Latest foray is the Fedora world
Posts: 46

Original Poster
Rep: Reputation: 15
Sorry missed off some detail there.

The monitor is a Compaq P700, 17" CRT
The graphics card is TNT ultra 32meg
The CPU is the Athlon 900 irongate slotted jobbie
128 meg ram
SUSE 9.3 pro as per their suggestions, with the suggested updates
Previously installed and working on this set up SUSE 7.2 Pro and
9.1 Personal both worked and displayed fine so i wonder if this is a
KDE issue?

Cheers
Simes
 
Old 07-17-2005, 03:19 AM   #3
Master_Simon
Member
 
Registered: Jun 2005
Location: SE England
Distribution: Latest foray is the Fedora world
Posts: 46

Original Poster
Rep: Reputation: 15
Thanks for all the replies (sic)

Despite the overload of replies I managed to sort this one, it required the actual monitor settings to be manually set, right down to the actual screen size in mm.

Given the level of problems this seems to cause, and once you know what to search on the resolution is easy to find, I am suprised this has not been stickied, it was using the forum the old fashioned way that I managed to cure this, and after reading about 5 threads it became apparent I was not searching on the right subject.

Maybe the day was too nice yesterday to bother posting replies, it would have taken one guru a quick one liner to point me in the right direction

Anyway I am now running 9.3 and am as happy as I was with 7.2 and 9.1 previously.

 
Old 07-17-2005, 04:21 PM   #4
A6Quattro
Member
 
Registered: Jul 2005
Location: SE, PA
Distribution: Fedora Core 3, Suse 9.3 pro(if I can get the NIC's working!!!)
Posts: 111

Rep: Reputation: 15
I'm not sure if I am having the same problem as you but here is my situation which is EXTREMELY frustrating. I get throught the install of 9.2 and it configures the username and password and then the install is finished. It reloads everything with theh new configuration settings and then the screen goes blank. My LCD comes up with a box that says:

Attention
Signal Frequency
Is Out of Range
H:03.1Khz
V: 59.2 Hz
Please change
Signal timing

That is it. I can't do anything else. The same type of thing happened to me when I installed 9.3. On my other boxes (which have a different brand LCD) I can't even get to the graphical install in 9.2 and 9.3 because it says something that the resolution is not correct (1280x1024) which is what itt says on the bottom of the install screen (F2) key. No matter what mode I put it in I have problems with this.

Can you help out at all? Is this what you were experiencing?
 
Old 07-17-2005, 04:36 PM   #5
AdamCo
Member
 
Registered: Aug 2004
Distribution: Suse 10
Posts: 126

Rep: Reputation: 15
A6Quattro, you need to find out the Horizontal and Vertical sync frequencies of your monitor and then either go into init 3 and manually edit your xf86config file and add these values under monitor where it says something like HorizSync and VertRefresh, change the values to those of your monitor. or you can do it with Sax2 i believe. It will be a range of values, for example for my monitor the values are:

Horizontal: 30-82
Vertical: 50-75

Before you begin the graphical install, try changing the resolution to 1024x768.

Last edited by AdamCo; 07-17-2005 at 05:01 PM.
 
Old 07-19-2005, 05:14 AM   #6
Master_Simon
Member
 
Registered: Jun 2005
Location: SE England
Distribution: Latest foray is the Fedora world
Posts: 46

Original Poster
Rep: Reputation: 15
sounds like it

This sounds exactly like the problem I was plagued with, but on an LCD monitor you'd have the out of range errors you are seeing, this is because the monitor has a native resolution and cannot resolve anything above this. Not too sure how you can sort this without access to a crt type monitor that can display at that resolution. I was lucky mine is a quite high end compaq jobbie, if it had been my old one it wouldn't have worked at all.

I had to enter in the exact screen dimensions, this along with the line and frame frequency has cure my problem.

Sorry can't think of anything else constructive, I mean reitterating the config stuff on a monitor that is out of range alarming..............

rgds
Simon
 
Old 07-19-2005, 02:01 PM   #7
girlboxer5
Member
 
Registered: Jun 2005
Location: San Fran, CA
Distribution: SuSE 9.3/Ubuntu/WinXP
Posts: 48

Rep: Reputation: 15
Quote:
That is it. I can't do anything else. The same type of thing happened to me when I installed 9.3. On my other boxes (which have a different brand LCD) I can't even get to the graphical install in 9.2 and 9.3 because it says something that the resolution is not correct (1280x1024) which is what itt says on the bottom of the install screen (F2) key.
Weird, you can't install in text mode (it's hiding under VESA/ the F2 key)? I've had funky resolution problems as well (screen would go dark and then have blobules of gray at the top of the screen when it booted into the YaST installer), but once I found out I could go into text to install on 9.3, I was pretty much home free, beyond trying to adjust the monitor settings in KDE which kept defaulting to 1280x1024. I had to adjust the resolution by right-clicking on the KDE desktop and picking the "screen" menu item-- the only place in KDE where you can adjust monitor settings graphically, including refresh rates.

I've had pretty good luck just hitting the "auto" button on my monitor if the display came up a little "off" on the edges (it's been pretty frequent in Ubuntu). The monitor's own internal mechanism adjusts pretty well to what a distro throws at it, and fine-tunes the display.

'Course, non of this rambling probably helps at all... Sorry
 
Old 07-22-2005, 05:55 PM   #8
Master_Simon
Member
 
Registered: Jun 2005
Location: SE England
Distribution: Latest foray is the Fedora world
Posts: 46

Original Poster
Rep: Reputation: 15
QUOTE "Weird, you can't install in text mode (it's hiding under VESA/ the F2 key)? I've had funky resolution problems as well (screen would go dark and then have blobules of gray at the top of the screen when it booted into the YaST installer), but once I found out I could go into text to install on 9.3, I was pretty much home free, beyond trying to adjust the monitor settings in KDE which kept defaulting to 1280x1024. I had to adjust the resolution by right-clicking on the KDE desktop and picking the "screen" menu item-- the only place in KDE where you can adjust monitor settings graphically, including refresh rates.

I've had pretty good luck just hitting the "auto" button on my monitor if the display came up a little "off" on the edges (it's been pretty frequent in Ubuntu). The monitor's own internal mechanism adjusts pretty well to what a distro throws at it, and fine-tunes the display.

'Course, non of this rambling probably helps at all... Sorry ? "/QUOTE



Hey don't knock your effort, what you say is relevant, the problem appears to be KDE defaulting to 1280 x 1024 and LCDs with a lower native reolution cannot resolve this, a crt can if you have a magnifying glass to read the resultant scripts, as for catching on what the normal text says, if you're a nube then................erm dunno??
 
Old 07-22-2005, 07:30 PM   #9
Maldain
Member
 
Registered: Jan 2005
Posts: 112

Rep: Reputation: 15
Had this same problem with 9.2 pro

I had this same problem with 9.2 pro and a 19 in gateway monitor. It seemed that both the horizontal and vertical refresh rates were set 5MhZ too high. Once i dropped them down in the X config files the system came right up. I installed off the dvd and that was the only problem I had with the installation.

M. Lacy
Western Tool Supply
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem setting resolution in KDE supertoad Linux - Newbie 3 11-25-2005 09:01 PM
Resolution in KDE 3.4, SuSE 10.0, Not Above 1024x768 frenchrh SUSE / openSUSE 2 10-18-2005 08:26 AM
Crazy KDE Resolution Problem Corallis Linux - Newbie 3 07-10-2004 05:30 AM
resolution change in KDE SUSE 8 jfranks214 Linux - General 1 03-23-2004 11:03 PM
KDE 3.0 Screen Resolution problem dai Linux - General 4 09-05-2002 04:09 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 11:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration