LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 07-09-2007, 05:28 AM   #1
ukkaapie
LQ Newbie
 
Registered: Jul 2007
Posts: 2

Rep: Reputation: 0
Angry Adding service in /etc/init.d


Hi,

I am using SUSE 10.1 and am having a bit of problem trying to get Apache 2.2.4 to load upon startup. This is not the apache that comes with the distro but the source download from Apaches' website.

I have tried by running the httpd -k command in /etc/init.d/boot.local, xinetd and system services but all of them try to load before the network has loaded which results in apache not being able to start because it is unable to bind to an ip address.

If I add apache to xinetd at runlevel 5 it adds the service at S01 prefix at which point I rename it to S07 prefix which is after the network is loaded but this does not change the order as shown in the boot.msg file.

How do I get apache to start up with the operating system correctly. I can manually start apache successfully using either "httpd -k" or "apachectl start".

I've been trying for days to get this up and running and numberous amount of searching on the net but no go. Any help would be greatly appreciated.

Thanks

Shane

Last edited by ukkaapie; 07-09-2007 at 05:30 AM.
 
Old 07-09-2007, 08:36 AM   #2
bsdunix
Senior Member
 
Registered: May 2006
Distribution: Caldera, CTOS, Debian, FreeBSD, Mac OS X, Mandrake, OpenBSD, Slackware, Solaris, SuSE, Xubuntu
Posts: 1,757

Rep: Reputation: 80
See if what was discussed in this thread helps you:

create a line automatically at every reboot
http://www.linuxquestions.org/questi...06#post2701806
 
Old 07-09-2007, 09:45 AM   #3
ukkaapie
LQ Newbie
 
Registered: Jul 2007
Posts: 2

Original Poster
Rep: Reputation: 0
Re: Adding service in /etc/init.d

Thank you so much for that. That has worked brilliantly.

It would be interesting to find out why the service was added before networking and why when it was moved down the list to S07 that it still ran as if it were in S01...

Anyways, thanks again... much appreciated...

Shane
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
cannot start /etc/init.d/novell-ZMD service sirray100 SUSE / openSUSE 0 08-21-2006 05:09 AM
init.d service start Question casentm Fedora 2 03-20-2005 09:23 PM
service squid.init stop says [failed] Niceman2005 Linux - Software 2 11-16-2004 07:20 PM
Difference between init.d, xinetd and running service as a dameon jstephens84 Linux - Newbie 1 09-13-2004 07:19 PM
Service Shutdown and Init Setup g_goblin Solaris / OpenSolaris 1 10-29-2003 04:53 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 04:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration