-   SUSE / openSUSE (
-   -   ACPI issue on IBM thinkpad r40e (

SmellyLlama 04-07-2005 10:41 AM

ACPI issue on IBM thinkpad r40e

I recently installed SuSe linux 9.2 professional from a DVD, after having given up trying to get gentoo working.

I am running an IBM thinkpad r40e, model number 2684-QVG. The processor is an Intel Pentium 4-m 2.2 GHz.

My problem is that ACPI hangs my system. The error occurs when the ACPI modules are switched on, at the processor module. Booting with "ACPI=OFF" works just fine, but I'd like to get acpi up and running.

While running Gentoo, I fixed the bug by compiling the kernel without processor management, following a guide located at (i removed the http prefix since I am prohibited from posting urls)

My question is: Is there a way to disable processor management without recomiling the kernel? The reason I would prefer another method is that I don't want to compile the kernel every time it gets updated...

Any help would be appreciated.

osbie 04-07-2005 12:08 PM


In Yast, go to System-/ect/sysconfig on the left are expandable choices. if it's just the freq. scaling thats the prob. go to 'system->powermanagement->CPU and in the first option "powersave_cpufreq_module" type 'off' .

the other choice is to go to, (in the same place but ACPID instead of powersave) ->general->ACPI_modules- you'll see the list of modules it will load, just remove 'processor' from the list.

reboot with acpi enabled.

SmellyLlama 04-07-2005 03:20 PM

Still not working...
Thank you for the hint osbie, it was quite obvious, wasn't it? :D

Yet the trouble is, this didn't change anything. My system still tried to load the processor module...
Why is this?

SmellyLlama 04-12-2005 11:37 AM

Ok, I fixed it
I got tired of not having any acpi, so I recompiled the kernel without processor management.

wazz72 04-18-2005 07:04 AM

ACPI Problem
I have had the same problem with an r40e, but have never been able to fix it, Iv'e never recompiled the kernel before. Is there any guide to doing this available, as not having any power managment on my laptop is driving me mad.


All times are GMT -5. The time now is 03:16 PM.