-   SUSE / openSUSE (
-   -   9.3- yast online update shows 'unknown' for product and version (

prkix 09-17-2005 04:45 AM

9.3- yast online update shows 'unknown' for product and version
I installed Suse 9.3 on this Compaq Armada m700 notebook. Things work really well, except YaST online update.

Here is what 'uname' shows.
# uname -a
Linux linux #1 Wed Mar 23 21:52:37 UTC 2005 i686 i686 i386 GNU/Linux

When I start yast2 and click on "Online Update', it shows
System Information:
Product: unknown
Version: unknown

I configured /etc/youservers with an HTTP server for getting patches. In order for online_update command to work, I MUST give "-a i386' and '-v 9.3'. Otherwise, "online_update" picks up 9.2 version number and it fails.

I am able to successfully download and even install the patches manually. I am wondering if anyone has ran into and solved that problem with Yast.

Yast2 does not know how to get the version number eventhough uname works fine. I am assuming it does not know how to get the architecture either.
If I specify
in /etc/youservers. YaST shows the location, but it is unable to find the patches that are there in that directory.

# cat SuSE-release
SuSE Linux 9.3 (i586)

Any help is greatly appreciated.

prkix 09-17-2005 01:21 PM

A few other posts pointed to the fix! The explanation is at

I did the following for my system and YaST2 shows correct product name and OS version.

# cd /var/adm/YaST
# cp InstSrcManager/IS_CACHE_0x00000001/DATA/descr/default* SelDB
# cp InstSrcManager/IS_CACHE_0x00000001/DESCRIPTION/description ProdDB/prod_00000001

- prkix

Runlevel51 11-12-2005 04:54 PM


your post gave me the right tip to solve the same problem for 9.3>10.0
it only works if you have only one entry in /var/adm/YaST/ProdDB/
so after I deleted my backup of the original file it worked.

I wrote about it in detail here:

cu, Frank

All times are GMT -5. The time now is 09:36 PM.