LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 08-21-2006, 03:36 AM   #1
noir911
Member
 
Registered: Apr 2004
Posts: 682

Rep: Reputation: Disabled
[Suse] nagios upgrade problem


I am trying to upgrade my nagios plugins on Suse Enterprise Server 9.

Code:
./configure --with-openssl=yes --exec-prefix=/home/me/nagios
But it will not enable SSL. And I get the following configuration warning -

"configure: WARNING: OpenSSL or GnuTLS libs could not be found or were disabled"


I have the folloing OpenSSL and GnuTLS packages installed -

Code:
gnutls-1.0.8-26.4
openssl-0.9.7d-15.21
perl-ldap-ssl-0.29-132.1
Does anyone know why I can't upgrade with OpenSSL? I need SSL for check_http where I need to check some HTTPS sites availability.

Last edited by noir911; 08-21-2006 at 03:38 AM.
 
Old 08-21-2006, 04:53 AM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,383
Blog Entries: 55

Rep: Reputation: 3558Reputation: 3558Reputation: 3558Reputation: 3558Reputation: 3558Reputation: 3558Reputation: 3558Reputation: 3558Reputation: 3558Reputation: 3558Reputation: 3558
I am trying to upgrade my nagios plugins
Doesn't SLES come with these Nagios rpm's?


"configure: WARNING: OpenSSL or GnuTLS libs could not be found or were disabled"
You haven't installed %{package}-devel.
 
Old 08-22-2006, 03:04 AM   #3
noir911
Member
 
Registered: Apr 2004
Posts: 682

Original Poster
Rep: Reputation: Disabled
I solved this problem. I needed to install the openssl-devel package and then "./configure && make clean && make && make install".
 
Old 08-22-2006, 08:12 AM   #4
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,383
Blog Entries: 55

Rep: Reputation: 3558Reputation: 3558Reputation: 3558Reputation: 3558Reputation: 3558Reputation: 3558Reputation: 3558Reputation: 3558Reputation: 3558Reputation: 3558Reputation: 3558
I solved this problem.
No, I did.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Nagios and Oreon (Nagios web front end) installation and Configuration LXer Syndicated Linux News 1 05-31-2016 07:26 AM
LXer: Nagios 2.5 and Oreon 1.3 (Nagios web front end) installation with screenshots LXer Syndicated Linux News 0 08-11-2006 05:33 PM
SuSe 10 install - Nagios -> Now what? mac_casey SUSE / openSUSE 2 11-17-2005 09:00 PM
nagios doesn't work after an upgrade on RH9 ntoughe Linux - Software 2 11-04-2005 01:58 AM
Networking problem after SuSE 8.1 to SuSE 9.3 upgrade chiyoung_ku SUSE / openSUSE 2 06-02-2005 10:14 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 09:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration