LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 10-06-2013, 11:04 PM   #1
newFreeBSD
Member
 
Registered: Mar 2006
Location: Malaysia, Putrajaya
Distribution: CentOS, Ubuntu, Fedora
Posts: 54

Rep: Reputation: 0
Zypper Problem


Hi,

After some clash package install, i got error when refresh zypper.
Code:
svr-database:/home/banie # zypper ref
Target initialization failed:
Rpm Exception
svr-database:/home/banie #
Any idea how to fix it? This is production server. Using SLES 11 SP1.

Thanks.
 
Old 10-06-2013, 11:10 PM   #2
newFreeBSD
Member
 
Registered: Mar 2006
Location: Malaysia, Putrajaya
Distribution: CentOS, Ubuntu, Fedora
Posts: 54

Original Poster
Rep: Reputation: 0
Update:
Code:
svr-crdb:/home/banie # zypper lu
Target initialization failed:
Rpm Exception
svr-crdb:/home/banie # zypper ve
Target initialization failed:
Rpm Exception
svr-crdb:/home/banie #
 
Old 10-06-2013, 11:17 PM   #3
newFreeBSD
Member
 
Registered: Mar 2006
Location: Malaysia, Putrajaya
Distribution: CentOS, Ubuntu, Fedora
Posts: 54

Original Poster
Rep: Reputation: 0
Update:
http://pastebin.com/PXYUAZcV
 
Old 10-06-2013, 11:24 PM   #4
John VV
Guru
 
Registered: Aug 2005
Posts: 12,081

Rep: Reputation: 1575Reputation: 1575Reputation: 1575Reputation: 1575Reputation: 1575Reputation: 1575Reputation: 1575Reputation: 1575Reputation: 1575Reputation: 1575Reputation: 1575
Quote:
After some clash package install
what did you install and from where did you get it from ?

and what repos are installed
Code:
zypper repos
if that is not working
what is listed in the log
/var/log/zypp/history
and
/var/log/zypper.log

as the last few things you did



from the log
"file:///home/SLES11_CD/"
you are using the OLD , very old SELS 11 sp1 cd to install things from ?

but you ALSO have the sp 2 repo installed on sp1 ?
/etc/zypp/repos.d/SLES_Repo_11.2.repo
and have the very incompatible
http://ftp5.gwdg.de/pub/opensuse/dis.../repo/oss/suse
Opensuse 11.2 repo installed

You can NOT mix OpenSUSE 11 ( now dead and unsupported ) with SLES 11
they are two VERY VERY different OS's

Last edited by John VV; 10-06-2013 at 11:34 PM. Reason: added to
 
Old 10-07-2013, 11:13 PM   #5
newFreeBSD
Member
 
Registered: Mar 2006
Location: Malaysia, Putrajaya
Distribution: CentOS, Ubuntu, Fedora
Posts: 54

Original Poster
Rep: Reputation: 0
If i not using opensuse repo, i cannot proceed install and using drbd, pacemaker, corosync and heartbeat.
 
Old 10-07-2013, 11:34 PM   #6
John VV
Guru
 
Registered: Aug 2005
Posts: 12,081

Rep: Reputation: 1575Reputation: 1575Reputation: 1575Reputation: 1575Reputation: 1575Reputation: 1575Reputation: 1575Reputation: 1575Reputation: 1575Reputation: 1575Reputation: 1575
For SELS 11 sp2 ( SUSE Enterprise Linux Server 11 service pack2 )
SELS sp3 is the current , you might want to install service pack 3 on your sp2 install

you buy the required support contract from Novell
http://www.novell.com/products/howtobuy.html

it is not a free operating system you have to buy it like Windows XP,vista,7 or apple OSX

you can not use the now dead and unsupported OpenSUSE 11.2
-- it went End of life back in "May 12th 2011 " --

they are two very different operating systems that just share a similar name
 
Old 10-09-2013, 12:58 AM   #7
newFreeBSD
Member
 
Registered: Mar 2006
Location: Malaysia, Putrajaya
Distribution: CentOS, Ubuntu, Fedora
Posts: 54

Original Poster
Rep: Reputation: 0
I don't have authorities to buy SLES 11SP3. Our application also not compatible to new php on SP3.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Zypper Question Brandon9000 Linux - Software 2 07-05-2012 01:55 PM
opensuse, yum & zypper thesunlover Suse/Novell 1 11-13-2009 01:37 PM
LXer: Package Management With Zypper LXer Syndicated Linux News 0 11-05-2009 04:11 PM
zypper in galeon fstreed Suse/Novell 4 01-16-2009 06:47 PM
zypper dependencies metallica1973 Suse/Novell 4 01-16-2008 05:43 AM


All times are GMT -5. The time now is 03:38 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration