LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 07-27-2005, 04:29 PM   #1
hanasi
Member
 
Registered: Jul 2005
Distribution: SUSE Linux v9.2
Posts: 85

Rep: Reputation: 15
Dead mouse, suddenly


I've installed v9.3 -- a fresh install, on a newly partitioned HD.

I have gone on line with it, using Firefox, and am pleased. The only changes I made were in some Firefox preferences, and changing the mouse to the left-handed persuasion and a different cursor..

Whatever I did or didn't do, the system is now inoperable. When it boots, the
mouse is not frozen in the center of the screen. Its buttons also do nothing.
The only way I could shut the system down (twice) was with the Reset button. Perhaps there was a way with the keyboard, but I don't know it. I was able to bring up a Process List (but I'm not sure how I did that); repeatedly pressing the Tab key moved the focus from field to field, so apparently the keyboard was operational.

There is nothing wrong with the mouse itself -- it works when I boot the machine to OS/2.

How do I get out of this fix?

The last time it booted, I watched the detailed progress on the screen. I saw
nothing tht looked suspicious, except one Warning near the very end, at the time when the network was being set up. I couldn't read it, and of course I can't look at the boot log.

I assume that I need to boot to the Fail Safe option, which I understand to be
a command-line mode. I am very new at this OS, and would much appreciate some pointers about how to go about diagnosing what is hanging the mouse and how to repair it.
 
Old 07-27-2005, 04:35 PM   #2
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 117Reputation: 117
Re: Dead mouse, suddenly

Quote:
Originally posted by hanasi

There is nothing wrong with the mouse itself -- it works when I boot the machine to OS/2.
You're the one!!!

For future reference, you can switch to a console by pressing Ctrl+Alt+F1. Then type 'dmesg' and look for any mouse-related messages there.
 
Old 07-27-2005, 06:09 PM   #3
sundialsvcs
Guru
 
Registered: Feb 2004
Location: SE Tennessee, USA
Distribution: Gentoo, LFS
Posts: 5,231

Rep: Reputation: 1071Reputation: 1071Reputation: 1071Reputation: 1071Reputation: 1071Reputation: 1071Reputation: 1071Reputation: 1071
Do you perchance have a cat? An exceptionally large orange tabby is currently playing with my mouse... must be time for supper.

Seriously, if the device has not unexpectedly malfunctioned, the file that controls this behavior is probably named XF86Config and it should have information about the pointer device or devices, namely mouse and/or trackpad.

Nothing that you could have done as an ordinary user, e.g. in Firefox's configuration panel, could have (afaik) altered that file. Only root can twiddle with it. Sometimes you must kill the X process, again as root, in order to make it pick-up changes, but you don't describe yourself as having done anything like that. All that you've said that you did was to change Firefox preferences, operating as an ordinary user.

You describe this as a "fresh" 9.3 installation. It .. worked okay 'before?' Place to begin, then, is "before what?" What e-x-a-c-t-l-y...?
 
Old 07-27-2005, 08:29 PM   #4
fragos
Senior Member
 
Registered: May 2004
Location: Fresno CA USA
Distribution: Ubuntu 10.10
Posts: 1,466

Rep: Reputation: 51
I had this problem but it went away -- I know not why. What you can do to start the mouse for that GUI session is:
Alt-F2 brings up run window
Enter "YaST" and it will start
Cursor down to "Hardware"
"Tab" to select device with cursor keys
select "Mouse" and hit return
The mouse will start working after YaST initializes it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Suddenly my standard PS/2 MS mouse pointer has stalled langbein Suse/Novell 22 11-09-2005 05:12 PM
Root login suddenly dead patrick-slack Linux - Security 9 08-25-2005 07:03 AM
keyboard and mouse suddenly stop working TexasDex Linux - Hardware 2 06-04-2004 11:26 PM
Keyboard and mouse suddenly stop working (SuSE 9.0) tygernoot Linux - Hardware 1 05-13-2004 05:48 PM
X suddenly dead under Mdk10.0 RabidJackal Mandriva 7 04-25-2004 05:22 AM


All times are GMT -5. The time now is 12:42 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration