LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Studio 13.37
User Name
Password
Studio 13.37 This forum is for the discussion of Studio 13.37.

Notices


Reply
  Search this Thread
Old 04-16-2015, 08:49 PM   #1
palartu
LQ Newbie
 
Registered: Apr 2015
Posts: 4

Rep: Reputation: Disabled
Grub4Dos bootloader installation error


I managed to install Studio 13.37 on hard drive. But when I try to install Grub4Dos bootloader I receive error message in file grub4dosconfig.log. In file it says:
Error: Too few sectors to hold GRLDR.MBR.

I have windows on sda1 partition and boot flaged partition for windows.
I made new partitions for swap, studio 13.37 and another boot flaged partition. When I try to install bootloader. I get message from installer that boot flag could not be found. I proceed anyway and get this error.

Also, I cannot find z_extras.sfs file on usb that I bought. Is this because of new release?

Without bootloader I cannot find Studio 13.37 in boot menu.

What is the problem. I am new linux user. Is this to advanced for me or maybe I am missing some small things.
 
Old 04-16-2015, 11:02 PM   #2
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,629

Rep: Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652
a question

why do you think you need to use "grub4dos "
what guide has you using that over the Operating systems DEFAULT bootloader ?


just use the default Grub or lilo

grub dualboots with the mess that is Microsoft's "SecureBoot" in EFI
 
Old 04-17-2015, 04:12 AM   #3
palartu
LQ Newbie
 
Registered: Apr 2015
Posts: 4

Original Poster
Rep: Reputation: Disabled
I didn't know about efi. Thank you for that information.

But still, even in efi I cannot find Studio 13.37 for booting. When I use live version of Studio 13.37, there is a partition with all files, which means OS is definitely there. There is no way fo me to boot it.

In efi there is Microsoft, it's boot, ubuntu because I previously used Linux Mint, but now it just opens grub console. The last thing is HP, but there is nothing in there.

Last edited by palartu; 04-17-2015 at 04:13 AM. Reason: mistake
 
Old 04-17-2015, 07:17 AM   #4
veerain
Senior Member
 
Registered: Mar 2005
Location: Earth bound to Helios
Distribution: Custom
Posts: 2,524

Rep: Reputation: 319Reputation: 319Reputation: 319Reputation: 319
Are you installing windows or linux version of studio 13.37?
 
Old 04-17-2015, 10:44 AM   #5
palartu
LQ Newbie
 
Registered: Apr 2015
Posts: 4

Original Poster
Rep: Reputation: Disabled
I don't understand the question. There is no Windows version of Studio 13.37. Is that sarcasm?

Maybe I was misunderstood. All I wanted to say is that there is no Studio 13.37 in efi.

Last edited by palartu; 04-17-2015 at 10:59 AM.
 
Old 04-17-2015, 12:55 PM   #6
rokytnji
LQ Veteran
 
Registered: Mar 2008
Location: Waaaaay out West Texas
Distribution: antiX 23, MX 23
Posts: 7,194
Blog Entries: 21

Rep: Reputation: 3491Reputation: 3491Reputation: 3491Reputation: 3491Reputation: 3491Reputation: 3491Reputation: 3491Reputation: 3491Reputation: 3491Reputation: 3491Reputation: 3491
For the replies.

Studio 13.37


Which is based on Puppy Linux which offers grub4dos as a mbr bootloader choice.
Since the OP is trying to dual boot with Windows.
I have been avoiding a reply because of

Quote:
have windows on sda1 partition and boot flagged partition for windows.
another boot flaged partition. When I try to install bootloader>>>>I didn't know about efi
If Me. I'd install grub4dos to internal drive mbr and let grub4dos pick up windows and chainload it.
But this is l0wt3ch distro so I figure the OP should wait for him to reply to be sure.

But from what I can see. The OP is going about installing grub4dos all wrong. It should go on the mbr. Not a partition.
Same would be for grub or lilo. Unless you wanted to chainload grub or lilo through another bootloader. Then you would install grub or lilo to root on another partition.

It's OK that the Studio partition and Windows partition are flagged as boot. But something needs to boot both off the mbr and I bet the OP is using Windows bootloader on the MBR and wondering why Studio won't boot.

So like I said. Wait for l0wt3ch. And take what I say with a grain of salt.
Because efi and Puppy Linux grub4dos. I am not hip on that.

Last edited by rokytnji; 04-17-2015 at 12:59 PM.
 
Old 04-17-2015, 01:20 PM   #7
l0wt3ch
CEO, Studio 13.37
 
Registered: Nov 2011
Distribution: Studio 13.37
Posts: 154

Rep: Reputation: 8
I never personally use grub4dos, I always use the grub installer (Legacy Grub Config under System in the menu).

I made a video about how to install 13.37 to your hard drive here: https://www.youtube.com/watch?v=PXFLqrUYlWM The gui of the apps mentioned are a little different now, but it's basically the same process.



When using the grub installer, if you're dual-booting you should choose Expert Mode. Notice it says hd0 by default, that's the first hard drive connected inside the computer. That's where Stage 1 is normally installed. The partition for Stage 2 is where your new install is. It starts at 1, so if you shrank your Windows partition and made a second partition, that would be sda2. The next line is just the partition info written in grub-speak, where the partition counting starts at 0, which is the most confusing aspect of this. So, if you had a new partition (sda2) you would write that here as (hd0,1). And if you only had the one partition at start, the default "Windows entry" would still be true, but nowadays it'll probably be something else. So check your setup first, maybe by opening a terminal and typing 'fdisk -l' to see what's going on.

As noted in the video, please use Windows' own partitioner to shrink your Windows install, or you'll have to get a recovery disk and fix the boot loader.

Most of the grub stuff is pretty generic across lines of Linux, and there's lots of great tutorials out there. The only difference is the handy gui included mentioned above.

Hope that helps!
 
Old 04-17-2015, 01:26 PM   #8
l0wt3ch
CEO, Studio 13.37
 
Registered: Nov 2011
Distribution: Studio 13.37
Posts: 154

Rep: Reputation: 8
Also, do you have the installer version? Because if you have more than one .sfs file in your iso, it will still install, but you'll have to copy the other sfs's to the / directory and then load them (right click and select "load sfs") after you boot for everything to work properly. (Yes, the extras.sfs is outdated.)

Last edited by l0wt3ch; 04-17-2015 at 01:38 PM.
 
Old 04-17-2015, 10:21 PM   #9
veerain
Senior Member
 
Registered: Mar 2005
Location: Earth bound to Helios
Distribution: Custom
Posts: 2,524

Rep: Reputation: 319Reputation: 319Reputation: 319Reputation: 319
Quote:
Originally Posted by palartu View Post
I don't understand the question. There is no Windows version of Studio 13.37. Is that sarcasm?

Maybe I was misunderstood. All I wanted to say is that there is no Studio 13.37 in efi.
I didn't knew of studio 13.37 and did a web search. It showed a page with windows, linux , macosx downloads. That's why I asked. It was definitely not sarcasm.

I thought Windows version would be requiring grub4dos. That's why.
 
Old 06-16-2015, 06:13 AM   #10
palartu
LQ Newbie
 
Registered: Apr 2015
Posts: 4

Original Poster
Rep: Reputation: Disabled
Thank you for your help! I managed to install Studio 13.37 on my hard drive. Legacy GRUB config worked.
 
Old 06-16-2015, 08:31 AM   #11
l0wt3ch
CEO, Studio 13.37
 
Registered: Nov 2011
Distribution: Studio 13.37
Posts: 154

Rep: Reputation: 8
Awesome! Glad you got it sorted.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Installation on a grub4dos platform - SOLVED wimpy Linux - Newbie 8 06-20-2014 04:44 AM
Syslinux Bootloader chainloaded to GRUB4DOS? help needed for Ultimate bootable USB areic4010 Linux - Software 4 07-17-2010 01:59 PM
GRUB Error 26: Disk Read Error (using grub4dos and ubuntu) Dark_Master Linux - Software 11 02-25-2007 07:42 AM
GRUB Error 26: Disk Read Error (using grub4dos and ubuntu) Dark_Master Linux - Newbie 2 11-07-2006 11:58 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Studio 13.37

All times are GMT -5. The time now is 05:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration