-   Solaris / OpenSolaris (
-   -   Xorg failing after patch install (

ADxD_7 08-22-2007 06:58 PM

Xorg failing after patch install
I just installed the newest recommended patches for sol 10 x86 - in single user mode - but when I rebooted my X server wont come up - the
/var/dt/Xerrors says

EE No devices detected

The config file I had customized myself worked perfect before the patch adds and now it is being stupid - I am frustrated with this now because a patch add should not mess this up - I would love any thoughts on it --


crisostomo_enrico 08-23-2007 01:53 AM

This is not going to help, but for your information: I had a vanilla Solaris 10 11/06 and I applied the same patch bundle you're mentioning: I had many and funny problems related to Xorg, including Xorg -configure and xorgcfg not working any more and some errors detected in xorg.conf which were not detected before applying the patch. I think there were due to some missing module which probably was removed from xorg distribution. By the way, not being able to generate a xorg.conf automatically (because Xorg -configure was broken...) and not willing to loose time solving something that sould work out of the box... I simply removed xorg.conf and the detected configuration was satisfactory for me.

That's exactly what patches shouldn't do... I'm afraid of patching, now. :)

Have luck,

ADxD_7 08-23-2007 11:41 AM

I reinstalled the Nvidia driver but now it says ::

WARNING:consconfig:No screen found

Cannot find driver for console framebuffer

And then it reboots ???? It will not load my Solaris install at all ???

Anybody seen this or know whats going on ???

ADxD_7 08-23-2007 03:01 PM

Ok so now I tried installing an older version of the NVIDIA driver and it seams to work but now I get this error -

NVIDIA(0):Failed to obtain a shared memory identifier

Which I found out is because of CONFIG_SYSVIPC not being enabled in the kernel

The patch must have done it -

Anybody know how to enable CONFIG_SYSVIPC ??

ADxD_7 08-27-2007 06:42 PM

I found the answer !
Ok so after tons of learning on changing kernel peramiters and all kinds of headache I found the problem - although it had nothing to do with that :) O well I learned alot --

The problem was patch # 125720-10 - an xorg patch - that fixed some bugs -

I patchrm 'ed it and right after a quick update_drv command and a reboot it was fixed -

I finally have dual screens with no problems --

All times are GMT -5. The time now is 10:44 AM.