LinuxQuestions.org
Help answer threads with 0 replies.
Home Forums Tutorials Articles Register
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris
User Name
Password
Solaris / OpenSolaris This forum is for the discussion of Solaris, OpenSolaris, OpenIndiana, and illumos.
General Sun, SunOS and Sparc related questions also go here. Any Solaris fork or distribution is welcome.

Notices


Reply
  Search this Thread
Old 06-22-2006, 09:56 AM   #1
richikiki
Member
 
Registered: Mar 2005
Location: Montréal, Québec, Canada
Distribution: Slackware 12.1 x32, 13.1 x64
Posts: 90

Rep: Reputation: 15
Question what kind of version system, processor(s) has my Solaris?


Hi guys,

Does any one know how to know what kind of version system, processor(s) has my Solaris?. I have only a remote access through a ssh connexion.

I'm new on this operative system.
 
Old 06-22-2006, 10:43 AM   #2
binary_y2k2
Member
 
Registered: Jul 2005
Location: England, UK
Distribution: Ubuntu 8.04 Server, Kubuntu 12.04
Posts: 698
Blog Entries: 1

Rep: Reputation: 31
Try the commands "uname -a" and "cat /proc/cpuinfo" to get the info:
Code:
user@host:~$ uname -a
Linux home 2.6.15-23-686 #1 SMP PREEMPT Tue May 23 14:03:07 UTC 2006 i686 GNU/Linux
user@host:~$ cat /proc/cpuinfo | grep "model name"
model name      : Intel(R) Pentium(R) 4 CPU 2.80GHz
 
Old 06-22-2006, 10:54 AM   #3
kvedaa
Member
 
Registered: Mar 2004
Location: Virginia
Distribution: PacketProtector
Posts: 331

Rep: Reputation: 30
For Solaris if memory serves:

Show OS version:

Code:
cat /etc/release
Show details on processors:

Code:
/usr/sbin/psrinfo -v
Show memory:

Code:
/usr/sbin/prtconf | grep -i memory

Happy hunting,

Last edited by kvedaa; 06-22-2006 at 10:57 AM.
 
Old 06-22-2006, 11:55 AM   #4
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris 11.4, Oracle Linux, Mint, Debian/WSL
Posts: 9,789

Rep: Reputation: 492Reputation: 492Reputation: 492Reputation: 492Reputation: 492
For all SPARC (and latest OpenSolaris on x86), there is also prtdiag:
Code:
/usr/platform/$(uname -i)/sbin/prtdiag -v
 
Old 06-22-2006, 01:37 PM   #5
richikiki
Member
 
Registered: Mar 2005
Location: Montréal, Québec, Canada
Distribution: Slackware 12.1 x32, 13.1 x64
Posts: 90

Original Poster
Rep: Reputation: 15
Thumbs up

Thanks guys,

jlliagre your command is pretty good. I was able to see a lot of information on the machine.

Thanks you all guys.
 
  


Reply



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Which kind of Linux could run on a 333Mhz Intel Celeron processor? mst3kman Linux - Software 13 06-23-2005 02:43 PM
Which version should i download for my AMD Duron processor? Sir Loin Linux - Software 12 02-06-2005 09:04 PM
What kind of BSD version can I install? lewkh *BSD 9 10-24-2004 02:17 PM
4 processor listings in cpuinfo on dual processor system. atticboy1 Linux - Hardware 2 02-08-2004 06:35 PM
xinetd 100% utilization on one processor on a two processor system red hat 9 garnold Linux - General 0 02-02-2004 01:47 PM

LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris

All times are GMT -5. The time now is 09:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration