LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris
User Name
Password
Solaris / OpenSolaris This forum is for the discussion of Solaris, OpenSolaris, OpenIndiana, and illumos.
General Sun, SunOS and Sparc related questions also go here. Any Solaris fork or distribution is welcome.

Notices


Reply
  Search this Thread
Old 04-27-2006, 08:58 PM   #1
babyphil
Member
 
Registered: Jun 2004
Location: Texas
Distribution: Solaris 10 / Slackware 10.1
Posts: 68

Rep: Reputation: 15
Ultra 20 workstation video card upgrade


What should I do in upgrading Sun Ultra 20's stock on-board video to a PCI (not PCI-E) nvidia geforce mx4000?
I have installed the card into the machine.
However when I boot up, only the on-board card works and it can no longer rn Xorg.
All the howtos online are only howto install the drivers, but my sun came with nvidia drivers pre-installed
So what must I do to deactivate the onboard card? The sun uses suns own openboot thing rather than a BIOS so I am at a loss.

Any suggestions or howtos around?
 
Old 04-28-2006, 03:46 PM   #2
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris 11.4, Oracle Linux, Mint, Ubuntu/WSL
Posts: 9,784

Rep: Reputation: 492Reputation: 492Reputation: 492Reputation: 492Reputation: 492
Quote:
Originally Posted by babyphil
The sun uses suns own openboot thing rather than a BIOS so I am at a loss.
Actually the U20 features a BIOS, not an openboot.
I don't know if it allows to enable your graphic card though.
You should try to install the latest bios if it doesn't.
Links here: http://www.unixconsult.org/u20/drivers.php
 
Old 04-28-2006, 04:30 PM   #3
babyphil
Member
 
Registered: Jun 2004
Location: Texas
Distribution: Solaris 10 / Slackware 10.1
Posts: 68

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by jlliagre
Actually the U20 features a BIOS, not an openboot.
I don't know if it allows to enable your graphic card though.
You should try to install the latest bios if it doesn't.
Links here: http://www.unixconsult.org/u20/drivers.php
You were right (of course), there is a BIOS
The BIOS sees the card, but it simply will not work.
I will upgrade the BIOS but I am thinking about just buying a low-cost PCI-E card since they work out of the box.

THanks for the help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Configuring a PCI video card on a Sun workstation xxxxspitfire Debian 2 12-17-2005 12:14 AM
Ultra 5 workstation - hardware compatibility frankie_DJ Solaris / OpenSolaris 3 07-06-2005 02:13 PM
Booting from a CD-ROM in an Ultra 60 workstation kaplan71 Solaris / OpenSolaris 7 12-24-2003 12:06 PM
Trying to boot off the CD-ROM in a Sun Ultra 60 workstation kaplan71 Linux - Software 1 11-26-2003 02:23 PM
Not as much of a Solaris problem rether hardware Ultra 10 problem (video card) neo77777 Solaris / OpenSolaris 7 06-24-2003 08:36 PM

LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris

All times are GMT -5. The time now is 12:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration