-   Solaris / OpenSolaris (
-   -   Solaris10, Disk Full, CANT DELETE to make room (

donanap 02-04-2009 10:10 PM

Solaris10, Disk Full, CANT DELETE to make room
Hi Guys,

I keep running into the same stupid problem, this time Im unable to fix it!
I look after a user area where the actual disks are layed out as below.

Filesystem Size Used Avail. Capacity Mounted On
pdc 1.0T 29K 909G 1% /pdc
pdc/archive 1.0T 24K 909G 1% /pdc/archive
pdc/scratch 145G 105G 0K 100% /pdc/scratch
pdc/staging 1.0T 8.4G 909G 1% /pdc/staging

I did not set up this server originally, I have just takne over administration and there was no hand over or explanation. SO...At first I thought that the pdc/scratch area was set up with diskquotas. But when I run requota i get..

quotactl: no quotas file on any mounted file system

So, Its not quotas.. How has he done this!? Also, as u can see the disk is currently full. usually I have been able to manipulate this in a way that I could move files in order to make enough space to delete.. but thats not working this time. I have no way of freeing up disk space unless somebody else can help me with ideas??

Help would be greatly appreciated and excuse me if I sound a little unaware.. I have been thrown in the deep end, training whilst administrating!!

Hope to hear from someone.

gilead 02-04-2009 10:34 PM

I'm not familiar with Solaris... But that looks like what can happen on a Linux file-system when it runs out of inodes. Are you able to boot from a rescue CD/DVD and clean out the /pdc/scratch partition?

amachina 02-04-2009 10:55 PM

Why don't you just "cd /pdc/scratch" and take a look around?

# du -sh * (to see which directories/files are using the most space)
# ls -S * (to see the files sorted by file size)

# rm <file_you_don't_need> (to free up some space)

BTW -- in general, lack of inodes should not show a full filesystem.

donanap 02-05-2009 12:59 AM

cannot clean out/delete data from scratch area..
Hi, thanks for your suggestion Gilead. Unfortunately i will not be able to clean out scratch by removing data. I have never had to do that before during boot up, so, just to answer your question with a question..

If I boot from CD, will I be able to move data at this point to another location on the server? (as this pdc disk is not the only disk) I have tried moving stuff now but cannot, so if its a possibility that I can do this when booting, i may try that...

Amachina, as explained in my original comments, I cannot delete or move items, the disk is too full and it will not process the command, they just keep reappearing. I have tried both in the GUI and by command line.. I have even tried to force them to delete but they wont...

rm -f file.txt

Thanks anyway...
Would like to hear back re: moving files on bootup..

Thanks so far!!

jlliagre 02-05-2009 03:23 AM

Your disk is using ZFS so the quotas aren't handled the same way and the size reporting looks confusing. If the reported available space is 0, you can't write more data to the disk regardless of the size shown.

You can check if there is one with:

zfs get all pdc/scratch | grep quota
Removing/moving files while they are written to isn't a way to free disk space. It just hides the file names but the allocated bytes stay and keep growing. You need to find out what processes are writing there and stop the responsible ones.


fuser -c /pdc/scratch

donanap 02-05-2009 07:44 PM

Hi jlliagre,

heres the output:


zfs get all pdc/scratch | grep quota
pdc/scratch      quota          145G                      local

So that much is something! Finally, as i said, im very inexperienced, so wasnt aware of the possibility of differences for ZFS quotas... Thankuyou.. i will begin my googling now on how to release this quota! :-)

However, there are no current process writing to this disk, which is what I expected. So I suppose if I can increase or release the qouta I can manage to play and sort this mess out.

Thanks for that - its the lightbulb I was looking for..

jlliagre 02-06-2009 06:49 AM

If you are using 105GB out of a 145GB quota but the file system reports it's full, it isn't a quota issue.

What say:

zpool list
zfs list


All times are GMT -5. The time now is 08:19 PM.