LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Solaris / OpenSolaris (https://www.linuxquestions.org/questions/solaris-opensolaris-20/)
-   -   Solaris Networking (https://www.linuxquestions.org/questions/solaris-opensolaris-20/solaris-networking-939459/)

rhadmn 04-12-2012 09:02 AM

Solaris Networking
 
Hi Friends,

Having come from the Linux background I am not able to understand the difference between the Interfaces: "bge#" & "e1000g#".

I know the question would be simple for the Solaris experts. But I am looking for something which explains the solaris networking in detail and virtual IP address assigning.

Regards,
RHADMN

jlliagre 04-12-2012 09:43 AM

The difference is simply the driver used to handle the NIC. Both bge# and e1000g# would map to eth# on linux.

Assigning a virtual IP can be done with the ifconfig command, eg:
Code:

ifconfig bge0:1 plumb
ifconfig bge0:1 192.168.1.2 up

or
Code:

ifconfig bge0 addif 192.168.1.2
For persistent assignations, put the IP address in the /etc/hostname.bge0:1 file.

Note that Solaris 11 no more distinguish interfaces names by default and uses net0, net1 and so on. Solaris 11 also introduces a totally different command set to administrate the network interfaces.

rhadmn 04-15-2012 06:20 AM

Hi jlliagre,

Thanks a lot for the reply. Appreciate it.

Would you be able to assist me with some relevant Solaris Network Documents ?

jlliagre 04-15-2012 07:01 AM

Start with the manual pages:

Code:

man ifconfig
man dladm
man ipadm


rhadmn 04-15-2012 08:35 AM

Thanks jlliagre

Blinker_Fluid 04-19-2012 12:37 PM

Just something to be aware of interface speed was often restricted by type for some of the old interfaces:

ce - 1000/full
eri - 100/full
ge - 1000/full
hme - 100/full
qfe - 100/full
bge - 1000/full


All times are GMT -5. The time now is 11:02 AM.