LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Solaris / OpenSolaris (https://www.linuxquestions.org/questions/solaris-opensolaris-20/)
-   -   solaris boot problem boot error loading interpreter(misc/krtld) (https://www.linuxquestions.org/questions/solaris-opensolaris-20/solaris-boot-problem-boot-error-loading-interpreter-misc-krtld-354160/)

Johncy_j 08-17-2005 06:19 AM

solaris boot problem boot error loading interpreter(misc/krtld)
 
When I installed the SOLARIS 10 OS first time, the desktop would not start up, this was because of network setup. Reinstalled worked. After a week due to some problem I had to reinstall OS, installation went fine and but when i reboot I get this error.

cannot find mis/krtld
boot error loading interpreter(misc/krtld)
elf32 read error
load error read of platform/i86pc/kernel/unix failed.
boot path /pci@0,0/pci-ide@1f,1/ide0/cmdk@0,0:a

I have been trying to reinstall with many option like formatting with windows fdisk, linux installer everything as I saw somewhere that disk needs low level format.

I have googled but could not find any solution..

When I try to format disk using windows this is the information gathered
Partition1 (solarisboot) 12 MB
partition2 unknown 152610

Hardware

pentium4 2.4 GHZ
1Gb DDR memor
Intel Original mother board.
140 Gb hard disk

Installation

install type 3 (tried other options as well)

Entire disk for boot and Solaris
accepted almost all default parameters.

downloaded again , burned a DVD still same.

Any help will be highly appreciated, as I have been trying out everything I could find, also I really want to learn to use Solaris

jlliagre 08-17-2005 07:51 AM

This looks like H/W failure (presumabily hard-disk or cd/dvd media).
Have you checked the iso image checksums ?

Johncy_j 08-17-2005 08:01 AM

i did veryfy the checksums against the values mentioned in install notes.

windows installs fin on this disk
i could install linux suse as well.

instalation goes very well, once finished i can see the directories. this happens when I reboot.

thanks a tom for the reply.

jlliagre 08-17-2005 08:13 AM

Try booting with this command (when prompted for boot arguments):
Code:

b kmdb -v

Johncy_j 08-17-2005 09:37 AM

thanks a lot, Can I ask you one thing, How do I, If needed boot the machine from DVD and look up for these files which it says cant find.

I went thorough install and cancelled installation when I got shel prompt, the searched 'find krltd' but got cant find ktltd static error.(Not exactly may be as I am at work)

I have seen some write ups on booting a sparc system but not and intel one.

jlliagre 08-18-2005 01:47 AM

You can boot with Schillix (Live OpenSolaris CD), mount your hard disk and check if /kernel/misc/krtld is there and OK.
This file belongs to the SUNWckr package, this is the place to look for in the distribution CD.


All times are GMT -5. The time now is 05:57 PM.