LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris
User Name
Password
Solaris / OpenSolaris This forum is for the discussion of Solaris, OpenSolaris, OpenIndiana, and illumos.
General Sun, SunOS and Sparc related questions also go here. Any Solaris fork or distribution is welcome.

Notices


Reply
  Search this Thread
Old 01-13-2011, 07:33 PM   #1
mitali
LQ Newbie
 
Registered: Oct 2010
Posts: 4

Rep: Reputation: 0
Solaris 10 NIS Setup (Using NFS and AutoFS)


Hello All,

I am new to SOlaris 10 and I am trying to configure NIS with AutoFS and NFS. But, having issues. Please help

NIS SErver:
1) I have installed packages: SUNWypu SUNWypr SUNWrot
2) #domainname sunlab
3) Created a FS and mounted on /users (mount -F ufs /dev/dsk/c1t1d0s5 /users)
4) Added users
#useradd -d /users/m1 -m m1
#useradd -d /users/m2 -m m2
#passwd m1
#passwd m2
5) vi /etc/dfs/dfstab
share -F nfs /users
6) #shareall
7) vi /etc/auto_master
/users auto_home
8) vi /etc/auto_home
* <server ip>:/users/&
9)cd /etc
#touch ethers bootparams netgroup
#ypinit -m

NIS CLIENT
1) #domainname sunlab
2) vi /etc/defaultdomain
sunlab
3) # cp /etc/nsswitch.nis /etc/nsswitch.conf
#vi /etc/nsswitch.conf
.
automount: nis files
.
.
4) vi /etc/hosts
<NIS server ip> <NIS hostname>
5) #ypinit -c
6)#cd /usr/lib/ntsvc/yp
#./ypstop
#./ypstart

NOW THE MAIN PART
#telnet 0
login m w1
passwd

$pwd
/


ABOVE IT SHOWS / but it should be /users
WHERE I AM WRONG????
I am very much confused.
autofs nfs rpc are running fine. I even tried to restart it.

Please help.

Thank you
 
Old 01-13-2011, 08:10 PM   #2
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 12,943
Blog Entries: 28

Rep: Reputation: 2233Reputation: 2233Reputation: 2233Reputation: 2233Reputation: 2233Reputation: 2233Reputation: 2233Reputation: 2233Reputation: 2233Reputation: 2233Reputation: 2233
Moved: This thread is more suitable in Solaris and has been moved accordingly to help your thread/question get the exposure it deserves.
 
Old 01-18-2011, 10:33 AM   #3
mitali
LQ Newbie
 
Registered: Oct 2010
Posts: 4

Original Poster
Rep: Reputation: 0
Please help someone.
Thanks.
 
Old 01-25-2011, 06:03 PM   #4
ADxD_7
Member
 
Registered: May 2007
Location: CO
Distribution: Solaris , Redhat , Debian
Posts: 152

Rep: Reputation: 23
I can help you with this but I will need more information - did you correctly check and edit the /var/yp/Makefile? On the client does `ypwhich` show the client bound to the server? Please on the server and the client show me the output of `svcs -a | grep nis`

If those all look good try doing `ypcat auto.home` and `ypcat auto.master` on the client and show me the output of that

O and please show the contents of /etc/nsswitch.conf on the client


Later
 
Old 02-02-2011, 03:18 PM   #5
mitali
LQ Newbie
 
Registered: Oct 2010
Posts: 4

Original Poster
Rep: Reputation: 0
Thank you so much for replying ADxD_7,

Here is the output you requested (sun35-nis server sun39-nis client)
1) I did not edit /var/yp/Makefile. Can u plz explain on wat i need to edit in this file.
2) On client ypwhich gives the hostname of the nis server
#ypwhich
sun35


3) Server
bash-3.00# svcs -a | grep -i nis
disabled Feb_01 svc:/network/rpc/nisplus:default
disabled Feb_01 svc:/system/patch-finish:delete
online 15:58:17 svc:/network/nis/passwd:default
online 15:58:17 svc:/network/nis/server:default
online 15:58:17 svc:/network/nis/xfr:default
online 15:58:17 svc:/network/nis/update:default
online 15:58:17 svc:/network/nis/client:default

CLient
bash-3.00# svcs -a | grep -i nis
disabled 16:31:42 svc:/network/rpc/nisplus:default
disabled 16:31:42 svc:/system/patch-finish:delete
online 16:05:07 svc:/network/nis/client:default

4) On Clinet
bash-3.00# ypcat auto.home

192.168.2.35:/users/&

bash-3.00#
bash-3.00#
bash-3.00# ypcat auto.master

auto_home
-hosts -nosuid,nobrowse
bash-3.00#


5) On client
bash-3.00# cat /etc/nsswitch.conf
#
# /etc/nsswitch.nis:
#
# An example file that could be copied over to /etc/nsswitch.conf; it
# uses NIS (YP) in conjunction with files.
#
# "hosts:" and "services:" in this file are used only if the
# /etc/netconfig file has a "-" for nametoaddr_libs of "inet" transports.

# NIS service requires that svc:/network/nis/client:default be enabled
# and online.

# the following two lines obviate the "+" entry in /etc/passwd and /etc/group.
passwd: files nis
group: files nis

# consult /etc "files" only if nis is down.
hosts: nis [NOTFOUND=return] files

# Note that IPv4 addresses are searched for in all of the ipnodes databases
# before searching the hosts databases.
ipnodes: nis [NOTFOUND=return] files

networks: nis [NOTFOUND=return] files
protocols: nis [NOTFOUND=return] files
rpc: nis [NOTFOUND=return] files
ethers: nis [NOTFOUND=return] files
netmasks: nis [NOTFOUND=return] files
bootparams: nis [NOTFOUND=return] files
publickey: nis [NOTFOUND=return] files

netgroup: nis

automount: nis files
aliases: files nis

# for efficient getservbyname() avoid nis
services: files nis
printers: user files nis

auth_attr: files nis
prof_attr: files nis
project: files nis
bash-3.00#

6) Server
bash-3.00# svcs -a | grep -i autofs
online 16:07:34 svc:/system/filesystem/autofs:default
bash-3.00#


Please help.. I don't know where I am missing .....

Thank You.
 
Old 02-10-2011, 11:18 AM   #6
mitali
LQ Newbie
 
Registered: Oct 2010
Posts: 4

Original Poster
Rep: Reputation: 0
Somebody Please help.

Thank You
 
Old 06-27-2011, 03:39 PM   #7
arunkrish
LQ Newbie
 
Registered: Jun 2011
Posts: 1

Rep: Reputation: Disabled
I believe the user home directory is not set for users it has to be added as /home/<username> will work which i tried myself working perfectly.....

Let me know if that works
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 8, NIS, NFS, autofs b1f30 Fedora 1 12-15-2007 03:38 AM
NIS, NFS, autofs and /home folder question ramram29 Linux - Networking 2 08-25-2006 08:26 PM
How to setup a solaris NIS client while with a Linux NIS server? ntcm Linux - Security 2 03-31-2004 12:43 PM
How to setup a solaris NIS client while with a Linux NIS server? ntcm Linux - Networking 1 03-31-2004 07:51 AM
Solaris serving NIS, NFS, autofs to RH7.3 joeljensen Linux - Networking 1 07-12-2002 07:28 PM

LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris

All times are GMT -5. The time now is 06:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration