LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris
User Name
Password
Solaris / OpenSolaris This forum is for the discussion of Solaris, OpenSolaris, OpenIndiana, and illumos.
General Sun, SunOS and Sparc related questions also go here. Any Solaris fork or distribution is welcome.

Notices


Reply
  Search this Thread
Old 10-11-2007, 12:58 AM   #1
LinuxLover
Member
 
Registered: Feb 2004
Distribution: Solaris 10/11 , RHEL 6 ,AIX 7.1
Posts: 194

Rep: Reputation: 32
sendmail log file at solaris 10


Hello everybody,

I am using sendmail on Solaris 10 at x86 machine and facing two problems.

There is no maillog file for mail logging.
I did try and added the entry in /etc/syslog.conf

mail.info /var/adm/maillog

But still no logging information about relay mails is being recorded.

Second problem is that I install imap. added the entery in /etc/inetd.conf file.

pop3 stream tcp nowait root /usr/local/sbin/ipop3d ipop3d

and then starting the service by
[~]# svcadm enable pop3/tcp

[~]# svcs -l pop3/tcp
fmri svc:/network/pop3/tcp:default
name pop3
enabled true
state online
next_state none
state_time Thu Oct 11 08:36:51 2007
restarter svc:/network/inetd:default



netstat -anP tcp |grep 110

[~]# netstat -anP tcp |grep 110

*.110 *.* 0 0 49152 0 LISTEN


show me that it is listening on port 110.
But still When I try to receive mail from client it ask for password again and again. and no mail pops
 
Old 10-11-2007, 04:00 AM   #2
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris 11.4, Oracle Linux, Mint, Ubuntu/WSL
Posts: 9,782

Rep: Reputation: 481Reputation: 481Reputation: 481Reputation: 481Reputation: 481
1: Make sure you didn't use a space but but a tab as field separator in the line you added.
2: Have syslogd read again its configuration
Code:
svcadm restart system-log
For the second question, that thread may help:
http://forum.java.sun.com/thread.jsp...sageID=9658918
 
Old 10-11-2007, 05:11 AM   #3
LinuxLover
Member
 
Registered: Feb 2004
Distribution: Solaris 10/11 , RHEL 6 ,AIX 7.1
Posts: 194

Original Poster
Rep: Reputation: 32
Thank jlliagre

I was using
# svcadm restart system-log

My mistake was that i am using space in

mail.info /var/adm/maillog line.

Now I used tab as per you advice and getting log in that file .
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
where is the secure log in solaris 10? xpucto Solaris / OpenSolaris 5 11-13-2006 09:29 AM
any ideas to reduce log file size or make log file size managed? George2 Programming 2 08-13-2006 07:55 AM
how do i get user authid in sendmail log file ? pd5c18 Linux - Networking 0 08-21-2004 09:32 AM
X apps from linux to solaris log me out xsecurity Solaris / OpenSolaris 3 09-24-2003 06:18 PM
iptables, changing log file from /var/log/messages acid2000 Linux - Networking 3 03-11-2003 09:38 PM

LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris

All times are GMT -5. The time now is 01:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration