-   Solaris / OpenSolaris (
-   -   rw access to Solaris ufs slices from Linux (

shachter 07-05-2007 09:42 PM

rw access to Solaris ufs slices from Linux
Since this is www dot linuxquestions dot org, presumably the readership
of this forum is interested in Solaris-Linux interoperability,
even though the name of the forum is "Solaris/OpenSolaris".
Please forgive me if I am wrong, I have never posted here before.

Can you tell me how to mount Solaris slices -t ufs -o rw
on a Linux kernel? My kernel recognizes my Solaris slices
("dmesg | grep solaris" produces
hda2: <solaris: [s0] hda12 [s1] hda13 [s2] hda14 [s3] hda15 [s4] hda16
[s5] hda17 [s6] hda18 >) and also has no problem reading the
files on those slices after a "mount -t ufs /dev/hda12 /mnt/solaris".
But any filesystem so mounted is a ROFS. I recompiled my kernel
(vmlinuz-2.6.13-15-default, SuSe 10) to turn on the ufs rw
option, but it still treated the filesystem on the slice
as a ROFS until I did both -o ufstype=sun and -o remount
(doing one without the other didn't help -- the -o rw
generated no errors, and mount reported rw, but I still
got the ROFS when I tried to write or chmod). After I did
-o ufstype=sun and -o remount, I was able to chmod without
ROFS errors, but I was still getting ROFS errors when I
tried to write. And then afterwards, the directory
in which I was working (/etc) seemed to disappear, even
after unmounting and remounting. I haven't tried booting
Solaris directly yet to see whether /etc really has
disappeared. If it has, I may need to reinstall Solaris.
Please do me the kindness of letting me know, if you reply; I do not
read this forum regularly. Thank you in advance.

jay at

jlliagre 07-06-2007 12:43 PM

I would never try myself to mount an UFS file-system R/W on linux outside testing.

That said, according to the Linux mount manual page, you are using an incorrect option to the mount command.

"-o ufstype=sun" is for SPARC while the right way is documented to be "-o ufstype=sunx86".

All times are GMT -5. The time now is 07:24 PM.