-   Solaris / OpenSolaris (
-   -   pkg-get install gcc ERROR: gcc unrecognized (

Raidmax 08-29-2007 05:08 PM

pkg-get install gcc ERROR: gcc unrecognized
Hello, I've been asked to setup a Solaris file server for windows clients for a small company. At my home office i run slackware 10.2 server with sendmail,apache,samba. I'm totally new to solaris, my contact person at this company does not know much about this system. So I started from scratch here is what I have accomplished. Configured lan and internet access, downloaded and unzipped Samba. Started to configure but ahhh no complier!! Surfed to followed the howto's on pkg-get and wget successfully. Here is my issue. I type pkg-get install gcc and receive the following ERROR: gcc unrecognized. I've googled and have hit a stalemate. Can someone please shed some light as to what I need to change?

Thank You


jlliagre 08-29-2007 05:34 PM

What Solaris version are you using ? Latest already bundle gcc, apache, samba and the likes.

About pkg-get, that just means there is no package named gcc.

You probably want gcc3core or gcc4core.

kebabbert 08-30-2007 07:05 AM

Look into /opt

There you have /opt/csw/bin/gcc and the likes, just as Jillagire writes.

Raidmax 08-30-2007 07:22 AM

thank you for the reply. the solaris version is nine. I'll check out /opt for gcc3core or gcc4core when I get to the company this morning.

kebabbert 08-30-2007 10:31 AM

Oops, I wrote wrong. gcc is not in /opt. On solaris 10, it is in

Raidmax 08-30-2007 10:49 AM

thanks kebabbert i looked in opt before i read your latest post ....went from bummer to What a beautiful day!!! found gcc in /bin version is 3.4.3

Thanks again!


jlliagre 08-30-2007 11:08 AM

"/bin/gcc" on a Solaris 9 machine ?

This is a hack.

Raidmax 08-30-2007 11:26 AM

kebabbert ,jilliagre where can I find a howto on compiling this(gcc)? Again I did not build this server and I'm a newbie to solaris. Can you please point me to where I would find a howto for gcc on solaris 10?

Thank You,


kebabbert 08-30-2007 11:31 AM

blastwave and CBE has several different versions of gcc to download. It installs automatically for you. I have seen gcc v4.XX at CBE.

Raidmax 08-30-2007 12:27 PM

kebabbert thanks so much now have different issue I don't know if the system was powered down incorrectly when I was not here but my experience tells me it was, everything I've done up to this point I no longer can verify. Tried to wget the gcc and got wget: not found Ahhh checked my /tmp and nothing is in there that was there yesterday not samba, etc. Here is the output of the who command
root console aug 30 10:05 (:0)
root pts/3 aug 30 10:05 (:0.0)
root pts/5 aug 30 10:05 (0:0)
root pts/4 aug 30 10:05 (0:0)

ok when I originally began the setup they were logging in as user genesis with password of root. Obviously I inquired as to roots password and was told and confirmed it was also root. Up until this morning configuring as root things were going fine. What do i need to do? My background is windows its a profile thing right?

Raidmax 08-30-2007 12:51 PM

wrong sorry login username: genesis, password: 23genesis, then su root:root. Past two days no problems. Now login genesis with password and I'm getting

The DT messaging system could not be started.
To correct the problem:

1. Choose [OK] to return to the login screen.
2. Select Failsafe Session from the login screen's option menu and login.
3. Check to see that the hostname is correct in these locations:

4. Check to see any magic cookie related error messages in these locations:

For additional information, see the DT User's Guide


All times are GMT -5. The time now is 03:08 AM.