LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Home Forums Tutorials Articles Register
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris
User Name
Password
Solaris / OpenSolaris This forum is for the discussion of Solaris, OpenSolaris, OpenIndiana, and illumos.
General Sun, SunOS and Sparc related questions also go here. Any Solaris fork or distribution is welcome.

Notices


Reply
  Search this Thread
Old 07-08-2009, 05:26 PM   #1
net-wolf
LQ Newbie
 
Registered: Apr 2005
Distribution: Suse 9.2 Pro
Posts: 1

Rep: Reputation: 0
Need to set up Sendmail Relay for a remote IP


I am transitioning from Fedora 9 to Solaris 10. I have sendmail set up to work locally (on Solaris) and I can send mail from outside the network to the Solaris machine. (I've been through the [local = false] hoop. I can telnet into the machine to sendmail and everything works fine.

What I am trying to do now is set up sendmail on Solaris 10 by assigning a remote IP (that's not local) to be allowed. In Fedora this was quite easy ... and I am guessing that I am missing something easy to get this working with Solaris 10.

I have not figured out where to put the IP in the Solaris 10 config file to allow it ... and for the config to allow a specific IP to relay.

Thanks,

steve
 
Old 07-10-2009, 07:21 AM   #2
h@foorsa.biz
Member
 
Registered: Sep 2008
Posts: 30

Rep: Reputation: 17
on solaris 10 either its x86 or sparc
here i'll assume you have GigaEthernet interface
Code:
e1000g0
e1000g driver name
0 is the instance number
you can determine physical interfaces using
Code:
dladm show-dev | show-link
determine plumbed and loopback interfaces using
Code:
ifconfig -a
for an example
NIC naming within Solaris OS: i.e. e1000g0
IP Address - /etc/hostname.e1000g0
domain name - /etc/defaultdomain
netmask - /etc/inet/netmasks
hosts database -
Code:
 /etc/hosts
,
Code:
/etc/inet/hosts
- loopback & ALL interfaces
client DNS resolver file -
Code:
/etc/resolv.conf
default Gateway -
Code:
/etc/defaultrouter
node name -
Code:
 /etc/nodename
Plumb/enable the e1000g0
Code:
ifconfig e1000g0 plumb up
unplumb/disable the e1000g0
Code:
ifconfig e1000g0 unplumb down
ensure that newly-plumbed interface settings persists across reboots
Steps include updating/creating the following files:
/etc/hostname.e1000g0
Code:
echo "192.168.1.10" > > /etc/hostname.e1000g0
create entry in /etc/hosts - ipaddr xxx.xxx.xxx.xxx hostname
example
echo "dotted ipaddr dotted subnetmask" >> /etc/inet/netmasks
example
Code:
echo "192.168.1.10 255.255.255.0" >> /etc/inet/netmasks
i hope this helps
 
  


Reply



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sendmail: Mailing to remote domains not supported. How to set up config please? themrrobert Linux - Software 1 05-22-2009 08:27 AM
sendmail relay sachin1361 Linux - Enterprise 4 04-22-2008 06:32 PM
relay from remote pc ayush1440 Linux - Server 1 02-21-2008 01:46 PM
relay mail to sendmail relay server??? lemay_jeff Linux - Newbie 0 07-06-2004 04:54 PM
sendmail relay atomicx Linux - General 2 01-04-2004 01:46 AM

LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris

All times are GMT -5. The time now is 05:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration