LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris
User Name
Password
Solaris / OpenSolaris This forum is for the discussion of Solaris, OpenSolaris, OpenIndiana, and illumos.
General Sun, SunOS and Sparc related questions also go here. Any Solaris fork or distribution is welcome.

Notices


Reply
  Search this Thread
Old 03-21-2008, 08:09 PM   #16
madivad
Member
 
Registered: Jan 2007
Posts: 70

Rep: Reputation: 15

oh, isn't this pretty? :-)
Code:
dave@solaris:~$ cat /etc/release 
                  OpenSolaris Developer Preview 2 snv_79b X86

                         _        _     _         _ _                
           _ __ _ _ ___ (_)___ __| |_  (_)_ _  __| (_)__ _ _ _  __ _ 
          | '_ \ '_/ _ \| / -_) _|  _| | | ' \/ _` | / _` | ' \/ _` |
          | .__/_| \___// \___\__|\__| |_|_||_\__,_|_\__,_|_||_\__,_|
          |_|         |__/
ok, the problem has been found/solved. jlliagre, you were beaten by only a margin.

I admit the answer was found by posting in the opensolaris forums (I joined for this question alone <G>).

The problem is with the gnome terminal, if I use xterm, all the path options are correct (and overflowing with duplicates from the various places I have set it and now need to clean up).

then, using your latest suggestion of looking in .bashrc reveals the problem:
Code:
dave@solaris:~$ cat .bashrc
#
# Simple profile places /usr/gnu/bin at front,
# adds /usr/X11/bin, /usr/sbin and /sbin to the end.
#
# Use less(1) as the default pager for the man(1) command.
#
export PATH=/usr/gnu/bin:/usr/bin:/usr/X11/bin:/usr/sbin:/sbin
export MANPATH=/usr/gnu/share/man:/usr/share/man:/usr/X11/share/man
export PAGER="/usr/bin/less -ins"

#
# Define default prompt to <username>@<hostname>:<path><"($|#) ">
# and print '#' for user "root" and '$' for normal users.
#
PS1='${LOGNAME}@$(hostname):$(
    [[ "$LOGNAME" = "root" ]] && printf "${PWD/${HOME}/~}# " ||
    printf "${PWD/${HOME}/~}\$ ")'
dave@solaris:~$
edit: The OpenSolarus forum where I realised the problem was with terminal
http://www.opensolaris.org/jive/thre...55297&tstart=0

Last edited by madivad; 03-21-2008 at 08:10 PM.
 
Old 02-02-2009, 06:23 AM   #17
shashi_hlb
LQ Newbie
 
Registered: Feb 2009
Posts: 1

Rep: Reputation: Disabled
Solaris set the calsspath permanently

Quote:
Originally Posted by jlliagre View Post
Can you post the content of /etc/release to clarify ?
Did you look at the bash files ?
~/.bashrc
/etc/bash.bashrc
Hi i am shashi from india, how to create the .profile in solaris 10
It is not there in /etc/profile or ${HOME}/.profile.

Best Regards,
Shashi

Last edited by shashi_hlb; 02-02-2009 at 06:24 AM.
 
Old 02-02-2009, 02:59 PM   #18
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris 11.4, Oracle Linux, Mint, Ubuntu/WSL
Posts: 9,781

Rep: Reputation: 481Reputation: 481Reputation: 481Reputation: 481Reputation: 481
Welcome to LinuxQuestions.

Next time, please start a new thread instead of using an existing one which isn't particularly related.

There must be a /etc/profile on you Solaris 10 installation. This file is part of the OS.

If there is no $HOME/.profile, feel free to create one with a text editor.
 
Old 12-05-2011, 09:19 PM   #19
pk315
LQ Newbie
 
Registered: Oct 2009
Posts: 5

Rep: Reputation: 0
!! good

this is very useful.
 
Old 08-29-2014, 01:05 AM   #20
mosini
LQ Newbie
 
Registered: Aug 2014
Posts: 1

Rep: Reputation: Disabled
The solution

Dear All,
My OS is Oracle Solaris 10.
I did solve this by doing following steps:
1.login with root user
2.goto /usr/default
Code:
-bash-3.2$ cd /usr/default
3.enter this command: vi login
4.Then add following text in the login file,
As you know for inserting text, you need to press i character where u need to insert text.
I press i after this line: #PATH=/usr/bin:/usr/sfw/bin
Code:
# PATH sets the initial shell PATH variable
#
#PATH=/usr/bin:/usr/sfw/bin
(press i) and enter your path, my path was as following
PATH=/usr/bin:/usr/sbin:/usr/sfw/bin
5.after entering the above mentioned text press ESC and
the enter colon : and then press w! and finished.
6.for exiting press SHIFT+z+z
7.for seeing the result enter exit command to exit from root user.

Last edited by mosini; 08-29-2014 at 01:07 AM.
 
Old 08-29-2014, 03:23 AM   #21
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris 11.4, Oracle Linux, Mint, Ubuntu/WSL
Posts: 9,781

Rep: Reputation: 481Reputation: 481Reputation: 481Reputation: 481Reputation: 481
Hi mosini,

welcome to LQ and thanks for this posting.

Beware however that this thread is quite old and the original question was already answered eight years ago.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Set the path systemwide/Set the path for a user with Slackware jayhel Slackware 1 06-12-2005 12:24 AM
edit value of PATH permanently rsumbeling Linux - General 2 12-13-2004 10:57 AM
permanently adding to the path hyphenage Linux - General 12 07-16-2003 01:14 AM
How to set path permanently for a particular user Sifvion Slackware 14 10-16-2002 11:02 AM
How to set PATH permanently chandhru Linux - Newbie 3 09-24-2002 12:43 AM

LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris

All times are GMT -5. The time now is 05:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration