LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Solaris / OpenSolaris (https://www.linuxquestions.org/questions/solaris-opensolaris-20/)
-   -   Intel i210 or i217 NIC device driver? (https://www.linuxquestions.org/questions/solaris-opensolaris-20/intel-i210-or-i217-nic-device-driver-4175489422/)

kebabbert 12-28-2013 05:30 PM

Intel i210 or i217 NIC device driver?
 
I am using a Supermicro X10SAT mobo, and it has i210 and i217 ethernet controllers. Solaris 11.1 does not have device drivers for those NICs. OmniOS and Illumos has. Does anyone know how to get such a device driver? Maybe an OmniOS user can zip it up? I am thinking of installing OmniOS into VirtualBox, but I dont know which files I should copy from OmniOS to my Solaris 11.1 PC. What are the steps needed? And which files? Anyone knows?
https://illumos.org/issues/4090
http://omniti.com/remembers/2013/lat...d-environments

kebabbert 12-29-2013 06:47 AM

Ok, here is the driver:
http://rob.com/lancair/2013.12/igb.tar.bz2

But I dont know which commands to type. Anyone knows how to install a driver in Solaris 11.1?

kebabbert 12-29-2013 08:40 AM

I copied the files to /kernel/drv and rebooted, but nothing happens. There are still ethernet problems in the "Device Driver Utility" in Solaris 11.1. Do I need to detect the driver somehow? Something like "add_drv ...."?

jlliagre 12-29-2013 11:56 AM

What is your card id ?
Is it bound to igb driver in the /etc/driver_aliases file ?

kebabbert 12-29-2013 12:59 PM

Not sure if this is the information you want, but when I typed "prtconf -pv" and searched for "Ethernet", I saw two devices. I have two NICs in the Supermicro X10SAT, one Intel i210 and another i217. The output showed:

...
vendor-id: 00008086
device-id: 0000153a
...

...
vendor-id: 00008086
device-id: 00001533
...


If I search for "8086,153a" in /etc/driver_aliases, there is no entry. And neither is "8086,1533" in /etc/driver_aliases.

Is this the information you wanted?


EDIT; I see in the etc/driver_aliases file, several entries looking like:
igb "pciex8086,1523"
...
but not these two numbers I found in prtconf -pv command


EDIT 2: It is the 1533 device-id I want, according to:
http://pci-ids.ucw.cz/read/PC/8086
Because it is the i210, which I heard is better than the i217 NIC.

EDIT 3: I suspect I just have to add this line to /etc/driver_aliases at the end:
igb "pciex8086,1533"
But I have read I should not manually edit the file.

jlliagre 12-29-2013 02:54 PM

This should add the required line:

Code:

add_drv -i '"pciex8086,1533"' igb

kebabbert 12-29-2013 03:13 PM

It doesnt work. I typed your command, and Solaris said:
# add_drv -i '"pciex8086,1533"' igb
("igb") already in use as a driver or alias
# rem_drv igb
# add_drv -i '"pciex8086,1533"' igb
devfsadm: driver failed to attach: igb
Warning: Driver (igb) successfully added to system but failed to attach
# ifconfig -a
lo0:...
lo0:...
#


Now what?

jlliagre 12-29-2013 04:16 PM

Code:

devfsadm -v
dladm show-phys
ifconfig -a plumb


kebabbert 12-29-2013 04:22 PM

I typed the three commands, and no output. Whatsoever. I then tried to "add_drv..." again, and same error message popped up:
"("pciex8086,1533") already in use as a driver or alias"

your_shadow03 12-30-2013 01:41 AM

I am too facing the same issue with Dell OptiPlex XE2 having Integrated Intel® I217LM Ethernet LAN 10/100/1000.
I am using Solaris 10U11.
Kebabbert,
Any Luck? Will the same driver be applicable for Sol10u11?
I tried the same step which you tried but didnt work and it succeeded to install but failed to attach.

your_shadow03 12-30-2013 06:10 AM

I read that e1000g is the driver which is related to this card. Don't know if thats correct.

your_shadow03 01-01-2014 04:21 AM

I dont think its igb but its e1000g driver.

kebabbert 01-01-2014 09:57 AM

It is the "igb" driver, not e1000g driver that we need.

Oracle says that only the i210 driver exists in SRU 11 and 12, that is, new patches. So it seem likely that i210 will be supported in Solaris 11.2. The release date of S11.2 I have no idea.

I can not get i210 to work using the Illumos driver. Illumos devs guess the Illumos driver is incompatible with Oracle Solaris, due to probable GLD interface changes. So, I will just install another NIC until Solaris 11.2 comes out. But I dont know if i217 will be supported in S11.2?

"Device Driver Utility" in Solaris 11.1 reports three device driver problems on the Supermicro X10SAT motherboard, it reports two Ethernet driver problems and one Lynx Point driver problem. The Ethernet driver problems are the i210 and i217 NICs. So you can install another NIC. Regading the Lynx Point driver, it is about serial ports. So if you are not going to use serial ports in Solaris, then you can ignore that error, as well.

EDIT: It seems that Solaris and illumos are not driver compatible, as Oracle made many changes.

jlliagre 01-01-2014 02:44 PM

Actually, both the igb and the e1000g drivers are designed to handle Intel NICs.

The e1000g is for PCI attached cards (appear as pci8086,xxxx in prtconf output) while the igb is for PCI Express ones (pciex8086,xxxx).

kebabbert 08-13-2014 01:35 PM

I can report that Solaris 11.2 supports both Intel i217 and Intel i210 NICs. :)

-igb is the driver for the server oriented i210
-e1000g is the driver for the desktop oriented i217


All times are GMT -5. The time now is 06:35 PM.