LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris
User Name
Password
Solaris / OpenSolaris This forum is for the discussion of Solaris, OpenSolaris, OpenIndiana, and illumos.
General Sun, SunOS and Sparc related questions also go here. Any Solaris fork or distribution is welcome.

Notices


Reply
  Search this Thread
Old 07-25-2005, 04:44 PM   #1
jsheffie
Member
 
Registered: Dec 2004
Location: Florida, USA
Distribution: Suse 10.0, OSX.4, Solaris 10
Posts: 163

Rep: Reputation: 30
increasing password length...


Anyone know how to increase the accepted password length in Solaris 9? I tried the /etc/default/passwd deal to increase from default to my desired amount (>twelve)
It didn't do the trick.

Are there other things I can try without ripping apart the system?

Thanks
 
Old 07-25-2005, 06:27 PM   #2
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris 11.3, Oracle Linux, Mint
Posts: 9,716

Rep: Reputation: 422Reputation: 422Reputation: 422Reputation: 422Reputation: 422
You can't as long as you use the standard unix crypt algorithm, which pick the first 8 letters of the password to build its hash.

To change, either use a different backend for authenticating users (e.g. ldap) or replace the algorithm used to encrypt /etc/shadow password fields by setting CRYPT_DEFAULT=X in /etc/security/policy.conf
X=1 is for linux/bsd compatibility
X=2a is for blowfish
X=md5 is for ... md5

As all this is plugin based, you can even write your own plugin that demand say 32 minimal password length, and add it to the /etc/security/crypt.conf file
 
Old 07-26-2005, 08:54 AM   #3
jsheffie
Member
 
Registered: Dec 2004
Location: Florida, USA
Distribution: Suse 10.0, OSX.4, Solaris 10
Posts: 163

Original Poster
Rep: Reputation: 30
Thanks,

I went into thepolicy.conf file and chenged these two lines
FROM: #CRYPT_ALGORITHMS_DEPRECATE=__unix__
CRYPT_DEFAULT=__unix__

TO: (uncomment) CRYPT_ALGORITHMS_DEPRECATE=__unix__
CRYPT_DEFAULT=__2a__


Now when I attempt to change password I receive a segmentation fault.
 
Old 07-26-2005, 09:03 AM   #4
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris 11.3, Oracle Linux, Mint
Posts: 9,716

Rep: Reputation: 422Reputation: 422Reputation: 422Reputation: 422Reputation: 422
__2a__ is wrong, its 2a.
 
Old 07-26-2005, 09:59 AM   #5
jsheffie
Member
 
Registered: Dec 2004
Location: Florida, USA
Distribution: Suse 10.0, OSX.4, Solaris 10
Posts: 163

Original Poster
Rep: Reputation: 30
thanks, that worked
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Howto change system password policies (passwd length, complexity) tisource Linux - Security 3 09-06-2005 01:01 AM
Password length ust Linux - Distributions 1 04-06-2005 06:18 AM
Password length in SuSE 8.0 odin123 Linux - Security 3 05-24-2002 04:12 PM
Can't Change Min Password Length in RHL7.2 MikHud Linux - Security 2 04-16-2002 06:36 AM
Setting Minimum Password Length (RH 7.1) zyft02 Linux - Newbie 1 02-26-2002 09:49 AM

LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris

All times are GMT -5. The time now is 01:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration