LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Solaris / OpenSolaris (https://www.linuxquestions.org/questions/solaris-opensolaris-20/)
-   -   How to configure network with solaris? (https://www.linuxquestions.org/questions/solaris-opensolaris-20/how-to-configure-network-with-solaris-221164/)

subaruwrx 08-23-2004 12:42 AM

How to configure network with solaris?
 
Can't find in any of the gui program and not very familiar with solaris commands.

jev-bird 08-23-2004 01:39 AM

ifconfig should do it. Much more simpler to use dhcp. For instance if driver for your nic is rf0 do this from a terminal as root:

Code:

/sbin/ifconfig rf0 dhcp
That's assumed that the drivers for your nic are already loaded into your kernel. If they are not then you will have to install the driver, plumb it and maybe do some other stuff. The main thing is to find the correct driver for your nic. What kind of card is it?

subaruwrx 08-23-2004 01:57 AM

Quote:

Originally posted by jev-bird
ifconfig should do it. Much more simpler to use dhcp. For instance if driver for your nic is rf0 do this from a terminal as root:

Code:

/sbin/ifconfig rf0 dhcp
That's assumed that the drivers for your nic are already loaded into your kernel. If they are not then you will have to install the driver, plumb it and maybe do some other stuff. The main thing is to find the correct driver for your nic. What kind of card is it?

I not sure if the drivers are already loaded. How do I check?

Anyway, ifconfig rf0 returns "No such interface"

ppuru 08-23-2004 02:22 AM

you may need to ifconfig plumb rf0 before you actually go ahead and set the ip, etc.

subaruwrx 08-23-2004 02:29 AM

Quote:

Originally posted by ppuru
you may need to ifconfig plumb rf0 before you actually go ahead and set the ip, etc.
It said bad address. :confused:

Anyway I think my nic driver is not installed? Tried installing the driver, sheesh.. I doesn't have the "make" program installed as well :(

bathory 08-23-2004 03:43 AM

Try a prtconf -v to see if it lists any ethernet devices. If it does, note the name of the interface (hme, dmfe, rf or whatever) and then do:
ifconfig <interface+number i.e. hme0> IP netsmask xxx.xxx.xxx.xxx up.
Or better yet, to have your network configured from the beginning do a sys-unconfig.

subaruwrx 08-23-2004 04:41 AM

Quote:

Originally posted by bathory
Try a prtconf -v to see if it lists any ethernet devices. If it does, note the name of the interface (hme, dmfe, rf or whatever) and then do:
ifconfig <interface+number i.e. hme0> IP netsmask xxx.xxx.xxx.xxx up.
Or better yet, to have your network configured from the beginning do a sys-unconfig.

I just installed the driver, not sure if its working.I use "prtconf -pv". My NIC is DLink/Real Tek RTL8139.

Code:

        Node 0x1a7908
            assigned-addresses:  81005010.00000000.0000c800.00000000.00000100.82
005014.00000000.dfffff00.00000000.00000100
            class-code:  00020000
            compatible: 'pci1186,1300' + 'pci1186,1300' + 'pci1186,1300' + 'pcic
lass,020000'
            device-id:  00001300
            devsel-speed:  00000001
            fast-back-to-back:
            interrupts:  00000001
            max-latency:  00000040
            min-grant:  00000020
            model:  'PCI: 1186,1300 - class: Ethernet controller'
            name:  'pci1186,1300'
            power-consumption:  00000001.00000001
            reg:  00005000.00000000.00000000.00000000.00000000.01005010.00000000
.00000000.00000000.00000100.02005014.00000000.00000000.00000000.00000100
            revision-id:  00000010
            slot:  00000002
            subsystem-id:  00001300
            subsystem-vendor-id:  00001186
            unit-address:  'a'
            vendor-id:  00001186

Then I modify the /etc/drivers_alias to change rtls "pci1188,1301" to rtls "pci1186,1301". The driver added 3 lines to the file.

Code:

rtls "pci1186,1301"
rtls "pci10ec,8139"
rtls "pci1113,1211"

Did a ifconfig -a, it only have lo0. Tried eth0, rh0, all reply with "No such interface"

2) Another problem I encountered, I don't have the "make" program installed, any idea how can I install it from the solaris cd?

jlliagre 08-23-2004 05:40 AM

Make is usually at /usr/ccs/bin/make, it is installed when you do a full installation or a developer one.
If your software is demanding the gnu make, because of some of its extensions, you can also install it from varous freeware sites.

Concerning your network card, from the logs it looks like its name is rtls, so you need to do a:

ifconfig rtls0 plumb

to enable it, before any configuration can occur.

bathory 08-23-2004 05:40 AM

Then try ifconfig rtls0 plumb, ifconfig rtls0 IP netsmask xxx.xxx.xxx.xxx up
To add a package try: pkgadd -d /cdrom/<Package name>
But it's better to download the package from http://www.sunfreeware.com/ and do the pkgadd at the dir you've downloaded it.

subaruwrx 08-23-2004 05:54 AM

I tried rtls0, rtls1, rtls, all returned with "No such file or directory".

jlliagre 08-23-2004 06:56 AM

try: devfsadm -v

subaruwrx 08-23-2004 08:43 PM

Quote:

Originally posted by jlliagre
try: devfsadm -v
Done. Nothing came out.

subaruwrx 08-24-2004 01:38 AM

Ok I reinstalled solaris and reinstall the driver. Got this error.

cp rtls //kernel/drv/rtls
+ chmod 755 //kernel/drv/rtls
+ chown root:sys //kernel/drv/rtls
+ grep ^rtls\> /etc/name_to_major
+ add_drv -v -i "pci1186,1301" "pci10ec,8139" "pci1113,1211" rtls
exit status = 0
devfsadm: driver failed to attach: rtls
exit status = 11
Warning: Driver (rtls) successfully added to system but failed to attach
Driver (rtls) installed.
+ exit 0

I got my driver from http://www.realtek.com.tw/downloads/...eyword=solaris

There are also some information in the readme file in the driver folder that tells me to create the /etc/hostname.rtls0" file and modify some other related files to make my networking environments working well.

What information do I need to type in the /etc/hostname.rtls0 file and what are these "modify some other related files"?

Thanks in advanced.

bathory 08-24-2004 04:03 AM

In /etc/hostname.rtls0 you write the name of your host, but since you must change a lot of other files by hand it's better to use sys-unconfig to reconfigure your system.

subaruwrx 08-24-2004 04:08 AM

Quote:

Originally posted by bathory
In /etc/hostname.rtls0 you write the name of your host, but since you must change a lot of other files by hand it's better to use sys-unconfig to reconfigure your system.
So, what do I do next?


All times are GMT -5. The time now is 06:35 PM.