-   Solaris / OpenSolaris (
-   -   Failed to execute child process "xscreensaver" (

fakie_flip 09-09-2006 05:46 PM

Failed to execute child process "xscreensaver"
I just created created a normal system user with Sun Managment Console who belongs to the staff group. I logged in as that user. I never got this error untill now. I rebooted, and it happened again. Look in the picture:

jlliagre 09-10-2006 01:57 PM

That's a known bug, see:

fakie_flip 09-11-2006 03:11 PM

It's a bug, but I also found a fix for it by changing a variable in /etc/profile. I can't remember exactly what I did, but it worked. If anyone's having the same problem, he or she can send me an email, and I will find out what I did. :D

jlliagre 09-11-2006 03:22 PM

Well, the fix is in the second link I posted, i.e. adding /usr/openwin/bin to the PATH.

fakie_flip 09-16-2006 11:29 PM

It's been fixed.

eozakos 10-21-2008 01:58 AM

hi there,

I tried "PATH=$PATH:/usr/openwin/bin" in .profile but it didn't work for me.I can log in by root but i can't log in with my other username.It appears "failed to execute child process "xscreensaver"" in my other username.Can you help me get through with this??

P.S:when i switch to other username from root,commands doesn't work in terminal

jlliagre 10-21-2008 02:45 AM

Can you clarify what Solaris version you are using, when does the message appears, does it prevent you from login in as a non root user ?

What is the PATH when you switch to the other username ?

eozakos 10-21-2008 07:49 AM

I am using Solaris 10g.It doesn't prevent me logging as a non root user but after logging on Solaris "failed to execute child process" and nothing in the screen appears.

All times are GMT -5. The time now is 11:05 PM.