LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Solaris / OpenSolaris (https://www.linuxquestions.org/questions/solaris-opensolaris-20/)
-   -   facing problems with nfs (https://www.linuxquestions.org/questions/solaris-opensolaris-20/facing-problems-with-nfs-404895/)

saradhi 01-18-2006 08:07 AM

facing problems with nfs
 
Hello friends
I am facing problems with NFS,I shared one mount point /home and one directory /dring in /etc/dfs/dfstab file. Then I stopped and started the rpc service in /etc/init.d and if I try to start the nfs.server service it is saying there is no entries in /etc/dfs/dfstab file. How to rectify this problem. I am unable to solve this problem, please kindily help me.

jlliagre 01-18-2006 08:30 AM

Post your /etc/dfs/dfstab file content, the command used to restart the service and the error message returned.

saradhi 01-18-2006 08:45 AM

#vi /etc/dfs/dfstab
share -F nfs /home
share -F nfs /dring
:wq!
#cd /etc/init.d
then I started rpc service successfully
#./rpc stop
#./rpc start
#./nfs.server stop
if I try to start nfs.server service
#./nfs.server start
it is giving below error message
/etc/dfs/dfstab file does'nt contain any entry's

jlliagre 01-18-2006 11:06 AM

What happens if you directly run the share commands:
Code:

share -F nfs /home
share -F nfs /dring


javier.e.menendez 01-31-2006 05:13 PM

try pgrep -l nfsd and mountd. But there is a catch here. /home is to be used for automounting home directories and you should share /export/home, not /home. In solaris, /home and /net are used exclusively for autofs.

Try this:

echo share /dring >> /etc/dfs/dfstab
/etc/init.d/nfs.server start
dfshares <- shows what you are sharing
nfsd and mountd should be running now.

jlliagre 02-01-2006 03:29 AM

Quote:

In solaris, /home and /net are used exclusively for autofs.
Well, better to write they are by default used by autofs, nothing forbid to comment out the /home map, and have this directory behaving as usual.
This doesn't mean I recommend to do it, the automounter is a great feature.

javier.e.menendez 02-01-2006 05:14 AM

I agree. We typically use /home to automount /export/home when using a naming service like nis or nisplus. Also, notice that if you create a user
account with smc (why would you, well that is a different story), it points to /home rather than /export/home and automatically mount /export/home itself.

But I like autofs as well, so I would never modify /etc/auto_master to then allow /home to behave as a "normal" directory.

qs_tahmeed 02-01-2006 01:29 PM

Hello!

I may be all wrong but I put an "-o ro" at the "share -F nfs /dir" line when I saw
that kind of message during NFS Setup.

In my case it fixed the problem.

Cheers ....

javier.e.menendez 02-02-2006 06:12 AM

Qs_tahmeed:

I am glad that it worked for you but with nfs, you should have been able to share
that directory (/dring?) either rw or ro. The default is rw. So I don't see why that did not work. You syntax looked correct at the top of the post. Just a note, you can skip the -F nfs since that is the default as well (check out /etc/dfs/fstypes). Also I don't know if you are running 10 or below but if you are running 10, you could have typed svcs -a | grep nfs to see the state of the nfs services. It's kind of cool that they left /etc/init.d/nfs.server for backward compatibility even though it calls upon svcadm.

But good for you anyhow


All times are GMT -5. The time now is 12:43 PM.