LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris
User Name
Password
Solaris / OpenSolaris This forum is for the discussion of Solaris, OpenSolaris, OpenIndiana, and illumos.
General Sun, SunOS and Sparc related questions also go here. Any Solaris fork or distribution is welcome.

Notices


Reply
  Search this Thread
Old 05-20-2011, 12:01 PM   #1
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,824

Rep: Reputation: 615Reputation: 615Reputation: 615Reputation: 615Reputation: 615Reputation: 615
Disable IPv6 autoconfig on Solaris 9/10


Hi,

I have a Solaris 9 system and a 10 system I have successfully configured with a static IPv6 address and route. I received the addresses from the network gods here, and I can't use autoconfig for my users' purposes because they want the address to be in DNS (autoconf doesn't put the address into DNS, and DHCPv6 is not used here).

Now, I would like to disable the autoconfiguration, to prevent possible confusion with my users ("Why is ipv6 traffic coming from a different address than what's in DNS?" "What's this second address in the output of 'ifconfig'?").

For Solaris 10, I have read that entering
Code:
if-variable-name StatelessAddrConf false
into /etc/inet/ndpd.conf will do this. However, that does not seem to be the case as after editing that file and rebooting, the autoconfigured address still appears.

For Solaris 9, I have been unable to find documentation on how to potentially disable autoconf. I tried the same way as in the previous paragraph, but that just gets me an "unknown variable" error.

Is there a way to disable IPv6 address autoconfiguration on 9 & 10? How?
 
Old 05-23-2011, 03:51 PM   #2
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,824

Original Poster
Rep: Reputation: 615Reputation: 615Reputation: 615Reputation: 615Reputation: 615Reputation: 615
Code:
ifdefault StatelessAddrConf off
in ndpd.conf

This seems to work for Solaris 9, though StatelessAddrConf is not mentioned in the man page for ndpd.conf. Will reboot the 10 box later today or tomorrow to test, but I expect it to work.

On both, the man page states that passing -a to in.ndpd will also achieve this.

http://dlc.sun.com/osol/docs/content...-64.html#gbuzm clearly states to paste the contents of the following box (which is in code tags in my original post) into ndpd.conf and makes no mention of having to substitute something in for "if-variable-name". Sigh.
 
1 members found this post helpful.
Old 05-23-2011, 04:37 PM   #3
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris 11.3, Oracle Linux, Mint, Tribblix
Posts: 9,754

Rep: Reputation: 457Reputation: 457Reputation: 457Reputation: 457Reputation: 457
Thanks for the feed-back !
 
Old 05-24-2011, 03:27 PM   #4
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,824

Original Poster
Rep: Reputation: 615Reputation: 615Reputation: 615Reputation: 615Reputation: 615Reputation: 615
Addendum: despite the warning from the Solaris 9 machine on boot:
Code:
Unknown variable <StatelessAddrConf> on line 1 <ifdefault StatelessAddrConf off>
, autoconfiguration does not seem to happen with the above in ndpd.conf.

Also, on Solaris 10, an alias like the following appears. This entry is different from the autoconfigured IP it had earlier and I'm not sure what it is.
Code:
ce0:2: flags=20a0841<UP,RUNNING,MULTICAST,NOLOCAL,ADDRCONF,IPv6> mtu 1500 index 2
        inet6 subnet 2001:db8:c000:212::/64

Last edited by AlucardZero; 05-24-2011 at 03:29 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't disable IPv6 bhamid Linux - Networking 10 04-30-2013 03:13 AM
Best Way to disable IPV6 idlehands Linux - General 6 12-04-2012 10:58 AM
How to Disable ipv6 in ubuntu 9.04 si.erkac Linux - Networking 7 03-18-2010 09:18 AM
[SOLVED] how can i disable the ipv6 address only? v_fone Linux - Networking 11 08-01-2009 05:54 AM
Disable IPV6 bjb_nyj101 Linux - Software 2 06-07-2007 10:54 PM

LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris

All times are GMT -5. The time now is 06:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration