LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris
User Name
Password
Solaris / OpenSolaris This forum is for the discussion of Solaris, OpenSolaris, OpenIndiana, and illumos.
General Sun, SunOS and Sparc related questions also go here. Any Solaris fork or distribution is welcome.

Notices


Reply
  Search this Thread
Old 09-01-2007, 07:17 PM   #1
rockcharles1
LQ Newbie
 
Registered: Sep 2007
Posts: 7

Rep: Reputation: 0
Lightbulb change to 1000MB full duplex for Solaris 10 ce


I am running Solaris with two NICs in the box ce0 ce1. Is there any way to get full duplex 1000

FYI


bash-2.05# netstat -k ce0 | egrep 'link_speed|link_status|link_duplex'
lp_cap_asmpause 1 lp_cap_pause 0 link_T4 0 link_speed 1000
link_duplex 2 link_asmpause 0 link_pause 0 link_up 1 mac_mtu 1522

bash-2.05# netstat -k ce1 | egrep 'link_speed|link_status|link_duplex'
lp_cap_asmpause 0 lp_cap_pause 0 link_T4 0 link_speed 10
link_duplex 1 link_asmpause 0 link_pause 0 link_up 1 mac_mtu 1522

See in ce1 link speed is 10 mpbs its should be same as that ce0 , please help me ,

when i tried to set

ndd -set /dev/ce1 adv_1000fdx_cap 1
open of /dev/ce1 failed: No such file or directory


Charles
 
Old 09-02-2007, 03:41 AM   #2
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris 11.3, Oracle Linux, Mint, Tribblix
Posts: 9,756

Rep: Reputation: 459Reputation: 459Reputation: 459Reputation: 459Reputation: 459
Try these commands:
Code:
# ndd -set /dev/ce instance 1
# ndd -set /dev/ce adv_1000fdx_cap 1
# ndd -set /dev/ce adv_autoneg_cap 1
By the way, you cannot force an interface to run at 1GB/S like you can do with 100Mb/s or lower. This speed must be negotiated according to the IEEE standard.

Last edited by jlliagre; 09-02-2007 at 08:53 AM.
 
Old 09-02-2007, 07:26 AM   #3
rockcharles1
LQ Newbie
 
Registered: Sep 2007
Posts: 7

Original Poster
Rep: Reputation: 0
after added the command ce1 still shows same 10x only

Aug 31 16:52:23 eqoas322 genunix: [ID 611667 kern.info] NOTICE: ce1: xcvr addr:0x01 - link up 10 Mbps half duplex
Aug 31 17:04:58 eqoas322 genunix: [ID 611667 kern.info] NOTICE: ce1: xcvr addr:0x01 - link up 10 Mbps half duplex
 
Old 09-02-2007, 08:52 AM   #4
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris 11.3, Oracle Linux, Mint, Tribblix
Posts: 9,756

Rep: Reputation: 459Reputation: 459Reputation: 459Reputation: 459Reputation: 459
Are you sure this interface is connected to a properly configured and working gigabit network ?
 
Old 09-02-2007, 10:19 AM   #5
rockcharles1
LQ Newbie
 
Registered: Sep 2007
Posts: 7

Original Poster
Rep: Reputation: 0
yep interface are ok cable and switch are ok.. ce1 card 1000mbps but it show always 10 mbps , but see ce0 automatically converted to 1000 , but only problem with ce1
 
Old 09-02-2007, 10:35 AM   #6
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris 11.3, Oracle Linux, Mint, Tribblix
Posts: 9,756

Rep: Reputation: 459Reputation: 459Reputation: 459Reputation: 459Reputation: 459
So if you swap the cables plugged to ce0 and ce1, what does dmesg reports ?
 
Old 09-06-2007, 01:56 PM   #7
rockcharles1
LQ Newbie
 
Registered: Sep 2007
Posts: 7

Original Poster
Rep: Reputation: 0
Wink

Problem Solved!!!!



The network cable is wrongly connected to gmaamm RSC Vice versa , after changing gmaamm mgt and gmaamm RSC it shows 1000





netstat -k ce1 | egrep 'link_speed|link_status|link_duplex'

lp_cap_asmpause 1 lp_cap_pause 0 link_T4 0 link_speed 1000

link_duplex 2 link_asmpause 0 link_pause 0 link_up 1 mac_mtu 1522

$
Note (gmaamm mean server name)

Thanks for every one help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
change to 1000MB full duplex for Solaris 8,9,10 DarReNz Solaris / OpenSolaris 17 07-02-2007 11:54 AM
Change Network sped from 100meg to 10meg full duplex jakeconnor Linux - Networking 3 05-31-2007 01:39 AM
full duplex chazzwozzer Linux - Networking 1 02-07-2005 03:11 PM
Trying to get 10base Full Duplex.. HELP??? richhoward Linux - Networking 1 06-04-2003 05:51 PM
Full/Half Duplex??? LupusNebula Linux - Networking 8 02-04-2003 04:33 PM

LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris

All times are GMT -5. The time now is 08:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration