LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Solaris / OpenSolaris (https://www.linuxquestions.org/questions/solaris-opensolaris-20/)
-   -   Cannot type on Reflection X connection to Solaris. (https://www.linuxquestions.org/questions/solaris-opensolaris-20/cannot-type-on-reflection-x-connection-to-solaris-688240/)

uks 12-04-2008 04:49 AM

Cannot type on Reflection X connection to Solaris.
 
I am connecting to my Solaris 10 server from a windows machine using Reflection X.
The machine shows up alright. The login screen is visible with the cursor flashing on the username field.
But when I type my username it will not respond.
The cursor just keeps flashing.

I can connect to my Solaris 8 and 9 servers using this without any problem. Any help would be much appreciated.

uks 12-05-2008 04:05 AM

I found only this on google:
http://www.starnet.com/xwin32kb/Unab...on_Solaris_10/

But that wont help either!!!

eggixyz 12-05-2008 10:39 PM

hey there,

I would say, use Xwin-pro or something else free ;)

J.k. I've had that problem before, too, at a previous place of work. I was able to get around it by just blind typing:

stty echo

if that doesn't work try blind typing

reset

or

echo -e \033c

or

stty sane

or

tput reset

or

tput init

or, oddly enough,

cat /bin/cat

although this may not be applicable to your situation. Worth a shot :)

Best wishes,

Mike

jlliagre 12-06-2008 12:18 AM

Eggxyz, how do you expect the OP to enter CLI commands while he/she doesn't seem to be able to log in ?

Uks, is this login screen the graphical "Login/Password" interface or are you connecting through a telnet/ssh session ?

eggixyz 12-06-2008 04:05 AM

Whoops ;) Sorry about that. I speed-read and assumed already logged in.

If not logged in, try logging in without specifying a login name or password. if you're using ssh, you can set up key auth from your machine to the Sun box. Using Reflection's scp/sftp client, you can enter your username and password to put the key up there and get around the terminal issue. And if scp'ing with their client doesn't connect you (assuming, again, that it's supposed to) then the problem might be with the connection and not the login.

Best wishes,

Mike

uks 12-08-2008 06:18 AM

I am able to login using a telnet/ssh session.
This is a problem only with the remote gui using Reflection X(thats the only tool we have for gui)
So,having answered Jillagre's question let me test eggxyz's suggestions.
I will let you know if it works.

uks 12-08-2008 09:47 AM

eggxyz's suggestions did not help.
I am unable to do anything. Tried rebooting(with ppl hounding me) but that did not help.
I have been thru this previously but rebooting has always helped me.

eggixyz 12-09-2008 12:02 AM

Hey again,

When you say GUI, I'm assuming your exporting an X display back to your regular computer (or making X available for others to use). I can see tunnelling through SSH, but I'm confused about the part Telnet plays in this (Forgive my ignorance if this is something Reflection can do - it's been a while)

Hope one of us will be able to help you and you can get back on track.

Just repeat - it'll all be over soon :)

Best wishes,

Mike

jlliagre 12-09-2008 02:39 AM

I think the login GUI is just that, the dtlogin login/password window that is remotely provided through XDMCP.
Uks, can you exercise the push buttons and menus appearing on that screen ?
Was that screen customized ?
Are you using the CDE (default) one or GDM (gnome) ?

uks 12-10-2008 06:48 AM

Hello jlliagre and Mike,

jlliagre is right.
The push buttons are working. I can click on Options, Help etc....
I tried both CDE and JDS without help. :(

jlliagre 12-10-2008 07:27 AM

Quote:

Originally Posted by uks (Post 3370294)
I tried both CDE and JDS without help. :(

How was you able to try CDE or JDS if you cannot login in the first place ?

uks 12-10-2008 09:17 AM

I dont know if I can attach a pic of it here....I can get to my login screen and there are 4 push buttons, viz, OK, Startover, OPtions and Help.
Under Options I have Session and have the option to choose CDE or JDS....
Like I said earlier, I can use my mouse on these push buttons and they work.
But when I start typing my username it wont agree....Hope this clarifies.
So basically its just the keyboaard that I am unable to use, Meaning, all the users, about 100 of em have the same problem....
Also, I am able to open a telnet/ssh to this machine....So I can login, but cannot use a remote GUI.

jlliagre 12-10-2008 11:50 AM

Okay. From your description, you are using the default CDE login screen.

I have no idea about what might prevent keyboard events to reach that dialog. Did you look at your X server (Reflection X) error log file ?

You might also want to try switching to the GDM login screen.

These two commands should do it:
Code:

svcadm disable cde-login
svcadm enable gdm

Depending on the Solaris version, the second line might be:
Code:

svcadm enable gdm2-login

uks 12-15-2008 06:32 AM

Both of that dont work.
I got the check the physical machine today and I see that i am unable to login at the machine itself.
So its not just on Reflection, its on the physical machine itself that I see this problem...

Sorry if I have mislead you guys...
I saw this http://sunsolve.sun.com/search/docum...ey=1-9-81175-1 on the Sun site but thats the same I tried earlier...no help.

uks 12-15-2008 07:47 AM

svcs -x -v /application/gdm2-login:default
svcs: svcs.c:329: Unexpected libscf error: invalid argument. Exiting.
svc:/application/gdm2-login:default-bash-3.00


So gdm2 goes to the maintanence mode.... I am totally confused here.


All times are GMT -5. The time now is 10:57 AM.