LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation
User Name
Password
Slackware - Installation This forum is for the discussion of installation issues with Slackware.

Notices


Reply
  Search this Thread
Old 11-24-2005, 12:16 AM   #1
rsamurti
Member
 
Registered: Dec 2003
Location: Mysore
Distribution: Mandrake, Libranet, Slackware
Posts: 104

Rep: Reputation: 15
Your session only lasted less than 10 seconds...


Hello,

When I try to login as a non-root user after power up, in Slackware 10.2+FRG-2.12.1 through GDM, I get the following error message:

Your session only lasted less than 10 seconds. If you have not logged out yourself, this could mean that there is some installation problem or that you may be out of disk space. Try logging in with one of the failsafe sessions to see if you can fix this problem.

This is the content of ~/.xsessions file:

stderr is not a tty -- where are you?
_IceTransSocketUNIXCreateListener: ... SocketCreateListener() failed
_IceTransMakeAllCOTSServerListener: server already running
** (gnome-session:6194): WARNING **: cannot establish any listening sockets

After one or two subsequent attemps, I will be able to login. After successful login, this problem is not repeated until another power up.

This problem is not seen when I login as root.

I have observed this problem even in Slack 10 and Slack 10.1. But so far I am unable find a fix for this. Any hints?

Thanks for your help.

Anand
 
Old 11-24-2005, 12:58 AM   #2
Artanicus
Member
 
Registered: Jan 2005
Location: Finland
Distribution: Ubuntu, Debian, Gentoo, Slackware
Posts: 827

Rep: Reputation: 31
im guessing you have diskspace left, and your /tmp is on a partition that has diskspace left?
 
Old 11-24-2005, 09:41 AM   #3
rsamurti
Member
 
Registered: Dec 2003
Location: Mysore
Distribution: Mandrake, Libranet, Slackware
Posts: 104

Original Poster
Rep: Reputation: 15
My /tmp has enough space.
 
Old 12-21-2005, 07:14 PM   #4
spelltoronto
Member
 
Registered: Jan 2005
Location: San Diego, CA
Posts: 36

Rep: Reputation: 15
I'm having this same problem...does anyone know of a fix? Strange thing is, this problem also happens when I try to log in as root, as well as any other user account. And, the .xsession-errors file is always empty, so it's as if no errors are being written to the log. I've tried emptying /tmp, chaning permissions on the files in /tmp....but no luck.

Any suggestions are appreciated.
 
Old 01-08-2006, 05:54 PM   #5
tincuchalice
LQ Newbie
 
Registered: Dec 2005
Posts: 5

Rep: Reputation: 0
I just had this problem trying to remotely configure my red-hat e3 box from a mac laptop to accept the MAC as an X-Client. I fiddled with some /etc/X11 files and kill -HUP the /usr/X1196/bin line. I think this caused it. I tried removing .ICEAuthority but no help. I can log in as root but no good. Now I get Xlib: connection to ":0.0" refused by server if i su to username then gnome-session or startkde. All I know is that it had something to do with changing the /etc/X11 files and/or kill -HUP the XServer. Anyone gets anywhere or if I do pls repost
 
Old 01-09-2006, 01:55 PM   #6
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
Can you post your etc/gdm/Xsession file? Smth can be badly configured there.
 
Old 01-10-2006, 11:53 AM   #7
tincuchalice
LQ Newbie
 
Registered: Dec 2005
Posts: 5

Rep: Reputation: 0
I did not have that file there but did in /etc/X11/xdm

#!/bin/bash
# Copyright (c) 1999-2002 Red Hat, Inc.

# redirect errors to a file in user's home directory if we can
errfile="$HOME/.xsession-errors"
if cp /dev/null "$errfile" 2> /dev/null ; then
chmod 600 "$errfile"
exec > "$errfile" 2>&1
else
errfile=`mktemp -q /tmp/xses-$USER.XXXXXX`
if [ $? -eq 0 ]; then
exec > "$errfile" 2>&1
fi
fi

if ! printenv PATH | grep -q /usr/X11R6/bin
then
PATH="${PATH}":/usr/X11R6/bin
fi

xsetroot -solid '#5477A0'

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
userxkbmap=$HOME/.Xkbmap

sysresources=/etc/X11/Xresources
sysmodmap=/etc/X11/Xmodmap
sysxkbmap=/etc/X11/Xkbmap

# merge in defaults
if [ -f "$sysresources" ]; then
xrdb -merge "$sysresources"
fi

if [ -f "$userresources" ]; then
xrdb -merge "$userresources"
fi

# merge in keymaps
if [ -f "$sysxkbmap" ]; then
setxkbmap $(cat "$sysxkbmap")
XKB_IN_USE=yes
fi

if [ -f "$userxkbmap" ]; then
setxkbmap $(cat "$userxkbmap")
XKB_IN_USE=yes
fi

if [ -z "$XKB_IN_USE" -a ! -L /etc/X11/X ]; then
if grep '^exec.*/Xsun' /etc/X11/X > /dev/null 2>&1 && [ -f /etc/X11/XF86Config ]; then
xkbsymbols=`sed -n -e 's/^[ ]*XkbSymbols[ ]*"\(.*\)".*$/\1/p' /etc/X11/XF86Config`
if [ -n "$xkbsymbols" ]; then
setxkbmap -symbols "$xkbsymbols"
XKB_IN_USE=yes
fi
fi
fi

# xkb and xmodmap don't play nice together
if [ -z "$XKB_IN_USE" ]; then
if [ -f "$sysmodmap" ]; then
xmodmap "$sysmodmap"
fi

if [ -f "$usermodmap" ]; then
xmodmap "$usermodmap"
fi
fi

unset XKB_IN_USE

# run all system xinitrc shell scripts.
for i in /etc/X11/xinit/xinitrc.d/* ; do
if [ -x "$i" ]; then
. "$i"
fi
done

# is ssh-agent available?
SSHAGENT=
[ -x /usr/bin/ssh-agent ] && SSHAGENT="/usr/bin/ssh-agent"

# now, we see if xdm/gdm/kdm has asked for a specific environment
case $# in
1)
if [ -x /usr/share/apps/switchdesk/Xclients.$1 ]; then
exec -l $SHELL -c "$SSHAGENT /usr/share/apps/switchdesk/Xclients.$1";
fi;

case $1 in
failsafe)
exec -l $SHELL -c "xterm -geometry 80x24-0-0"
;;
gnome)
exec -l $SHELL -c "$SSHAGENT gnome-session"
;;
kde|kde1|kde2)
exec -l $SHELL -c "$SSHAGENT /usr/share/apps/switchdesk/Xclients.kde"
;;
twm)
# fall back to twm
exec -l $SHELL -c "$SSHAGENT /usr/share/apps/switchdesk/Xclients.twm"
;;
esac
esac

# otherwise, take default action
if [ -x "$HOME/.xsession" ]; then
exec -l $SHELL -c "$SSHAGENT $HOME/.xsession"
elif [ -x "$HOME/.Xclients" ]; then
exec -l $SHELL -c "$SSHAGENT $HOME/.Xclients"
elif [ -x /etc/X11/xinit/Xclients ]; then
exec -l $SHELL -c "$SSHAGENT /etc/X11/xinit/Xclients"
else
# should never get here; failsafe fallback
exec -l $SHELL -c "xsm"
fi
 
Old 02-19-2006, 09:37 PM   #8
royjones
LQ Newbie
 
Registered: Feb 2006
Distribution: Fedora Core 3
Posts: 1

Rep: Reputation: 0
Re: "Your session only lasted 10 seconds...."
I'm not very skilled using command-line stuff in Linux so here is what worked for me:
1. Log in as root rather than your normal user name.
2. Access the User Manager via APPLICATIONS, SYSTEM SETTINGS, USERS AND GROUPS
3. Correct the Home Directory that is shown for the normal user name. Mine incorrectly showed "/root" as the home directory. I changed it to "/home/username". Reboot and log in normally. All works fine now. Hope this helps someone else.
 
Old 02-24-2006, 07:31 AM   #9
Satriani
Member
 
Registered: Mar 2003
Location: The Netherlands
Distribution: Red Hat 7.3, Red Hat 9, Solaris8, Slackware 10, Slax on USB, AIX, FreeBSD, WinXP, AIX, Ubuntu
Posts: 418

Rep: Reputation: 30
I have seen this problem too...
It turned out to be that the rights in the users home folder weren't set correctly, especially the ~/.gnome dirs....
For some strange reason, these dirs were uid root...
Setting the right permissions fixed the problem, hopefully for you the same.

Last edited by Satriani; 02-24-2006 at 07:32 AM.
 
Old 03-22-2006, 08:04 AM   #10
tuesdays-child
LQ Newbie
 
Registered: Mar 2006
Distribution: Fedora Core 4
Posts: 6

Rep: Reputation: 0
I have the exact problem! But i know what cause mine. I accidentally, like root issued ( rm -rf ) and deleted whole /tmp directory and it's sub-dir's. I know, silly but now i cannot log like regular user, just like super-user only. Well i guess now I'm off to search how to fix this problem i casued myself .

btw --I am FC4 user

Last edited by tuesdays-child; 03-22-2006 at 08:06 AM.
 
Old 12-11-2007, 04:59 PM   #11
MadTurki
Member
 
Registered: Nov 2003
Location: Toronto
Distribution: RedHat 9, Mandrake 10, OS X
Posts: 114

Rep: Reputation: 15
I don't know if this is against the forum rules, but I'm sure there's some sort of sexual joke refering to the title of this thread...

Can someone help me? My last session only lasted 10 seconds...
 
Old 04-18-2008, 11:49 AM   #12
bighaubs
LQ Newbie
 
Registered: Jan 2008
Location: MD
Posts: 1

Rep: Reputation: 0
Check /tmp permissions

Had this same problem. In my case the permissions on /tmp were not set correctly due to the way we restored the system. To fix the problem, had to change the permissions to 777 by issuing the command:

chmod 1777 /tmp

Once I did this, I was able to log in as a regular (non root) user and all our problems were solved.

In our case this was with RHEL, but I'm assuming you could have a similar issue.
 
Old 07-13-2009, 02:11 PM   #13
tory2brh
LQ Newbie
 
Registered: Jan 2006
Posts: 2

Rep: Reputation: 0
Try deleting .Xclients
In my case I think switchdesk left this around.
-toryt
 
Old 10-13-2011, 03:24 AM   #14
MEETKAMBOJ
Member
 
Registered: May 2010
Posts: 41

Rep: Reputation: 0
Creat /tmp Directory in home Partition and give full permission. then restart pc
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
"your last session only lasted less than 10 seconds" supwiddiss SUSE / openSUSE 6 08-10-2007 07:19 AM
Your session only lasted for less than 10 seconds Raafi Linux - Newbie 5 04-17-2005 05:56 PM
Oracle 10g and Fedora 2.0 "Session lasted lesst than 10 seconds" ushradha Linux - Software 6 11-19-2004 11:04 PM
Your session lasted for < 10 seconds ... rsamurti Slackware 4 06-27-2004 09:24 AM
Session lasted less than 10 seconds. Your HDD maybe full pnh73 Red Hat 6 09-02-2003 08:48 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation

All times are GMT -5. The time now is 11:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration