-   Slackware - Installation (
-   -   USB keyboard doesn't work - Slackware 14.0 64-bit (

Zookeeper 11-24-2013 11:14 AM

USB keyboard doesn't work - Slackware 14.0 64-bit
Hello everyone. This is my first post, so please be kind!

I'm trying to install Slackware 14.0 64-bit from the DVD onto a GA-970A-D3 BIOS version FC with a FX6300. At the second prompt <OPTION TO LOAD SUPPORT FOR NON-US KEYBOARD> it prompts me with

Enter 1 to select a keyboard map:

I press 'ENTER' and no response. I can't get past this.

I'm writing this post on a functioning 14.0, 64-bit system, a ZH77A-G43 with a i5 which installed without a hitch, so I'm guessing that either I have to set something in the BIOS, and/or I have to specify some parameters along with 'huge.s'. When I'm in the BIOS set-up on the problem machine the mouse and keyboard work, so it seems that the mouse, keyboard, USB ports, etc work.

I've read through some related posts that I've found here already, but nothing seems to be exactly the right problem.

Thank you very much for any assistance with this.

Jim Haluska

henkees 11-24-2013 11:36 AM

Find out where your keyboard is connected to on a terminal with lsusb.
When you start the install cd, do you have a working keyboard in the beginning?
If so, than you can pass extra parameters to the kernel (first question / prompt by starting the install cd).
Try: console=/dev/ttyUSB<your usb number here>
example: console=/dev/ttyUSB1
If that doesn't work, you can try with the default: console=/dev/tty0

Zookeeper 11-24-2013 01:27 PM


Thank you very much for your suggestions. I tried both and, unfortunately, neither worked. The result was the system hanging at 'Booting the kernel'.

But you have inspired me to start studying all those kernel parameters to see if I can figure out what's going on.

If it's of any interest I used Puppy Linux to find the USB device numbers, and both the mouse and keyboard worked with Puppy. I've been fiddling with this for hours now and it's worn me out, but when I get back I think I'm going to look through the Puppy start-up log and compare it to the Slackware start-up log and see if I can see anything.

Thanks again for your help.

Jim Haluska

henkees 11-25-2013 06:06 PM

When I google your processor, you have an UEFI bios.
I found something little bit similar on another forum:

So maybe you can enable IOMMU in the bios, and try out to boot the kernel from the install-cd on the first prompt (where you can pass extra options to the kernel) with:

I hope this helps...

Zookeeper 11-26-2013 07:22 AM


iommu=soft worked! IOMMU was already enabled.

Thank you so much for digging out the solution. I spent about four days trying to get this working. I'd seen the UEFI many times on the box but I never looked it up to find out what it meant--my error.

Jim Haluska

All times are GMT -5. The time now is 12:05 AM.