-   Slackware - Installation (
-   -   Upgrade from -11.0 to -12.0: Can No Longer Print (

rshepard 12-01-2008 01:42 PM

Upgrade from -11.0 to -12.0: Can No Longer Print
My HP LaserJet 5 with a JetDirect card has been working perfectly for years under Slackware. I just tried to print a web page but could not. The problem is apparently a socket failure.

Here is the appropriate section from /etc/cups/printers.conf:

<DefaultPrinter laser5_duplex>
Info Double-sided printing
Location office
DeviceURI socket://lj5:9100/
State Stopped
StateMessage /usr/lib/cups/backend/socket failed
StateTime 1228158485
Accepting Yes
Shared Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
ErrorPolicy stop-printer

How do I fix this?


rshepard 12-01-2008 08:52 PM


Using the laser5_duplex or laser5_single definitions from the command line or within xpdf/gv produces a failed socket message when 'lpstat -p -d' is run. Nothing comes out the printer. However, if I specify the default laser5 printer name, the job prints from both the command line and from within xpdf.

I still need to fix this quickly since business checks must be printed single-sided and I need that definition to work for them.

This seems inexplicable to me: the generic definition works, but the _single and _duplex definitions don't.

Your help is still needed.


rshepard 12-01-2008 09:15 PM


Taking a round-about way to the web-based CUPS admin pages I was able to cancel all pending print jobs, restart the printers (which cleared the failed socket messages), print test pages, and print from the command line and xpdf.

This thread is closed as the problem has been solved.


All times are GMT -5. The time now is 03:24 PM.