LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation
User Name
Password
Slackware - Installation This forum is for the discussion of installation issues with Slackware.

Notices


Reply
  Search this Thread
Old 02-11-2015, 09:10 AM   #1
jowa45
Member
 
Registered: Apr 2007
Location: Stockholm, Sweden
Distribution: Slackware11&14.1
Posts: 119

Rep: Reputation: 15
Text goes small on new 14.1 boot


After using Slackware 11 since 2006 I decided to do an update to 14.1.
Installation went well and I just went with defaults.

On booting the new installation all seamed to be going well but then the screen blanked for a few moments and the booting process resumed with now very small text.
This very small text continued even after log in.

Would anyone be as good as to explain how I can restore the text size.
Alternativly how can I check the text size in my Slackware 11 and set the same text size.

John
 
Old 02-11-2015, 10:48 AM   #2
veerain
Senior Member
 
Registered: Mar 2005
Location: Earth bound to Helios
Distribution: Custom
Posts: 2,524

Rep: Reputation: 319Reputation: 319Reputation: 319Reputation: 319
Perhaps this is because slackware 14 is using KMS for video. Your resolution has increased compared to previous vga resolution in old. So fonts are appearing small.

You can set bigger console fonts.

Code:
setfont /usr/share/consolefonts/iso01-12x22.psfu.gz
or
setfont -C /dev/tty1 /usr/share/consolefonts/iso01-12x22.psfu.gz
or
for f in /dev/tty*; do
setfont -C "$f" /usr/share/consolefonts/iso01-12x22.psfu.gz
done
Please see /usr/share/consolefonts/ directory to see other fonts.

You can also install terminus-fonts. They are much better to view.

Last edited by veerain; 02-11-2015 at 10:49 AM.
 
2 members found this post helpful.
Old 02-11-2015, 05:03 PM   #3
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1.2 on Lenovo Thinkpad W520
Posts: 9,479

Rep: Reputation: Disabled
+1 for Terminus fonts, included in a full Slackware 14.1 installation. You just can't use "setconsolefont" or "pkgtools" to set one of them as default as they are not included in the built-in fonts list, but no big deal, just edit /etc/rc.d/rc.font and make it executable. For instance the content of this file here is:
Code:
#!/bin/sh
#
# This selects your default screen font from among the ones in
# /usr/share/kbd/consolefonts.
#
setfont -v ter-118n.psf.gz
The ter-1<font size> series includes all glyphs needed for English and Swedish.

Would you want even bigger fonts you can install fbterm that allows you to use True Type fonts on the console like Deja Vu (also shipped in Slackware) that are scalable at will.

See also: /usr/doc/terminus-font-4.38/README and /usr/doc/dejavu-fonts-ttf-2.34/* in your system and after installation of fbterm /usr/doc/fbterm-1.7/README.

Last edited by Didier Spaier; 02-17-2015 at 04:03 PM. Reason: Typos fixed
 
2 members found this post helpful.
Old 02-11-2015, 05:42 PM   #4
fogpipe
Member
 
Registered: Mar 2011
Distribution: Slackware 64 -current,
Posts: 550

Rep: Reputation: 194Reputation: 194
Try putting vga=normal in the appropriate spot in your lilo.conf. Dont forget to run /sbin/lilo afterward.
 
Old 02-12-2015, 04:54 AM   #5
jowa45
Member
 
Registered: Apr 2007
Location: Stockholm, Sweden
Distribution: Slackware11&14.1
Posts: 119

Original Poster
Rep: Reputation: 15
Thank you all.

The installation had vga = normal as did my Slackware 11.
What is normal for 11 does not appear normal for 14.1.

Editing my /etc/rc.d/rc.font as suggested and then
source /etc/rc.d/rc.font
gave a larger font but not as large as the initial boot font.

The original text in /etc/rc.d/rc.font was just
setfont -v

On rebooting the small font came back again.
As though /etc/rc.d/rc.font
is not being read during boot up.
It can be restored with
source /etc/rc.d/rc.font
after logging in.

John
 
Old 02-12-2015, 05:04 AM   #6
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1.2 on Lenovo Thinkpad W520
Posts: 9,479

Rep: Reputation: Disabled
Quote:
Originally Posted by jowa45 View Post
On rebooting the small font came back again.
As though /etc/rc.d/rc.font
is not being read during boot up.
Probably you forgot to make that file executable. As root, type:
Code:
chmod 755 /etc/rc.d/rc.font
PS what media (ISO image or DVD) did you use for installation and from where did you get it?

Last edited by Didier Spaier; 02-12-2015 at 05:13 AM. Reason: PS added
 
1 members found this post helpful.
Old 02-12-2015, 06:22 AM   #7
jowa45
Member
 
Registered: Apr 2007
Location: Stockholm, Sweden
Distribution: Slackware11&14.1
Posts: 119

Original Poster
Rep: Reputation: 15
Thanks

Quite right the file was not executable but is now.

There are now three stages in the boot process.
It starts with the nice easy to read font.
It switches to that small hard to read font.
It switches to the font defined in /etc/rc.d/rc.font
just before loggin.

All installation files were downloaded from

http://mirrors.slackware.com/slackwa...ware-14.1-iso/

My installation methode was to copy all packages to a
USB portable hard disk by using a loopback device,
burn in the d1 to a CD and use that to boot the machine,
then use the "install from premounted directory" alternative,
the premounted directory being my USB hard disk.

I selected "install everything" it took 35 minutes.

This is interesting as of course the machine was a 32 bit.
At the weekend I will be attempting another 14.1 installation
this time on a 64 bit HP slimline.
So far all I have done is to burn in and test the installation DVD.
The machine does not have a floppy disk or seam capable of booting
from USB so those two backup methodes are out.

Anyone any good advice before I even begin.

John

Edit:- Something made a url out of my original text that does not work.
Edit2:- Works now.

Last edited by jowa45; 02-13-2015 at 01:55 AM. Reason: added url did not work
 
Old 02-23-2015, 08:45 PM   #8
slacker1337
Member
 
Registered: Jun 2012
Location: Connecticut, USA
Distribution: Slackware
Posts: 144

Rep: Reputation: 38
This is kinda a shot in the dark, but I had a similar problem while using QEMU VNC sessions to my virtual machines until I made the following change to /etc/lilo.conf:

#append=" vt.default_utf8=0"
append="video=800x600"
 
Old 02-24-2015, 11:29 AM   #9
jowa45
Member
 
Registered: Apr 2007
Location: Stockholm, Sweden
Distribution: Slackware11&14.1
Posts: 119

Original Poster
Rep: Reputation: 15
During the installation I was offered to try out some fonts.
I just accepted the default.
Here is the real problem.
My bad.

John
 
Old 06-20-2015, 05:32 PM   #10
Arcosanti
Member
 
Registered: Apr 2004
Location: Mesa, AZ USA
Distribution: Slackware 14.1 kernel 4.1.13 gcc 4.8.2
Posts: 246

Rep: Reputation: 22
One possible solution is to reconfigure the kernel to use a lower resolution which means recompiling the kernel. It's probably been configured to use too high of a resolution for your display.

Quote:
Originally Posted by jowa45 View Post
During the installation I was offered to try out some fonts.
I just accepted the default.
Here is the real problem.
My bad.

John
I did something just as bad. I inadvertently chose a font I didn't want. Slip of the finger on the keyboard.

Last edited by Arcosanti; 06-20-2015 at 05:35 PM.
 
Old 06-20-2015, 05:40 PM   #11
Pednick
Member
 
Registered: Nov 2014
Posts: 80

Rep: Reputation: Disabled
Actually, I'd like to be able to boot in to desktop with kms like the OP had no problem doing, fixing text is no problem. I need to put nomodeset at kernel prompt just to get to desktop. Btw I have 2 radeon on crossfire.

Quote:
Originally Posted by veerain View Post
Perhaps this is because slackware 14 is using KMS for video. Your resolution has increased compared to previous vga resolution in old. So fonts are appearing small.

You can set bigger console fonts.

Code:
setfont /usr/share/consolefonts/iso01-12x22.psfu.gz
or
setfont -C /dev/tty1 /usr/share/consolefonts/iso01-12x22.psfu.gz
or
for f in /dev/tty*; do
setfont -C "$f" /usr/share/consolefonts/iso01-12x22.psfu.gz
done
Please see /usr/share/consolefonts/ directory to see other fonts.

You can also install terminus-fonts. They are much better to view.
 
Old 06-20-2015, 11:48 PM   #12
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1.2 on Lenovo Thinkpad W520
Posts: 9,479

Rep: Reputation: Disabled
Quote:
Originally Posted by Arcosanti View Post
One possible solution is to reconfigure the kernel to use a lower resolution which means recompiling the kernel. It's probably been configured to use too high of a resolution for your display..
That would really be an overkill! Including the proper kernel parameters in the booting command line (either manually or through your boot loader's configuration file) is obviously the way to go.
 
Old 06-21-2015, 08:42 AM   #13
Pednick
Member
 
Registered: Nov 2014
Posts: 80

Rep: Reputation: Disabled
Quote:
Originally Posted by Pednick View Post
Actually, I'd like to be able to boot in to desktop with kms like the OP had no problem doing, fixing text is no problem. I need to put nomodeset at kernel prompt just to get to desktop. Btw I have 2 radeon on crossfire.
No answer? Ok at least let me know if I should follow this:

http://www.linuxquestions.org/questi...-works-760963/

Seems like old advice so I'm wondering if things have been fixed since then and if there is a simpler solution?

Last edited by Pednick; 06-21-2015 at 09:02 AM.
 
Old 06-21-2015, 09:18 AM   #14
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1.2 on Lenovo Thinkpad W520
Posts: 9,479

Rep: Reputation: Disabled
"nomodeset" requests the kernel not to use KMS which is the abbreviation of Kernel Mode Setting. So it's completely impossible to get KMS if you need this kernel parameter for your video adapter.
 
Old 06-21-2015, 09:24 AM   #15
Pednick
Member
 
Registered: Nov 2014
Posts: 80

Rep: Reputation: Disabled
Quote:
Originally Posted by Didier Spaier View Post
"nomodeset" requests the kernel not to use KMS which is the abbreviation of Kernel Mode Setting. So it's completely impossible to get KMS if you need this kernel parameter for your video adapter.
That's what don't want, I don't want to use "nomodeset", I want to use kms but it doesn't work, with kms my screen boots into black screen with a flashing minus sign in the top left hand corner.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Newie - boot/bash text too small Please help my eyes! Netnovice Slackware - Installation 10 02-05-2013 04:12 AM
On-screen text and icons are way too small punchy71 Linux Mint 3 08-21-2012 03:49 PM
Text too small and too big in Firefox?! Cinematography Linux - Software 5 04-28-2005 03:36 PM
text in fluxbox too small. levicc00123 Slackware 2 01-08-2005 12:56 PM
Text to small.. >_< Mystical Itachi SUSE / openSUSE 4 10-20-2004 11:16 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation

All times are GMT -5. The time now is 01:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration