LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware - Installation (https://www.linuxquestions.org/questions/slackware-installation-40/)
-   -   SW 9.1 Wont Boot (https://www.linuxquestions.org/questions/slackware-installation-40/sw-9-1-wont-boot-134194/)

UbErBeAsT 01-12-2004 10:31 PM

SW 9.1 Wont Boot
 
I have slackware 9.1 Everything installed with no errors but if I reboot the Bios wont boot into linux instead it tries to boot from the cd. It will let me use the cd to run linux but in need it to boot from the hard drive rather than the cd. I also noticed that the cd roms light is on while im in linux so i think it may be using the cd's kernel. If anyone knows how I can fix this please let me kno ASAP. Thanx!

gnashley 01-13-2004 01:38 AM

I'll assume that you set the BIOS to boot first from CD so that you could install Slackware, so you need to remove the CD from the drive in order for the computer to try to boot from the hard drive. Did you install lilo during installation?

UbErBeAsT 01-13-2004 05:05 PM

I have the bios set to boot from the HD and i installed lilo to the superblock then tried the MBR but neither worked.

UbErBeAsT 01-13-2004 06:52 PM

Also, if its any help the BIOS says: "Boot Failure, Insert System Disk And Press Enter"

UbErBeAsT 01-15-2004 10:39 PM

I made a rescue disk with mkrescue and it says "Error: 0x10." Anyone know what this means?

nesware 01-17-2004 08:55 AM

have any partitions set active? works sometimes

don't worry about using the cd roms kernel.. as soon as it read the kernel into memory you don't need the cd anymore.. but it is anoying, i know

can you post the output of the following 3 commands (as root)
fdisk -l
cat /etc/lilo.conf
dmesg | grep hd

UbErBeAsT 01-17-2004 06:09 PM

fdisk -l :
Code:

Device        Boot        Start    End      Blocks      Id        system
/dev/hda1                    1      63      506016      82        Linux Swap
/dev/hda2      *            64      784      5791432      83        Linux

cat /etc/lilo.conf :
# LILO configuration file
# generated by 'liloconfig'
# start LILO global section
boot = /dev/hda
# compact
prompt
timeout = 300
# VESA framebuffer console @ 1024x768x64k
vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# ramdisk = 0 # paranoia setting
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/hda2
label = Linux
read-only # Non-UMSDOS filesystems should be mounted read-only for checking
# Linux bootable partition config ends

dmesg | grep hd :

ide0: BM-DMA at 0xf000 - 0xf007, Bios settings: hda: DMA, hdb: DMA
ide1: BM-DMA at 0xf008 - 0xf00f, Bios settings: hdc: DMA, hdd: DMA
hda: WDC AC26400R, ATA Disk drive
hdc: Memorex CRW-1622, ATAPI CD/DVD-Rom drive
hda: attached disk driver.
hda: task_no_data_intr: status=0x51 {Drive Ready Seek Complete Error}
hda: task_no_data_intr: error=0x04 {DriveStatusError}
hda: host protected area => 1
hda: 12594960 sectors(6449MB) w/ 512KiB Cache, CHS = 784, 255, 63
hdc: attached ide-cdrom driver
hdc: ATAPI 6x CD-ROM CD-R/RW drive, 1024KB Cache, DMA
hda: hda1 hda2

Allen614 01-17-2004 09:28 PM

In your lilo.config you need to change this line
boot = /dev/hda
to this
boot=/dev/hda2
Then run /sbin/lilo to set the change. With /dev/hda it's trying to boot the swapfile.

netcrawl 01-18-2004 01:39 PM

Lilo should be fine; mine looks like this:

boot="/dev/hda"
lba32
prompt
timeout="50"
root=/dev/hda3
vga="773"
image="/boot/vmlinuz"
label="Slack9.1"
root="/dev/hda3"
read-only

image="/boot/vmlinuz-ide-2.4.22"
label="2.4.22"
root="/dev/hda3"
read-only

other=/dev/hda1
label="XP"

however, this doesn't look good:

hda: task_no_data_intr: status=0x51 {Drive Ready Seek Complete Error}
hda: task_no_data_intr: error=0x04 {DriveStatusError}

HD problem perhaps?

nesware 01-18-2004 03:56 PM

in ur BIOS... is the harddisk set to LBA NORM AUTO? try different settings, rerun lilo every time you change something and check if it works...
bit worried about the
hda: task_no_data_intr: status=0x51 {Drive Ready Seek Complete Error}
hda: task_no_data_intr: error=0x04 {DriveStatusError}

UbErBeAsT 01-18-2004 04:57 PM

I tried switching it to hda2 but it still didn't work. :(

UbErBeAsT 01-18-2004 04:58 PM

I think it is LBA but ill check.

nesware 01-18-2004 05:08 PM

i've had heaps a lilo problems with that stuff on my secondhand fujitsu... until i started changing the BIOS settings for the LBA... just play around with it and try every thing... and also the lba setting for lilo!

UbErBeAsT 01-19-2004 01:13 PM

its set to LBA.

nesware 01-19-2004 02:14 PM

still won't work?
ok.. first let's get rid of the cd...
make sure you have a kernel at /boot/vmlinuz else link it to the kernel you want.
$ ln -s /whereveryourkernelis /boot/vmlinuz

then
change lilo.conf (first back-up existing one)

#lilo.conf
boot = /dev/fd0
prompt
lba32
timeout = 50
change-rules
reset
image = /boot/vmlinuz
root = /dev/hda2
label = Linux
read-only

get a clean floppy...
run lilo
$ lilo

check if you don't get any errors! it should say
Adding *linux
and your floppy should write...
try rebooting from this floppy... mind.. now you only have lilo running from floppy.. your kernel will be read from de hard drive... and remove the CD!

let me know if this works


All times are GMT -5. The time now is 08:42 AM.