LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation
User Name
Password
Slackware - Installation This forum is for the discussion of installation issues with Slackware.

Notices


Reply
  Search this Thread
Old 07-20-2016, 11:06 PM   #46
scythempress
Member
 
Registered: Dec 2012
Location: Tradinghouse Lake, Texas
Distribution: Slackware
Posts: 116

Original Poster
Rep: Reputation: Disabled

Well close, will try again tomorrow
 
Old 07-20-2016, 11:18 PM   #47
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.2
Posts: 3,719

Rep: Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067
Quote:
Originally Posted by scythempress View Post
Code:
insmod ERROR could not load module b44: no such file or directory
Am on other machine again.
Code:
As root typed /etc/rc.d/rc.networkmanager restart and got -su: /etc/rc.d/rc.networkmanager: Permission denied
But Wicd is gone!
Ok, run as root chmod +x /etc/rc.d/rc.networkmanager and that should fix that problem when you reboot.

See you tomorrow. At least we all know that your wireless can be made to work again.
 
1 members found this post helpful.
Old 07-21-2016, 05:32 AM   #48
scythempress
Member
 
Registered: Dec 2012
Location: Tradinghouse Lake, Texas
Distribution: Slackware
Posts: 116

Original Poster
Rep: Reputation: Disabled
That was it. We are up and running again. I actually get to put solved on something. Thanks that was great. I hope the rest of this works out as well. Will talk to you later.
 
Old 07-21-2016, 04:56 PM   #49
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.2
Posts: 3,719

Rep: Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067
After checking, I really should have told you to run (as root)
Code:
/sbin/modprobe b44
instead (insmod wants a path to a file, while modprobe is smart enough to look in the right places). "b44" is the kernel module that your system was using to bring up your wired connection before and it comes with the slackware kernel. Your system really should be able to load b44 without any help from you, but first things first.

If eth0 does come back to life, you can use NM to configure your wired connection too. Some folks use NM for the wireless connections and /etc/rc.d/rc.inet1 for wired connections, but if you have a laptop you might as well have NM handle both types of connections for you.
 
Old 07-21-2016, 05:11 PM   #50
scythempress
Member
 
Registered: Dec 2012
Location: Tradinghouse Lake, Texas
Distribution: Slackware
Posts: 116

Original Poster
Rep: Reputation: Disabled
Yep that took care of cable problem too.
Code:
root@scythempress:~# ifconfig
eth0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 00:21:70:6e:fe:ab  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 17  

eth1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 10.0.0.8  netmask 255.255.255.0  broadcast 10.0.0.255
        inet6 fe80::216:44ff:fee1:1c2b  prefixlen 64  scopeid 0x20<link>
        ether 00:16:44:e1:1c:2b  txqueuelen 1000  (Ethernet)
        RX packets 105877  bytes 4937661 (4.7 MiB)
        RX errors 0  dropped 0  overruns 0  frame 426435
        TX packets 2929  bytes 327201 (319.5 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 17  base 0xc000  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 4  bytes 288 (288.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 4  bytes 288 (288.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
 
Old 07-21-2016, 05:11 PM   #51
scythempress
Member
 
Registered: Dec 2012
Location: Tradinghouse Lake, Texas
Distribution: Slackware
Posts: 116

Original Poster
Rep: Reputation: Disabled
Now how do I mark a problem solved?
 
Old 07-21-2016, 09:06 PM   #52
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.2
Posts: 3,719

Rep: Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067
I think it is on the "Thread Tools" pull-down at the top.

However, when you reboot now, does eth0 show up on its own? Or do you have to run the modprobe command?

It really should show up on its own.

EDIT: You may have a different opinion (hey, it's your machine, not mine!), but I don't think your problem is solved until you can boot up, log into KDE, and your wired connection (if the ethernet cable is plugged in, of course) and your wireless connection connect without you having to load kernel modules by hand.

Last edited by Richard Cranium; 07-21-2016 at 09:27 PM.
 
Old 07-21-2016, 09:41 PM   #53
scythempress
Member
 
Registered: Dec 2012
Location: Tradinghouse Lake, Texas
Distribution: Slackware
Posts: 116

Original Poster
Rep: Reputation: Disabled
Had to run modprobe after reboot so I guess still have some work to do

Last edited by scythempress; 07-21-2016 at 09:46 PM.
 
Old 07-21-2016, 09:59 PM   #54
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.2
Posts: 3,719

Rep: Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067
Yeah, that's not good. You can "fix" it by adding the line /sbin/modprobe b44 at the very end of /etc/rc.d/rc.modules.

That should do the trick for you.

I suspect that the SBo broadcom packages blacklisted the b44 module, which would be why your system all of a sudden doesn't think that kernel module should be automatically loaded.
However, my Day Job(TM) is software engineering and that would drive me to figure out why such a system doesn't load the correct kernel modules by itself.

Software engineering, I don't believe, is *your* Day Job; if you just want the *bleeping* thing to work and don't really care why it is acting stupid, then add the line to the end of /etc/rc.d/rc.modules and be happy. (That's not meant as an insult or anything like that. It is an absolutely rational position to take.)

God knows I've done something like that a few times with my Windows boxes.
 
1 members found this post helpful.
Old 07-22-2016, 07:13 PM   #55
scythempress
Member
 
Registered: Dec 2012
Location: Tradinghouse Lake, Texas
Distribution: Slackware
Posts: 116

Original Poster
Rep: Reputation: Disabled
If you mean
Code:
/etc/rc.d/rc.modules/sbin/modprobe b44 OR
/etc/rc.d/rc.modules /sbin/modprobe b44
it tells me that its up to date no new kernel dependencies loaded. But /sbin/modprobe b44 brings it right back up
 
Old 07-22-2016, 08:27 PM   #56
scythempress
Member
 
Registered: Dec 2012
Location: Tradinghouse Lake, Texas
Distribution: Slackware
Posts: 116

Original Poster
Rep: Reputation: Disabled
Nope I'm a cop and an instructor at MCC, as well as a farmer in the evening. I do however intend to actually learn slackware this time, so I do not intend to give up, and I like knowing how things work as well as that they just do.
 
Old 07-22-2016, 09:40 PM   #57
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.2
Posts: 3,719

Rep: Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067
Quote:
Originally Posted by scythempress View Post
If you mean
Code:
/etc/rc.d/rc.modules/sbin/modprobe b44 OR
/etc/rc.d/rc.modules /sbin/modprobe b44
it tells me that its up to date no new kernel dependencies loaded. But /sbin/modprobe b44 brings it right back up
Sorry.

I should have written...
Quote:
As root, edit the file /etc/rc.d/rc.modules and add the line
Code:
/sbin/modprobe b44
at the very end of the file.
(I'm late responding tonight since I'm trying to upgrade my wife's Windows 7 laptop to Windows 10. That's the only machine in the house that is giving me a hard time with the upgrade.)

Last edited by Richard Cranium; 07-22-2016 at 10:04 PM.
 
Old 07-22-2016, 09:59 PM   #58
scythempress
Member
 
Registered: Dec 2012
Location: Tradinghouse Lake, Texas
Distribution: Slackware
Posts: 116

Original Poster
Rep: Reputation: Disabled
That did it. Rebooted and came up ready to go both wired and wireless. Did my wifes win 7 to win 10, took forever but it pretty much did itself. WIll mark this thread solved, thanks for all the help. I managed to get flash up and running in fire fox, not Konqueror, but am doing more with it than ever. Appreciate all the help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
wireless connection problems & now lost lan connection & network manager wont work Rainbowserpant Linux - Wireless Networking 2 09-02-2009 04:00 AM
Wireless Connection Problems canada_eh Linux - Networking 2 03-10-2008 11:22 PM
wireless connection problems. PSBP753 Linux - Newbie 5 07-26-2006 12:27 AM
Wireless card..Wireless router.. Slackware 10.2 ..Problems with Internet Connection. Storm Bringer Linux - Wireless Networking 4 03-23-2006 06:25 AM
Wireless Connection Problems Spennysimmo Linux - Laptop and Netbook 1 11-06-2004 07:37 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation

All times are GMT -5. The time now is 12:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration