-   Slackware - Installation (
-   -   Sound Issues partly solved. (

soxplayer 11-24-2012 08:36 PM

Sound Issues partly solved.
Have installed Slackware 14.0 64 bit on an Acer Aspire One 722

Audio used to work in 13.37 but now no sound.
The relevant portion of lspci is below:

00:01.1 Audio device: Advanced Micro Devices [AMD] nee ATI Wrestler HDMI Audio [Radeon HD 6250/6310]
0:14.2 Audio device: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA) (rev 40)

A little poking around with Audacious shows that alsa is using the HDMI output as the default, hence no sound. If you make Audacious use the second card you get audio, although the headphone speaker cutout does not work.

How do you force the second card to be the default?

H_TeXMeX_H 11-25-2012 04:42 AM

1) Run:


cat /proc/asound/modules
You will get something like:


0 snd_hda_intel
 1 snd_yamaha
 2 snd_sis

2) To set the default sound card edit '/lib/modprobe.d/sound.conf' (create if not there).


options snd_yamaha index=0
options snd_hda_intel index=1
options snd_sis index=2

That sets the yamaha card as the default (index=0). You'll probably have to run:


for changes to take effect, or you can reboot if that doesn't work.

3) Use 'alsamixer' to set the volumes, and 'alsactl store' to store them.

soxplayer 11-25-2012 05:54 PM

I like your idea but both "cards" use the same module:

I get:

0 snd_hda_intel
1 snd_had_intel

As the digital (HDMI) and analog parts of the card use the same module.

I still have no idea how to make the analog side a priority. Am am experimenting with phonon and I do get some sound for some programs in KDE but nothing on the commmand line. I get:

ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slaveaplay: main: 696: audio open error: No such file of directory

soxplayer 11-25-2012 11:17 PM

I have a better workaround. I created an ~.asounrc file with the following content:

pcm.!default {
type hw
card 1
device 0

Now all sound goes to the analog side by default and I have system sound and internet sound and command line sound.

The only quirk is that the headphone jack does not silence the speakers, but this is typical of new intel based cards, and I had to tell KDE to use the master on card 1 for the volume.

A lot better than a poke in the eye.

All times are GMT -5. The time now is 07:58 AM.