-   Slackware - Installation (
-   -   Slackware install on GPT HDD (

san2ban 07-21-2013 09:29 AM

Slackware install on GPT HDD
Dear Slackers
My hand was itching to convert MBR to GPT. gdisk was saying some 33 blocks are overlapping, and that it has to be re-sized using other utilities. With system rescue CD, I moved my partitions, so that space was there between sdb1, sdb2. After doing this, slackware did not boot. 99 99 was displayed on monitor. Got fed up. Using gdisk, converted entire disk to GPT. re formatted. Made 3 partitions. Sdb1-swap, sdb2-ef02 for bios-gpt, sdb3 for /, install. Installed slackware14 64 bit. But, I did not install lilo, since I want to install grub2, which is not on install dvd.
I have stopped at this, and posting here. Pl. inform how and where on these three partitions, grub2 is to be installed

Tried to boot second hdd (sdb) from SystemRescue CD, but gave only 99 99 99

business_kid 07-21-2013 11:07 AM

Is UEFI in there somewhere? If so, GPT or MBR is a big deal, and you have a lot of reading to do.

san2ban 07-21-2013 11:38 AM


I had earlier done this on Archlinux (before being banned due to systemd comments) I am familiar with GPT on funtoo linux also. But in slackware, documentation on this is not exhaustive, or I cannot find it

business_kid 07-22-2013 03:40 AM

99 99

as a boot error is a symptom of an incorrectly set up lilo (or grub). I believe grub2 and some later lilo were for uefi, so you might do better sticking with earlier versions. The bios points the boot at the first 512 bytes of a selected disk. Lilo needs to be rerun each change, grub not so much - which is good because personally I find grub a pig.

The rest of the documentation on slackware is "Figure it out yourself." :-)). You promote yourself to slackware when that's not a big deal for you. Glad to have you on board. As a creature of habit, I always set up /boot as sda1, and swap maybe as sda2. If I go to a GPT disk, I wake up the UEFI in this box (Samsung) which might better be named NLFI (No Linux Firmware Interface:)

Didier Spaier 07-22-2013 04:21 AM

As you mention sdb, not sda:

Do you try to make an installation on an USB hard disk?

Out of curiosity, what do you have on /dev/sda?

Out of curiosity, why grub2 instead of lilo? I ask that because if you have only one system, you would make you life easier simply using lilo.

san2ban 07-22-2013 04:56 AM

WinXP on sda. GRUB2, as a support to GNU. Also, it is in active development.
I did not make a USB installation disk.

I need to know, using systemrescue cd, after chroot into my slackware14 on sdb, how to install GRUB2

Didier Spaier 07-22-2013 05:43 AM

As grub2 is not shipped in Slackware but can be built on a running Slackware system using the SlackBuild available @, I'd suggest you first install lilo, then build and install a grub2 package, then replace lilo with grub2.

Or you could skip the "install lilo" step and built grub2 just after you chrooted on your slackware 14, provided you first set up a network connection and download what you need to build a grub2 package.

san2ban 07-22-2013 06:29 AM

Finally, that is what I did. Came here to mark it 'solved', saw your post. Posting from slackware14_64bit. I will change over to grub2 later.

Thanks to all

business_kid 07-22-2013 11:04 AM

FWIW, Fedora 18 shipped grub2 with this sort of helpful remark beside it:

"Actually, this thing doesn't work, but we are supplying it for people who want to experiment (read fart about) with it."

TommyC7 07-22-2013 06:46 PM

I thought LILO could boot GPT just fine, just not UEFI?

Didier Spaier 07-22-2013 08:44 PM


Originally Posted by TommyC7 (Post 4994916)
I thought LILO could boot GPT just fine, just not UEFI?


ruario 11-13-2013 03:58 AM

I hope people don't mind but I am bumping this thread for the benefit of future users who stumble across it. I have now added a short tutorial on about using GPT and BIOS, with the various bootloaders now included with Slackware 14.1.

ruario 11-13-2013 06:46 AM

EDIT: Scratch all that liloconfig works fine for me.

All times are GMT -5. The time now is 06:09 PM.