-   Slackware - Installation (
-   -   Slackware Install Dell XPS 8500 (Success) (

MCDewy 06-27-2013 11:35 AM

Slackware Install Dell XPS 8500 (Success)
Just wanted to drop a note for anyone else with this machine.

Installed Slackware 14 on a Dell XPS 8500. It found all the devices so far except the Audio.

I am new at linux and trying to find a procedure for the audio that will work.

Anyway, it runs on 8500's.


flyinggeorge 06-30-2013 12:22 PM

Do you know the name of your audio device? For example when I use lspci -v (as root) I get:


#lspci -v
00:1b.0 Audio device: Intel Corporation Panther Point High Definition Audio Con$
        Subsystem: ASUSTeK Computer Inc. Device 1487
        Flags: bus master, fast devsel, latency 0, IRQ 48
        Memory at f7310000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
        Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
        Capabilities: [100] Virtual Channel
        Capabilities: [130] Root Complex Link
        Kernel driver in use: snd_hda_intel

Try to find out the name of your audio device and see if you can find anyone else who has a similar problem via google. I would be glad to help, but I would just be google-ing things too. Please post the output of lspci though.

MCDewy 06-30-2013 09:05 PM

Running that command I see two audio devices listed:


00:1b.0 Audio device: Intel Corporation Panther Point High Definition Audio Controller (rev 04)
        Subsystem: Dell Device 0545
        Flags: bus master, fast devsel, latency 0, IRQ 47
        Memory at f7f10000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
        Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
        Capabilities: [100] Virtual Channel
        Capabilities: [130] Root Complex Link
        Kernel driver in use: snd_hda_intel


01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Turks HDMI Audio [Radeon HD 6000 Series]
        Subsystem: Dell Device aa90
        Flags: bus master, fast devsel, latency 0, IRQ 48
        Memory at f7e40000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 3
        Capabilities: [58] Express Legacy Endpoint, MSI 00
        Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
        Capabilities: [150] Advanced Error Reporting
        Kernel driver in use: snd_hda_intel

MCDewy 06-30-2013 09:43 PM

Looked through some of the other threads on google, trying what they suggest isn't working.

Note that sound does work when I log into KDE as root. It doesn't use ALC887, but falls back to something. When I look at teh devices there, it has a numch of hw.0, hw.1 and so on devices. Not sure if it is using them or what. But it doesn't work when logged in as a regular user. Weird.

I downloaded the latest 887 drivers from realtek for Linux, but I do not know how to compile it under slackware.

flyinggeorge 07-02-2013 06:27 PM

What does the groups command output as your user? For example, I get:


bash-4.2$ groups
users lp floppy audio video cdrom plugdev power netdev scanner

If audio isn't there, that could be the source of your problem. The fact that root can use sound and your user can't seems to suggest this is possible, it also would suggest that this is not a driver problem, but if you do have audio in your user's groups...

Also did you download source code of the drivers you said you got? Usually there is an INSTALL or README file included in them. Or is it a binary of some sort? Is there a makefile included? Or a configure script?

I'm not really an advanced linux user myself, but sometimes dmesg has useful information when troubleshooting. Try to play some audio file and type 'dmesg | tail' into a terminal. It might give you some information. Also I'm going to of course assume you verified everything was un-muted in alsamixer.

If none of the above works, maybe you could check and see if root and your user are using the same card. In a terminal type 'alsamixer' in the top left, it says something like Card: *** for me it says 'Card: HDA Intel PCH' this is a shot in the dark, but maybe your root account is using one of your sound cards, while the user is trying to use the other. Then you would have to reconfigure alsamixer as your user to use the proper sound card. But I'm not honestly sure exactly what your problem is, just trying to help troubleshoot. Also, from alsamixer pressing F6 lets you select different sound cards, try to change which device you are using and see if it makes a difference.

MCDewy 07-02-2013 09:59 PM

Hello, Thank you so much for the suggestions.

The group info is:


bash-4.2$ groups

Audio is not there, I will try to figure out how to add it.

The driver I got was from teh realtek site itself, it was a tar.gz file which Slack doesn't seem to like for installpkg. I just looked through the files and there is an install script. I was reading the Linux install pdf, and some of the commands would not work on my machine.

I will try the groups first.

I do not know how to get alsamixer to run without being su.

MCDewy 07-02-2013 10:19 PM

Progress, Flying George, thanks!

I added my user account to the various groups per the slackware documentation:

usermod -a -G audio,cdrom,floppy,plugdev,video user
I had skipped that step for additional groups when I added my user account after the install.

I rebooted, and I no longer receive a gui error that there are no sound devices and it is reverting to default. The volumn control shows up in the taskbar now as well.

When I go to Phonom, I can hear teh test sounds, but Youtube and Pandora from Google Chrome do not work still. Also, selecting an mp3 I get "couldn't open audio" error message.

When I use alsamixer it pops up with a sound card that has no options to manipulate, just s/pdif. I can choose F6 to change cards and mess with the controls there. I saw a post that said there was a way to store the alsamixer settings, perhaps that is it?

No change, I tried

alsactl store
, logged out and back in and no change. Again, I can hear the test sounds from Phonom, and the logout system sound. No mp3, or webpage sound.

flyinggeorge 07-02-2013 10:37 PM

I'm glad you are making some sort of progress! I'm going to try and google around and see if I can help you, as for the .tar.gz file, this is not a Slackware binary, this is a compressed file (tarball). To extract a .tar.gz open a terminal and type:


$tar xvzf name_of_file.tar.gz
Then there is usually a folder inside, you should then be able to do something to the effect of


$cd name_of_folder
(Find out if there is a file called configure)
$ls configure (or ls | grep configure)
(if configure exists)
(From here you should be able to build)
$make && make install clean

As far as the above is concerned, this is how *most* source files come packaged, you might not have source code, maybe it's proprietary in which case it might have a .run file or something similar, the INSTALL file should tell you what you need to know about installing it.

I am really confused about how you can hear sounds from the system in KDE, right? And not in your browser. If I remember correctly, mp3 requires a special codec, I have no idea if KDE gives you this by default, I use fluxbox, so I don't know anything about KDE. Does your audio suite give you any errors when you try to play an mp3 about missing codecs? Try to run your audio suite from a terminal and see if it spits out any errors.

*edit: just saw you said you got a "couldn't open audio" error for mp3

As a final thought, I don't really think you should need to install new driver, it might help, but this seems like a separate issue to me.

Also just for the hell of it, can you try to play something with audio in another browser? Konquer or Firefox/SeaMonkey? Just in case there is a problem with chrome itself (unlikely but worth a stab)


Have you taken a look through this thread? This guy has the same card as you, and these people seem to know a lot more about it than I do.

MCDewy 07-02-2013 10:47 PM


Agree on the driver.

I am in KDE.

I understand what you are saying about the mp3 codec.

I did just manage to go backwards, I was following some other threads about no audio for flash, (I think this issue is the same), and had created a intel_snd_hda.conf file in modprobe.d

Well, I deleted that file and immediately, my audio broke. I am tyring to put it back now.

MCDewy 07-02-2013 11:17 PM


Thanks Flying George!!!!

My /etc/modprobe.conf folder has three files.

All three have the same line: options snd_hda_intel model=auto

I saw some posts using a dash instead of an underscore. My system likes the underscore.

With this setup, mp3's are working, and youtube in Chrome is working. I tried Firefox, (Wanted a new flash plugin which I was not smart on), and konquorer, didnt play the video at all.

But it all appears to be working.

For others:
1. Make sure your user is in all the groups
2. Make sure none of the channels are muted including alsamixer settings
3. Check the files in /etc/modprobe.d (Google search for slackware no audio and flash brings up posts related to the files in here)
4. Check preferred devices in Phonom.

flyinggeorge 07-02-2013 11:24 PM

Awesome! Glad you fixed it.

All times are GMT -5. The time now is 04:40 AM.