-   Slackware - Installation (
-   -   slackware boot images w/ 2 scsi adapters (

radabasp 06-07-2004 03:15 PM

slackware boot images w/ 2 scsi adapters
I am attempting to install Slackware 9.1 on an old dell 4200 server using raid. I can only use fdisk and/or cfdisk when using the raid.s boot image. However, the cdrom isn't found found as the "SOURCE" later in the install process.

I can use jfs.s or xfs.s boot images and the cdrom will be found and located at /dev/sr0, but then fdisk and/or cfdisk won't recognize my scsi controlled hard disks.

Is there a way I can use a combination of raid.s and jfs.s so that both the scsi controller with the disks are found as well as the scsi controller for the cdrom? This has me baffled.

Thanks much,

roAder 06-10-2004 09:05 AM

"I can only use fdisk and/or cfdisk", what do u mean? cfdisk and fdisk are the only things ure supposed to use...
I dunno if this will solve anything but I'll give it a try, here it goes:

boot ure computer from the CD-ROM drive, then just hit enter when it say´s "boot:" then it will appear some text.
then it says login, all you hafto do is to type "root" the n hit enter.
now type "fdisk" and hit enter. you'll se a bunch of options, if ure using a scsi hdd then just type what it says about scsi hdds.
now press "P" and then you'll se ure partionions, i guess you have 1 in that list, a windows partition.
you can delete that (thats what i did) if you dont want it and you probably dont want it because windows sux =)

To delete the partition just press "D" and then 1 if it's the first in the list.
now press "p" again and see if the partition is gone, then press "N" to make a new partition.
then it will ask wich number, select 1. Now you may want some other partitions, if you do its just to add some more.

when ure done adding partitions type "write". It will now appear some text.. think it should say "calling ()iotlc host" and then "Syncing disks" or something like that. Now ure done! type setup and then press "Target" and then select the first partition.
then select format, it doesnt really matter wich file system u choose, I use the file system ext2 because its stabil.

Then just install slackware.

dunno if that helped ya but...

radabasp 06-10-2004 09:21 AM

roAder, thank you for your response. I think I could have been more clear in my sentence "I can only use fdisk and/or cfdisk when using the raid.s boot image." I am aware that these are the only two partitioning options available. The problem was that I could only partition with these while using raid.s boot image. Any other image and they wouldn't recognize /dev/sda. The catch 22 is that raid.s is the only image that wouldn't recognize my scsi CD drive after initially logging in as root. Therefore I couldn't run the Setup after partitioning. So what do you do? :)

Fedora Core 2, although not my first, or even second pick, installed just fine. Anaconda took care of it what ever the mismatch was. I am still very interested in any suggestions so that I can install Slack. This is a work machine and needed an OS asap. I could however make a quick switch.


CactusLoyale 07-03-2004 10:16 AM

I'm going to bump this up since i'm running into the same situation. I'm using a PowerEdge 2200, and if I use raid.s, I can do anything I need to with the hard drives, but not the scsi NEC cdrom. If I select the adaptec.s kernel, I am able to scan for the SCSI cdrom successfully, but it cannot find the raid controller.

I guess what we need to know is a way to load a kernel and add parameters to use another kernel, or parts of it to make both devices work. All help is appreciate.


CactusLoyale 07-03-2004 12:33 PM


Did a different google search this time, and came up with this:

Makes perfect sense. I'm going to try it now and see what happens.

CactusLoyale 07-03-2004 02:34 PM

Well, i'm not having any luck mounting the floppy drive on the poweredge. The floppy drive gets accessed, then I get this message:

mount: wrong fs type, bad option, bad superblock on /dev/fd0, or too many mounted file systems

I did try unmounting usbfs as this server doesnt have usb, and I tried multiple floppies, making sure that I did a thorough format in ext2 format. I am doing these formats on a Slackware 10 system. This happens if I boot off of the slackware 9.1 and 10 cds.

Any ideas?

gnashley 07-03-2004 04:41 PM

Just format the floppies on a win system or with msdos fs.

CactusLoyale 07-03-2004 05:20 PM

OK, will do. Thanks for the update!

CactusLoyale 07-05-2004 03:57 PM

OK. Was able to mount the floppy using mount -t msdos /dev/fd0 /mnt2/floppy. Thanks!

But... I am now seeing this problem with any aic7xxx.o file I try:

/mnt2/floppy/aic7xxx.o: /mnt2/floppy/aic7xxx.O is not an ELF file

This is when I run the insmod /mnt2/floppy/aic7xxx.o command as specified on that link.

So close..... :study:

CactusLoyale 07-05-2004 06:02 PM

OK!!!! Must have been the .o modules I was using. Found a good one, and Slack 10 is installing now!!

Thanks to all the posters that helped out!

All times are GMT -5. The time now is 03:07 PM.