LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation
User Name
Password
Slackware - Installation This forum is for the discussion of installation issues with Slackware.

Notices


Reply
  Search this Thread
Old 03-02-2018, 07:32 PM   #16
lansoar
LQ Newbie
 
Registered: Feb 2018
Location: earth
Distribution: multi distro
Posts: 13

Original Poster
Rep: Reputation: Disabled

Quote:
Originally Posted by bassmadrigal View Post
Well, there seems to be a disconnect there, because in the first command, it shows it's running, but in the second series of commands, it isn't running.

I would try opening up a new command prompt that you can monitor and then, as root, run the following. It will prevent Network Manager from running as a daemon and should print messages to the console. This will help aid in any troubleshooting if it's exiting prematurely.

Code:
NetworkManager -d
Once you have it running in that console, try and use the GUI again and see what happens.
Very strange. starting to look like a bug between the Daemon and the GUI.

Boot up - start the GUI-open Console and verify NM Daemon is running
Code:
bash-4.4$  /etc/rc.d/rc.networkmanager status    
NetworkManager is currently running
Use NM GUI to connect, after entering password, prompt vanishes, hovering over Wifi symbol gets message "Network Manager not running"

verified by console
Code:
bash-4.4# /etc/rc.d/rc.networkmanager status 
NetworkManager is not running.
Interesting, the GUI no longer shows the Wifi i wanted to join as an option.

then as instructed:
Code:
bash-4.4# NetworkManager -d
<info>  [1520040278.1410] NetworkManager (version 1.10.4) is starting... (after a restart)
<info>  [1520040278.1410] Read config: /etc/NetworkManager/NetworkManager.conf (etc: 00-dhcp-client.conf, 00-rc-manager.conf)
<info>  [1520040278.1447] manager[0x12b70c0]: monitoring kernel firmware directory '/lib/firmware'.
<info>  [1520040278.1460] hostname: hostname: couldn't get property from hostnamed
<info>  [1520040278.1462] hostname: hostname changed from (none) to "SlackerPenguin.local"
<info>  [1520040278.1464] dns-mgr[0x12d3970]: init: dns=default, rc-manager=file
<info>  [1520040278.1469] rfkill2: found WiFi radio killswitch (at /sys/devices/pci0000:00/0000:00:1c.2/0000:02:00.0/ieee80211/phy0/rfkill2) (driver iwlwifi)
<info>  [1520040278.1470] rfkill0: found WiFi radio killswitch (at /sys/devices/platform/dell-laptop/rfkill/rfkill0) (platform driver dell-laptop)
<info>  [1520040278.1568] manager[0x12b70c0]: rfkill: WiFi hardware radio set enabled
<info>  [1520040278.1568] manager[0x12b70c0]: rfkill: WWAN hardware radio set enabled
<info>  [1520040278.1716] settings: loaded plugin keyfile: (c) 2007 - 2016 Red Hat, Inc.  To report bugs please use the NetworkManager mailing list.
<info>  [1520040278.1815] keyfile: new connection /etc/NetworkManager/system-connections/GeorgeandDragon-90f44173-05c0-408c-9bea-da9642c3b8c7 (90f44173-05c0-408c-9bea-da9642c3b8c7,"GeorgeandDragon")
<info>  [1520040278.1893] keyfile: new connection /etc/NetworkManager/system-connections/GeorgeandDragon (34728467-e94a-4b5c-8bde-25016fa7e968,"GeorgeandDragon")
<info>  [1520040278.1897] manager: rfkill: WiFi enabled by radio killswitch; enabled by state file
<info>  [1520040278.1898] manager: rfkill: WWAN enabled by radio killswitch; enabled by state file
<info>  [1520040278.1898] manager: Networking is enabled by state file
<info>  [1520040278.1899] dhcp-init: Using DHCP client 'dhcpcd'
<info>  [1520040278.1900] Loaded device plugin: NMBondDeviceFactory (internal)
<info>  [1520040278.1900] Loaded device plugin: NMBridgeDeviceFactory (internal)
<info>  [1520040278.1900] Loaded device plugin: NMDummyDeviceFactory (internal)
<info>  [1520040278.1901] Loaded device plugin: NMEthernetDeviceFactory (internal)
<info>  [1520040278.1901] Loaded device plugin: NMInfinibandDeviceFactory (internal)
<info>  [1520040278.1901] Loaded device plugin: NMIPTunnelDeviceFactory (internal)
<info>  [1520040278.1902] Loaded device plugin: NMMacsecDeviceFactory (internal)
<info>  [1520040278.1902] Loaded device plugin: NMMacvlanDeviceFactory (internal)
<info>  [1520040278.1902] Loaded device plugin: NMPppDeviceFactory (internal)
<info>  [1520040278.1902] Loaded device plugin: NMTunDeviceFactory (internal)
<info>  [1520040278.1902] Loaded device plugin: NMVethDeviceFactory (internal)
<info>  [1520040278.1902] Loaded device plugin: NMVlanDeviceFactory (internal)
<info>  [1520040278.1903] Loaded device plugin: NMVxlanDeviceFactory (internal)
<info>  [1520040278.1938] Loaded device plugin: NMWwanFactory (/usr/lib64/NetworkManager/libnm-device-plugin-wwan.so)
<info>  [1520040278.1948] Loaded device plugin: NMBluezManager (/usr/lib64/NetworkManager/libnm-device-plugin-bluetooth.so)
<info>  [1520040278.1953] Loaded device plugin: NMAtmManager (/usr/lib64/NetworkManager/libnm-device-plugin-adsl.so)
<info>  [1520040278.1957] Loaded device plugin: NMWifiFactory (/usr/lib64/NetworkManager/libnm-device-plugin-wifi.so)
<info>  [1520040278.1964] device (lo): carrier: link connected
<info>  [1520040278.1969] manager: (lo): new Generic device (/org/freedesktop/NetworkManager/Devices/1)
<info>  [1520040278.1979] manager: (eth0): new Ethernet device (/org/freedesktop/NetworkManager/Devices/2)
<info>  [1520040278.1987] keyfile: add connection in-memory (2252d7c2-c617-31fc-a21d-e78653cc749c,"Wired connection 1")
<info>  [1520040278.1991] settings: (eth0): created default wired connection 'Wired connection 1'
<info>  [1520040278.1998] device (eth0): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')
<info>  [1520040278.2008] wifi-nl80211: (wlan0): using nl80211 for WiFi device control
<info>  [1520040278.2010] device (wlan0): driver supports Access Point (AP) mode
<info>  [1520040278.2016] manager: (wlan0): new 802.11 WiFi device (/org/freedesktop/NetworkManager/Devices/3)
<info>  [1520040278.2023] device (wlan0): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')
<info>  [1520040278.2050] device (wlan0): set-hw-addr: set MAC address to 9A:69:58:30:B4:0A (scanning)
<info>  [1520040278.2157] bluez: use BlueZ version 5
<info>  [1520040278.2182] modem-manager: ModemManager available
<info>  [1520040278.2214] bluez5: NAP: added interface 60:F6:77:AF:B8:5F
<info>  [1520040278.2279] supplicant: wpa_supplicant running
<info>  [1520040278.2279] device (wlan0): supplicant interface state: init -> starting
<info>  [1520040278.2311] sup-iface[0x1282a40,wlan0]: supports 5 scan SSIDs
<info>  [1520040278.2315] device (wlan0): supplicant interface state: starting -> ready
<info>  [1520040278.2317] device (wlan0): state change: unavailable -> disconnected (reason 'supplicant-available', sys-iface-state: 'managed')
<info>  [1520040279.1929] device (wlan0): supplicant interface state: ready -> disconnected
<info>  [1520040279.2286] policy: auto-activating connection 'GeorgeandDragon'
<info>  [1520040279.2300] device (wlan0): Activation: starting connection 'GeorgeandDragon' (90f44173-05c0-408c-9bea-da9642c3b8c7)
<info>  [1520040279.2303] device (wlan0): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
<info>  [1520040279.2304] manager: NetworkManager state is now CONNECTING
<info>  [1520040279.2322] device (wlan0): set-hw-addr: reset MAC address to 60:F6:77:AF:B8:5B (preserve)
<info>  [1520040279.2457] device (wlan0): supplicant interface state: disconnected -> disabled
<info>  [1520040279.2468] device (wlan0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
<info>  [1520040279.2472] device (wlan0): Activation: (wifi) access point 'GeorgeandDragon' has security, but secrets are required.
<info>  [1520040279.2473] device (wlan0): state change: config -> need-auth (reason 'none', sys-iface-state: 'managed')
<info>  [1520040279.2474] sup-iface[0x1282a40,wlan0]: wps: type pbc start...
<info>  [1520040279.2542] device (wlan0): supplicant interface state: disabled -> scanning
<info>  [1520040279.3234] device (wlan0): state change: need-auth -> prepare (reason 'none', sys-iface-state: 'managed')
<info>  [1520040279.3238] device (wlan0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
<info>  [1520040279.3241] device (wlan0): Activation: (wifi) connection 'GeorgeandDragon' has security, and secrets exist.  No new secrets needed.
<info>  [1520040279.3241] Config: added 'ssid' value 'GeorgeandDragon'
<info>  [1520040279.3241] Config: added 'scan_ssid' value '1'
<info>  [1520040279.3242] Config: added 'bgscan' value 'simple:30:-80:86400'
<info>  [1520040279.3242] Config: added 'key_mgmt' value 'WPA-PSK'
<info>  [1520040279.3242] Config: added 'auth_alg' value 'OPEN'
<info>  [1520040279.3242] Config: added 'psk' value '<hidden>'
<info>  [1520040280.2274] device (wlan0): supplicant interface state: scanning -> authenticating
<info>  [1520040280.2367] device (wlan0): supplicant interface state: authenticating -> associating
<info>  [1520040280.2491] device (wlan0): supplicant interface state: associating -> associated
<info>  [1520040280.4894] device (wlan0): supplicant interface state: associated -> 4-way handshake
<info>  [1520040280.5030] device (wlan0): supplicant interface state: 4-way handshake -> completed
<info>  [1520040280.5031] device (wlan0): Activation: (wifi) Stage 2 of 5 (Device Configure) successful.  Connected to wireless network 'GeorgeandDragon'.
<info>  [1520040280.5031] device (wlan0): state change: config -> ip-config (reason 'none', sys-iface-state: 'managed')
<info>  [1520040280.5038] dhcp4 (wlan0): activation: beginning transaction (timeout in 45 seconds)
<info>  [1520040280.5102] dhcp4 (wlan0): dhcpcd started with pid 1871
<info>  [1520040280.6863] dhcp4 (wlan0): state changed unknown -> expire
<info>  [1520040280.7347] dhcp4 (wlan0):   address 192.168.1.101
<info>  [1520040280.7347] dhcp4 (wlan0):   plen 24 (255.255.255.0)
<info>  [1520040280.7347] dhcp4 (wlan0):   gateway 192.168.1.1
<info>  [1520040280.7348] dhcp4 (wlan0):   lease time 86400
<info>  [1520040280.7348] dhcp4 (wlan0):   hostname 'SlackerPenguin'
<info>  [1520040280.7348] dhcp4 (wlan0):   nameserver '192.168.1.1'
<info>  [1520040280.7348] dhcp4 (wlan0): state changed expire -> bound
<info>  [1520040280.7356] device (wlan0): state change: ip-config -> ip-check (reason 'none', sys-iface-state: 'managed')
<info>  [1520040280.7364] device (wlan0): state change: ip-check -> secondaries (reason 'none', sys-iface-state: 'managed')
<info>  [1520040280.7368] device (wlan0): state change: secondaries -> activated (reason 'none', sys-iface-state: 'managed')
<info>  [1520040280.7369] manager: NetworkManager state is now CONNECTED_LOCAL
<info>  [1520040280.7427] manager: NetworkManager state is now CONNECTED_SITE
<info>  [1520040280.7429] policy: set 'GeorgeandDragon' (wlan0) as default for IPv4 routing and DNS
<info>  [1520040280.7447] device (wlan0): Activation: successful, device activated.
<info>  [1520040280.7464] manager: NetworkManager state is now CONNECTED_GLOBAL
<info>  [1520040284.2022] manager: startup complete
NM auto connected to the chosen wifi previously picked via the GUI
 
Old 03-02-2018, 07:48 PM   #17
lansoar
LQ Newbie
 
Registered: Feb 2018
Location: earth
Distribution: multi distro
Posts: 13

Original Poster
Rep: Reputation: Disabled
Experimenting some more:

Deleted the saved Wifi profile from NM GUI, disconnecting connection.

started NM as a daemon:

Code:
bash-4.4# /etc/rc.d/rc.networkmanager start
Starting NetworkManager daemon:  /usr/sbin/NetworkManager
Checked GUI, it says "Network Manager is not running"

according to the console:
Code:
bash-4.4# /etc/rc.d/rc.networkmanager status
NetworkManager is currently running
bash-4.4#
Restarted the NM service....no change in the GUI.

stopped the Daemon and ran

Code:
NetworkManager -d
Starts up as previously posted....GUI now shows networks to connect and connection through the GUI is successful.
 
Old 03-02-2018, 08:09 PM   #18
lansoar
LQ Newbie
 
Registered: Feb 2018
Location: earth
Distribution: multi distro
Posts: 13

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by abga View Post
wext has been replaced by nl80211 & cfg80211 & mac80211, but still kept for compatibility (not sure if it's still enabled in the Slackware -current kernel). I advised you to use:
Code:
/usr/sbin/wpa_supplicant -B -D nl80211 -i wlan0 -c /etc/wpa_supplicant.conf
and only substitute that with wext if it's failing.
Hi,

Sorry, I didn't get a chance to post to you that i did try with nl80211. I got this result:

Code:
bash-4.4# /usr/sbin/wpa_supplicant -B -D nl80211 -i wlan0 -c /etc/wpa_supplicant.conf
Successfully initialized wpa_supplicant
nl80211: Could not set interface 'p2p-dev-wlan0' UP
nl80211: deinit ifname=p2p-dev-wlan0 disabled_11b_rates=0
p2p-dev-wlan0: Failed to initialize driver interface
P2P: Failed to enable P2P Device interface
bash-4.4#
I'll go over your instructions again and see what happens. Thx!
 
Old 03-02-2018, 08:54 PM   #19
abga
Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 511

Rep: Reputation: 266Reputation: 266Reputation: 266
Quote:
Originally Posted by lansoar View Post
Hi,

Sorry, I didn't get a chance to post to you that i did try with nl80211. I got this result:

Code:
bash-4.4# /usr/sbin/wpa_supplicant -B -D nl80211 -i wlan0 -c /etc/wpa_supplicant.conf
Successfully initialized wpa_supplicant
nl80211: Could not set interface 'p2p-dev-wlan0' UP
nl80211: deinit ifname=p2p-dev-wlan0 disabled_11b_rates=0
p2p-dev-wlan0: Failed to initialize driver interface
P2P: Failed to enable P2P Device interface
bash-4.4#
I'll go over your instructions again and see what happens. Thx!
Please make sure NetworkManager is not running if you go for the manual config. Also, check if /etc/wpa_supplicant.conf is clean (contains only the default two lines I presented above) before you start the sequence of manual configuration commands.
References to the p2p interface:
https://bugzilla.redhat.com/show_bug.cgi?id=1342916
https://bbs.archlinux.org/viewtopic.php?id=213013

Just noticed in your NetworkManager log that you had no hostname defined and would suggest to execute netconfig for basic network configuration on Slackware (it's also part of the Slackware Setup Wizard):
http://www.slackware.com/config/network.php

EDIT>
Additional to making sure NetworkManager isn't running while you're doing the manual configuration, make also sure that wpa_supplicant is not running in the background either!
Code:
killall wpa_supplicant
https://unix.stackexchange.com/quest...onnect-to-wifi

Last edited by abga; 03-02-2018 at 09:42 PM. Reason: - added the requirement to not have wpa_supplicant running for manual config
 
1 members found this post helpful.
Old 03-03-2018, 09:01 PM   #20
lansoar
LQ Newbie
 
Registered: Feb 2018
Location: earth
Distribution: multi distro
Posts: 13

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by abga View Post
Please make sure NetworkManager is not running if you go for the manual config. Also, check if /etc/wpa_supplicant.conf is clean (contains only the default two lines I presented above) before you start the sequence of manual configuration commands.
Thx.

I had stopped the NM service prior but this time i did a full reboot. Stopped the NM daemon on Konsole and reran the commands:

Code:
bash-4.4# /etc/rc.d/rc.networkmanager stop                                           
Stopping NetworkManager: stopped
bash-4.4# /usr/sbin/wpa_supplicant -B -D nl80211 -i wlan0 -c /etc/wpa_supplicant.conf
Successfully initialized wpa_supplicant
bash-4.4# ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN mode DEFAULT group default qlen 1000
    link/ether a4:4c:c8:74:80:46 brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DORMANT group default qlen 1000
    link/ether 60:f6:77:af:b8:5b brd ff:ff:ff:ff:ff:ff
bash-4.4# cat /etc/wpa_supplicant.conf    
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=root
# reading passphrase from stdin
network={
        ssid="GeorgeandDragon"
        #psk="# commented out by me"
        psk="#commented out by me"
Was able to verify connected to the Wifi Network

Code:
bash-4.4# iw wlan0 link
Connected to c0:56:27:b8:45:8f (on wlan0)
        SSID: GeorgeandDragon
        freq: 5220
        RX: 14847 bytes (137 packets)
        TX: 1711 bytes (17 packets)
        signal: -52 dBm
        tx bitrate: 866.7 MBit/s VHT-MCS 9 80MHz short GI VHT-NSS 2

        bss flags:      short-slot-time
        dtim period:    1
        beacon int:     100
Only problem was no Internet. but i realized after running iwconfig that my connection had no IP. so ran

Code:
bash-4.4# dhclient -v wlan0
Internet Systems Consortium DHCP Client 4.4.0
Copyright 2004-2018 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/wlan0/60:f6:77:af:b8:5b
Sending on   LPF/wlan0/60:f6:77:af:b8:5b
Sending on   Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 5
DHCPOFFER of 192.168.1.147 from 192.168.1.1
DHCPREQUEST for 192.168.1.147 on wlan0 to 255.255.255.255 port 67
DHCPACK of 192.168.1.147 from 192.168.1.1
bound to 192.168.1.147 -- renewal in 36175 seconds.
bash-4.4#
Guess the only thing left is to add dhcp as part of my config file on boot. Thank you all very much for your help. A learning experience as always with Linux. :-)
 
Old 03-03-2018, 09:10 PM   #21
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,504
Blog Entries: 3

Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
you posted you had wifi connection i read it 14.2 is stable but you need to learn linux. learn to create a wifi connection with a profile. Frank 14.2 is up to date . All the tools work . Come on current is a wreck right now. in many areas.
 
Old 03-03-2018, 09:58 PM   #22
abga
Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 511

Rep: Reputation: 266Reputation: 266Reputation: 266
Quote:
Originally Posted by lansoar View Post
Guess the only thing left is to add dhcp as part of my config file on boot. Thank you all very much for your help. A learning experience as always with Linux. :-)
Now with your fresh Linux (Slackware) experience, understood how to set your WiFi connection, you can move on and use the standard and documented way Slackware does the network configuration with the help of the /etc/rc.d/rc.inet1 script and its /etc/rc.d/rc.inet1.conf configuration file.
Official documentation:
https://docs.slackware.com/slackbook:wifi
AlienBob's Wiki page (maybe more detailed - as also "official"):
https://wiki.alienbase.nl/doku.php?i...in_rcinet1conf

NetworkManager was designed to ease the way Linux users are configuring the network, it looks like it's causing more trouble, unfortunately.
https://en.wikipedia.org/wiki/NetworkManager
 
Old 03-03-2018, 10:08 PM   #23
abga
Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 511

Rep: Reputation: 266Reputation: 266Reputation: 266
Quote:
Originally Posted by Drakeo View Post
you posted you had wifi connection i read it 14.2 is stable but you need to learn linux. learn to create a wifi connection with a profile. Frank 14.2 is up to date . All the tools work . Come on current is a wreck right now. in many areas.
The OP had no network connectivity, neither wired nor wireless, due to the lack of support for his new HW in the Slackware 14.2 kernel. bassmadrigal suggested to either use a new kernel or move to Slackware -current. I came along, backed up what bassmadrigal suggested and detailed that the OP needs a very actual kernel for making his HW work. Instructing the OP to compile a new kernel might have been a very difficult solution, using the kernel that comes with Slackware -current and installing it on Slackware 14.2 could have broken the system and I personally never tried that.
 
Old 03-03-2018, 10:08 PM   #24
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,504
Blog Entries: 3

Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
Wifi: Intel AC8265 been out a long time the firmware is in the slackware kernel 14.2 has the latest firmware.
so lets go from there.
 
Old 03-03-2018, 10:18 PM   #25
abga
Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 511

Rep: Reputation: 266Reputation: 266Reputation: 266
Quote:
Originally Posted by Drakeo View Post
Wifi: Intel AC8265 been out a long time the firmware is in the slackware kernel 14.2 has the latest firmware.
so lets go from there.
Might be, the OP reported that the kernel did not recognize the HW/load any drivers and that the firmware file was not loading.
Intel is also listing 4.6.X as the kernel were the AC8265 support is starting:
https://www.intel.com/content/www/us...etworking.html
 
Old 03-04-2018, 01:16 AM   #26
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 5,209

Rep: Reputation: 2982Reputation: 2982Reputation: 2982Reputation: 2982Reputation: 2982Reputation: 2982Reputation: 2982Reputation: 2982Reputation: 2982Reputation: 2982Reputation: 2982
Quote:
Originally Posted by abga View Post
Instructing the OP to compile a new kernel might have been a very difficult solution, using the kernel that comes with Slackware -current and installing it on Slackware 14.2 could have broken the system and I personally never tried that.
This actually works great. I've been doing it for years (although, I have a custom kernel right now). I would installpkg the kernel-generic, kernel-huge, kernel-modules, and kernel-source packages, which would keep my old kernels intact as well. I would then have a reference in lilo for the old (original) kernel and the new one. I still have the 4.4.14 kernel available in my bootloader along with whatever 4.14.x kernel I have going right now (I'm away from the computer and too lazy to ssh in to check).

Quote:
Originally Posted by Drakeo View Post
Wifi: Intel AC8265 been out a long time the firmware is in the slackware kernel 14.2 has the latest firmware.
so lets go from there.
If you look at the lspci output in the first post, there are many unknown devices, including network devices. Just because the kernel-firmware package includes the right firmware doesn't mean the driver is available in the kernel. As abga posted, support for the AC8265 wasn't added until the 4.6 series and 14.2 has the 4.4 series.

Here's the lspci output from the first post:

Code:
00:00.0 Host bridge: Intel Corporation Sky Lake Host Bridge/DRAM Registers (rev 08)
00:02.0 VGA compatible controller: Intel Corporation Sky Lake Integrated Graphics (rev 07)
00:04.0 Signal processing controller: Intel Corporation Device 1903 (rev 08)
00:14.0 USB controller: Intel Corporation Device 9d2f (rev 21)
00:14.2 Signal processing controller: Intel Corporation Device 9d31 (rev 21)
00:15.0 Signal processing controller: Intel Corporation Device 9d60 (rev 21)
00:15.1 Signal processing controller: Intel Corporation Device 9d61 (rev 21)
00:15.2 Signal processing controller: Intel Corporation Device 9d62 (rev 21)
00:16.0 Communication controller: Intel Corporation Device 9d3a (rev 21)
00:16.3 Serial controller: Intel Corporation Device 9d3d (rev 21)
00:17.0 RAID bus controller: Intel Corporation 82801 Mobile SATA Controller [RAID mode] (rev 21)
00:1c.0 PCI bridge: Intel Corporation Device 9d10 (rev f1)
00:1c.2 PCI bridge: Intel Corporation Device 9d12 (rev f1)
00:1c.4 PCI bridge: Intel Corporation Device 9d14 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Device 9d48 (rev 21)
00:1f.2 Memory controller: Intel Corporation Device 9d21 (rev 21)
00:1f.3 Audio device: Intel Corporation Device 9d70 (rev 21)
00:1f.4 SMBus: Intel Corporation Device 9d23 (rev 21)
00:1f.6 Ethernet controller: Intel Corporation Device 15d7 (rev 21)
01:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 525a (rev 01)
02:00.0 Network controller: Intel Corporation Device 24fd (rev 78)
As you can see by the two items I bolded and colored red, they only show their device ID, which is usually due to a kernel not recognizing them (also, many other device IDs are shown for other components that weren't properly detected).

Once OP installed -current, the lspci output changed dramatically.

Code:
00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Host Bridge/DRAM Registers (rev 08)
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 520 (rev 07)
00:04.0 Signal processing controller: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem (rev 08)
00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)
00:15.0 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #0 (rev 21)
00:15.1 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #1 (rev 21)
00:15.2 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #2 (rev 21)
00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI #1 (rev 21)
00:16.3 Serial controller: Intel Corporation Device 9d3d (rev 21)
00:17.0 RAID bus controller: Intel Corporation 82801 Mobile SATA Controller [RAID mode] (rev 21)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #1 (rev f1)
00:1c.2 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #3 (rev f1)
00:1c.4 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #5 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-LP LPC Controller (rev 21)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (4) I219-LM (rev 21)
01:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS525A PCI Express Card Reader (rev 01)
02:00.0 Network controller: Intel Corporation Wireless 8265 / 8275 (rev 78)
 
1 members found this post helpful.
Old 03-04-2018, 07:29 PM   #27
abga
Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 511

Rep: Reputation: 266Reputation: 266Reputation: 266
Quote:
Originally Posted by bassmadrigal View Post
This actually works great. I've been doing it for years (although, I have a custom kernel right now). I would installpkg the kernel-generic, kernel-huge, kernel-modules, and kernel-source packages, which would keep my old kernels intact as well. I would then have a reference in lilo for the old (original) kernel and the new one. I still have the 4.4.14 kernel available in my bootloader along with whatever 4.14.x kernel I have going right now (I'm away from the computer and too lazy to ssh in to check).
Thanks for confirming this, I might do it myself when I'll need it. Gone are the days when I was constantly updating and compiling manually the 2.6.x (and pre) kernels on Slackware, mainly because of new/exotic HW support and TCP/IP Stack updates. I'm a little concerned to suggest this kernel manual upgrade to the OP, given his fist sentence in the first post "Linux novice user."

Drakeo seemed confused by the OP stating that he has other Linux distros booting on his system, also mentioning Debian, all these giving him Ethernet/WiFi connectivity (successful HW installation). See post #21

@lansoar
I hope you're realizing that you are running an unstable development version of Slackware now and that you might get into some issues with it. Continuing using this Slackware -current version until the stable Slackware 15 will be released (soon enough I hope) would require you to constantly run updates on it.
The updates sequence you should follow, as root, in a console window (preferably not having the X Server running):
- first time only, update the gpg signature:
Code:
slackpkg update gpg
- and afterwards you'll need to run only the following:
Code:
slackpkg update
slackpkg install-new
slackpkg upgrade-all
Should you want to use the stable Slackware 14.2 with a new kernel, you can follow bassmadrigal's confirmation and inline instructions from above and get the actual kernel from Slackware -current. This would require you to install an external network card, that is supported by the kernel from Slackware 14.2, on your system or to get the required kernel packages on an USB stick and install them manually on your system, since with the Slackware 14.2 kernel you won't have network connectivity with your internal network adapters.
 
Old 03-04-2018, 09:53 PM   #28
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 5,209

Rep: Reputation: 2982Reputation: 2982Reputation: 2982Reputation: 2982Reputation: 2982Reputation: 2982Reputation: 2982Reputation: 2982Reputation: 2982Reputation: 2982Reputation: 2982
Quote:
Originally Posted by abga View Post
Thanks for confirming this, I might do it myself when I'll need it. Gone are the days when I was constantly updating and compiling manually the 2.6.x (and pre) kernels on Slackware, mainly because of new/exotic HW support and TCP/IP Stack updates. I'm a little concerned to suggest this kernel manual upgrade to the OP, given his fist sentence in the first post "Linux novice user."
It is likely that upgrading the kernel still wouldn't show all the devices in OP's lspci since the PCI IDs database would still be out of date, but the functionality of the devices should work. To get the PCI IDs to show properly, you'd need to run update-pciids as root.

I definitely don't miss the 2.4/2.6 era kernels...
 
Old 03-06-2018, 08:08 PM   #29
lansoar
LQ Newbie
 
Registered: Feb 2018
Location: earth
Distribution: multi distro
Posts: 13

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by abga View Post

@lansoar
I hope you're realizing that you are running an unstable development version of Slackware now and that you might get into some issues with it. Continuing using this Slackware -current version until the stable Slackware 15 will be released (soon enough I hope) would require you to constantly run updates on it.
Hi,

That's not a problem. Do that all the time with Fedora. :-)

Quote:
Should you want to use the stable Slackware 14.2 with a new kernel, you can follow bassmadrigal's confirmation and inline instructions from above and get the actual kernel from Slackware -current. This would require you to install an external network card, that is supported by the kernel from Slackware 14.2, on your system or to get the required kernel packages on an USB stick and install them manually on your system, since with the Slackware 14.2 kernel you won't have network connectivity with your internal network adapters.
Sounds like fun. I have not attempted such a thing before. (only once with a pkg, never with the kernel) Is there a good primer for bassmadrigal's suggestion? I'm not worried about breaking things. That's what these distros on this machine are for. I take it I'd have to reinstall 14.2_stable as a first step.
 
Old 03-06-2018, 08:12 PM   #30
lansoar
LQ Newbie
 
Registered: Feb 2018
Location: earth
Distribution: multi distro
Posts: 13

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by bassmadrigal View Post
It is likely that upgrading the kernel still wouldn't show all the devices in OP's lspci since the PCI IDs database would still be out of date, but the functionality of the devices should work. To get the PCI IDs to show properly, you'd need to run update-pciids as root.

I definitely don't miss the 2.4/2.6 era kernels...
Thx for this. This explains why my wifi was working in OpenSUSE yet the PCI ID for the 8265 was as generic as it was on 14.2 Stable. I was curious about that. you saved me the research. running update-pciids did the trick.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Order of network interfaces in Slackware 14.2 FlinchX Slackware 2 11-21-2017 08:23 AM
[SOLVED] Cannot get network interfaces up in Slackware 14.1 (32b) Xiano Slackware 18 08-21-2014 07:49 PM
Two network interfaces on Slackware djake Linux - Networking 4 06-29-2008 04:04 PM
[CentOS] Problem with mrtg. No valid network interfaces detected. WojtekO Linux - Networking 1 05-22-2006 01:34 PM
Wireless woes - acx100 module loaded, card detected in harddrake no network device brownb2 Mandriva 1 01-02-2005 05:02 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation

All times are GMT -5. The time now is 12:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration