-   Slackware - Installation (
-   -   Slackware 14.1 wireless "waiting for authorization" (

enine 11-09-2013 01:27 PM

Slackware 14.1 wireless "waiting for authorization"
I just installed 14.1 and was able to connect to my network as root then logged out and in as myself and could not see any wireless interfaces. So I logged out and back in as root and now I'm stuck at "waiting for authorization" and I can't edit the wireless connection, clicking edit nothing happens.

Asus eeePC which has an Atheros card.

enine 11-09-2013 06:17 PM

I'll mark as solved though not the proper way, I installed WICD.

Network manager appears to have a way to make a connection available to all or specific users but I couldn't see any connections as non root.

Drakeo 11-10-2013 01:58 AM

I did a fujitsu net book install this week and I find if the networkmanger is ran as root then you re-log to another user it will not let the none root user use the network manager. So for the install for the friends that will not be using root much.
I mean a full login. I set it up to go to runlevel 4 then had them login that way. No problem after that.
seems if root user makes that connection that pid is under root.

Then I got a call on another machine small net book said there wired wasn't working. I asked if they plugged it into the netbook after it was up and running they said yes. Please remember these are very simple Linux users. I told them just reboot the netbook all will be fine. and it was.

sometimes it just easier then explaining how to restart the network.
I find make sure you configure net and your dhcpd at install and also for wifi enable the /etc/rc.d/rc.networkmanger make it executable. life will be a lot easier on you.
remember this all can be done from pkgtool run Slackware scripts. during install or after.

Drakeo 11-23-2013 12:26 PM

well seems after reading tips and hints in slackware 14.1 it really did not help the situation with the network-manager. You see during an install you run netconfig and it makes /etc/rc.d/rc.inet1 executable and then if you want to make the /etc/rc.d/rc.networkmanager work you make it executable. Well this make thing not work at all. As root you can log in and you have network. but the moment you click the nm-applet it kills the connection on wired.

so many people install wicd and the install scripts on that pretty much make the /etc/rc.d/rc.inet1 /etc/rc.d/rc.networkmanager not used at boot up. this is not really a fix.

All I had to do was chmod 664 /etc/rc.d/rc.inet1
by default networkmanager is set for system so it will do the wired handshake at boot time.
and that firefox bug of disable networkmanager ? I never had that happen to me so hard to trouble shoot it.

Hope this helps some people.

All times are GMT -5. The time now is 10:38 AM.