-   Slackware - Installation (
-   -   Slackware 13.1 installation huge.s stops at kernel_thread_helper (

amitbhatia 04-16-2011 01:57 AM

Slackware 13.1 installation huge.s stops at kernel_thread_helper
I have an old Toshiba Laptop (Mobile Pentium 3, 64MB).
I have Windows XP and Fedora Core 1 installed and working on it.
Want to replace the Fedora Core 1 with Slackware. So tried using a Slackware 13.1 DVD.
At boot prompt I gave:

huge.s noapic acpi=off
It gives messages about loading kernel/bzimage and initrd.img etc and then when it says "Trying to unpack root file system as initramfs", then, quickly there is stack of messages like:

? flush_buffer+0x0/0x9a
? nofill+0x0/0x10
? gunzup+0x0/0x309
? flush_buffer+0x0/0x9a
? error+0x0/0x13
? kernel_init+0x0/0xdb
? pci_get_dev_by_id+0x55/0x80
? match_pci_dev_by_id+0x0/0x70
? pci_get_subsys+0x76/0x90
? printk+0x1d/0x1f
? pci_apply_final_quirks+0xeb/0x10a
? kernel_init_0x0/0xdb
? kernel_init+0x0/0xdb
? populate_rootfs+0x0/0x299
? kernel_init+0x0/0xdb

There is no progress after this message and installation halts.
Once, I also got this line, after a long wait:

Clocksource tsc unstable (delta = -246681047 ns)
But, then again no progress after this line.

I had downloaded the ISO from:
So, it does NOT appear to be 64 bit.

I tried using the same DVD on another newer laptop, again using huge.s and same options, and the install seems to progress further, i.e. I at least get the keyboard map option. So, the image on the DVD is ok.

I have looked at the thread:
But no luck from there.

Anything else I can try to debug the problem further ?

alekow 04-16-2011 05:08 PM


I have an old Toshiba Laptop (Mobile Pentium 3, 64MB).
I think the problem is, taht you don't have enough ram. Read this:
Download the slackware-12.2-mini-install.iso and see if it boots. If it does you can try replacing the cd with your slackware 13.1 disk and progress with installation (this SHOULD work - but i never tried that with two different slackware versions)

OR you can try chroot install from your fedora, if you have any additional disk space available. Though it's not as easy as cdrom install...

amitbhatia 04-17-2011 03:33 PM

Thanks. I will try it out.
Currently I am trying to use the Ubuntu Alternate install for low memory systems.

All times are GMT -5. The time now is 01:00 AM.