-   Slackware - Installation (
-   -   slackware 13.1 blank screen - intel kms modeset? (

back40 05-30-2010 07:26 PM

slackware 13.1 blank screen - intel kms modeset?
Hello all. I just installed 13.1 on my Compaq laptop that has i915 video. After install, it reboots and I'm left at a blank screen. Actually, I've been installing and reinstalling 13.1 for the last couple of days, always stuck at this perplexing blank screen. I can tell it's actually booted, just no display. I can log in as root and type 'reboot' without seeing what I'm typing and it actually reboots.

I found many similar threads on the web, and through all that, discovered that I can get the display back by including "nomodeset" as a kernel parameter when booting. The only problem is then I can't startx because it'll complain that no driver could be configured with modeset (or some message like that).

What I've gathered is that KMS is somehow enabled and setting nomodeset means KMS won't work and X is configured to require KMS. But I'm not sure.

Now, the weird thing is sometimes seems to magically work. Once, I put in video=i915:modeset=1 as a kernel parameter and it worked, and I was in KDE and thrilled. Next day - didn't work anymore. A complete format and reinstall and it rebooted and worked once. Next reboot, no display. Although I certainly wouldn't call this intermittent. 99.99% of the time the display does not show unless I use "nomodeset". Using nomodeset always works to get to a command prompt.

Any ideas what could be causing this strange problem? Something between kernel, i915 and KMS but I'm at my wits end with this one. I just came from Mint 8 which had no issues and before that have used Debian, Gentoo, then Arch, all with no display issues. I have a feeling this is because of kernel and all my other distros were earlier versions.

Any thoughts would be greatly appreciated. For some reason, I am 100% determined to use slackware now :)


damgar 05-30-2010 07:35 PM

Maybe look at this thread to see if it's related?

back40 05-30-2010 11:08 PM

man - I've spent hours reading countless threads about intel i915, kms, and drivers. That one you pointed me to had a fairly brief conclusion that works for me now.

For others benefit, here is the summary:

the intel driver, xf86-video-intel that is installed with Slackware 13.1 is version 2.11.0. What user gapan found in the other thread is that version 2.10.x and beyond require KMS. Apparently KMS has some kernel bug related to intel graphics. This gapan also provided links to packages he build for 2.9 so you don't have to compile yourself.

steps I did to fix it:

1. change lilo/grub to specify the "nomodeset" kernel parameter, this will allow you to boot into your system and see the console at least (but X won't start).

2. uninstall current xf86-video-intel driver

3. download and install intel driver package he created:

4. I rebooted at this point and was able to get into X. You could probably just unload and reload the i915 module instead of rebooting.

Thanks so much damgar for finding probably the one thread I hadn't read yet.

damgar 05-30-2010 11:12 PM

No, thank you for justifying the countless hours I spend reading threads that have no bearing on my actual setups, just in case I need it later. :)

All times are GMT -5. The time now is 01:31 AM.