-   Slackware - Installation (
-   -   Slackware 12.2 not starting with an initrd (

Didier Spaier 12-12-2008 11:11 AM

Slackware 12.2 not starting with an initrd
Hello everybody,

I wanted to give a try to this shiny new release on my laptop...

I installed it with the huge kernel. So far, so good.

Then I tried to use the generic-smp- kernel, with an initrd (because we are on a reiserfs file system).

While booting, at a point of time I get these messages:


Using /lib/modules/
mount: mounting /dev/root on /mnt failed: No such file or directory
ERROR: No /sbin/init found on rootdev (or not mounted). Trouble ahead.
      You can try to fix it. Type 'exit' when things are done
/bin/sh: can't acces tty; job control turned off

Tried a little googling ; somebody had a similar problem with -current but I could not find the answers (the message was only in Google cache):

Yes modules for are installed in /lib/modules (otherwise I couldn't have made the initrd, anyway).

titopoquito 12-12-2008 12:22 PM

Probably you forgot to include the modules for your IDE or SATA driver in the initrd image.

Boot from cd, follow the at the boot prompt given line to use the huge kernel and your root partition so that you can boot into your fresh and shiny Slackware installation :)
Then login and use the script from Eric: to see which modules are missing. Then just create a new initrd.gz.

Didier Spaier 12-12-2008 12:53 PM

Problem solved
Thanks titopoquito.

Anyway I solved my problem this way (after reading mkinitrd and mkinitd.conf manual pages) :

cp /etc/initrd.conf.sample /etc/mkinitrd.conf
nano /etc/mkinitrd.conf

My mkinitrd.conf look like this after editing (edited lines only):



mkinitrd -F

and of course:


did the trick.

I can be wrong but I guess giving the parameters as indicated in this example from README.initrd:
mkinitrd -c -k -m reiserfs

is no more enough, I don't know why.

FYI I first issued following command:
mkinitrd -c -k -m reiserfs

and got the result shown in my first message.

gegechris99 12-15-2008 03:56 PM

Another person got the same issue and it was solved by using the mkinitrd with "full options".

This is the second example mentioned at end of paragraph 3 in file README.initrd

bgeddy 12-20-2008 02:44 PM

Just in case anyone doesn't know there has been an updated package issued here in the patches directory for Slackware 12.2. I recommend installing this.

All times are GMT -5. The time now is 09:34 AM.